Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
3 replies Latest Post - ‏2013-08-23T21:11:11Z by F-DataPower
Aprithvi
Aprithvi
6 Posts
ACCEPTED ANSWER

Pinned topic DPA does not work on datapower

‏2013-03-18T17:04:20Z |
I have created a DP map in my WTX studio. I run it locally using my test file, it works fine. When I deploy on datapower and run using a soap request, the error comes as One or more inputs invalid. How to I turn on the trace for WTX maps on Datapower?

WTX studio version
Version: 8.3.0.2
Build id: 23

Datapower Version
Firmware Rev:XI50.4.0.2.5
Build:211322

I have tried everything. The input is a non XML and the output is an XML.
Updated on 2013-04-04T08:23:41Z at 2013-04-04T08:23:41Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    6184 Posts
    ACCEPTED ANSWER

    Re: DPA does not work on datapower

    ‏2013-04-04T08:23:41Z  in response to Aprithvi
    Hi

    Normal trace will work if you run the map for Datapower on WTX design studio.

    Configure below settings on WTX map designer.
    1. Configure IP and Port in Map designer--->Window-->Preferences-->Transformation extender-->Map-->Datapower.
    2. Select the Mapruntime as WebsphereDatapower in map settings.
    3. Enable trace.

    Configure the above settings and run the map, Map will Execute in Datapower and generate trace.
    • JoeMorganNTST
      JoeMorganNTST
      5 Posts
      ACCEPTED ANSWER

      Re: DPA does not work on datapower

      ‏2013-04-30T16:27:51Z  in response to SystemAdmin

      I'm having exactly this same problem and very, very new to WTX (and not sure how to spell it :-)).  I'm dealing with a WTX file created by someone else and am very reluctant to change it.

      I have an HL7 file that about 10 lines long, so there's almost nothing that can be wrong with it.  A couple of questions:

      1) Is there a way, within WTX, to simply tell WTX to use the sample file as input and show me the trace locally within Design Studio, rather than having to figure out how to navigate a maze of firewalls to the DataPower running the DPA?

      2) I don't see any intuitive way of turning on trace.  When I go to Map Settings, it says MapTrace->Switch->ON.  MapTrace->TraceLocation->Directory is set to Custom, and the Value is my local file system.  Should that be something on DataPower?    I suspect that IS on, but where will I find the file if the test is running within DataPower somehow?

      3) Though I set all of that up as described above, how do I tell WTX (or DataPower) to make the request using the sample file I have that is failing?

       

  • F-DataPower
    F-DataPower
    1 Post
    ACCEPTED ANSWER

    Re: DPA does not work on datapower

    ‏2013-08-23T21:11:11Z  in response to Aprithvi

    Before you move a DPA file to a DataPower appliance, ensure that any trace or backup file options are disabled. These options should only be used when run locally in WTX Design Studio. On DataPower appliances, if trace or backup files did exist, you could not access them. From the latest DataPower documentation (which hasn't changed in several releases), the following limitation exists:

    The WebSphere Transformation Extender engine does not support the following map and card settings:

    • Map settings, MapTrace
    • Map settings, WorkSpace, except for Memory
    • Card settings, Backup
    • Card settings, DocumentVerification, except Well Formed (Xerces Only)

    To use the trace or backup files, run the map locally in IBM® WebSphere Transformation Extender Design Studio.

    Updated on 2013-08-23T21:13:03Z at 2013-08-23T21:13:03Z by F-DataPower