Topic
6 replies Latest Post - ‏2013-03-21T15:21:40Z by SystemAdmin
SystemAdmin
SystemAdmin
8523 Posts
ACCEPTED ANSWER

Pinned topic QM + FTE v7

‏2013-03-18T14:48:31Z |
Hi all.
I have QM and FTE v7 deployed on Windows.

In my environtment i must transfer file namde in pattern $C* - started with $C.
I use Monitor for this issue.
When i simply put $C* in fteCreateMonitor.cmd .... -tr match,$C* .... it isn't work.

I have next question:

What i must put in -tr statment to force it work?
Updated on 2013-03-21T15:21:40Z at 2013-03-21T15:21:40Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    8523 Posts
    ACCEPTED ANSWER

    Re: QM + FTE v7

    ‏2013-03-18T22:14:04Z  in response to SystemAdmin
    > it isn't work.

    That doesn't help us much. What error did it display? What made you thought it didn't work? What investigation did you do?
    • SystemAdmin
      SystemAdmin
      8523 Posts
      ACCEPTED ANSWER

      Re: QM + FTE v7

      ‏2013-03-19T06:44:48Z  in response to SystemAdmin
      Thanks for you reply.

      This is obviously.
      I didn't have any error.

      I put match pattern in -tr key for fteCreateMonitor command. That was -tr match,$C* .
      And nothing happed.

      Files started with $Cbla_bla_bla didn't copy from directory source to destination QM and destination directory.
      This is the reason why i asked you, you know.
      • R_Simons
        R_Simons
        4 Posts
        ACCEPTED ANSWER

        Re: QM + FTE v7

        ‏2013-03-19T14:22:44Z  in response to SystemAdmin
        Post the entire fteCreateMonitor command.
        • SystemAdmin
          SystemAdmin
          8523 Posts
          ACCEPTED ANSWER

          Re: QM + FTE v7

          ‏2013-03-19T14:48:03Z  in response to R_Simons
          That's it

          C:\IBM\WMQFTE\bin\fteCreateMonitor.cmd -ma AGENT_KIE -mm QMKIE -mn KHA_$C -md F:\KHA.0200 -tr match,$C* -pi 5 -pu seconds -mt C:\KHA_$C.txt

          <?xml version="1.0" encoding="UTF-8"?>
          <request xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="4.00" xsi:noNamespaceSchemaLocation="FileTransfer.xsd">
          <managedTransfer>
          <originator>
          <hostName>192.168.5.155</hostName>
          <userID>admin</userID>
          </originator>
          <sourceAgent QMgr="QMKIE" agent="AGENT_KIE"/>
          <destinationAgent QMgr="QMKHA" agent="AGENT_KHA"/>
          <transferSet priority="5">
          <item checksumMethod="MD5" mode="binary">
          <source disposition="delete" recursive="false">
          <file>F:\KHA.0200\$C*</file>
          </source>
          <destination exist="error" type="directory">
          <file>F:\in</file>
          </destination>
          </item>
          </transferSet>
          </managedTransfer>
          </request>
          • R_Simons
            R_Simons
            4 Posts
            ACCEPTED ANSWER

            Re: QM + FTE v7

            ‏2013-03-20T17:33:38Z  in response to SystemAdmin
            Problem #1 - The transfer definition file (XML listed) cannot contain any wildcards in the source file path/name. The transfer definition does not resolve wildcards so FTE will attempt to transfer a file of that exact name. See variable substitution in the Info Center to resolve this.

            Problem #2 - Since the monitor has a wild card specified in the -tr parm, one or more files can meet the match criteria. This means that for each file that matches, a transfer definition file will be submitted for it. If you don't us variable substitution to pass the matched file name to the transfer definition, then the same file could be transfers the number of times the monitor found matches.

            Problem #3 - The transfer definition file has a static file for the destination file name. Based upon problem #2, this would be an issue. Transfer #1 would be successful and all other subsequent transfers would fail because of of the exist parm set to "error". If you wanted to transfer more that one file matched, you will need to use variable substitution to make the destination file name unique for each transfer.

            If your file name does have the "*" in it, then you may need to put the match string in quotes in the fteCreateMonitor command
            • SystemAdmin
              SystemAdmin
              8523 Posts
              ACCEPTED ANSWER

              Re: QM + FTE v7

              ‏2013-03-21T15:21:40Z  in response to R_Simons
              Thank you for help.

              I just use option -pt regex from fteCreateMonitor and pattern -tr "match,\$C.*"