Topic
1 reply Latest Post - ‏2013-03-18T07:00:54Z by SystemAdmin
SystemAdmin
SystemAdmin
1086 Posts
ACCEPTED ANSWER

Pinned topic RSEG1056 Connection refused. Make sure that the datastore server is runnin

‏2013-03-15T15:22:12Z |
RDz client receives error message 'RSEG1056 Connection refused. Make sure that the datastore server is running on host_name under port port_number.' The RSED and JMON tasks are both running. In the rseserver.log we see the following


Thu Mar 14 10:26:09 MDT 2013
INFO acceptSocket: New Logon Request arrived in socket=137: Peer IP address: 206



Thu Mar 14 10:26:09 MDT 2013
INFO getServerPort: port(0) ticket(4303933) userid(NUO3405) displayId(36217) NON



Thu Mar 14 10:26:09 MDT 2013
INFO RseDaemon: selectThreadPoolProcess(): process=903: check PID result=0


Thu Mar 14 10:26:09 MDT 2013
INFO LogHandler: 903:NUO3405:4303933:0:36217


Thu Mar 14 10:26:09 MDT 2013
INFO LogHandler: ProcessId=903: port 47634 assigned to XXXXXXX

Then the client gets the connection refused message. The host_name in the message is correct and the port_number is the one assigned to user XXXXXXX in the above LogHandler message. I can't see any error messages on the z/OS side in SYSLOG, TCPIP, RDz logs, or the RDz tasks. Any idea where or why the connection to the RSE server is getting refused?

Thank you for any assistance provided.
Updated on 2013-03-18T07:00:54Z at 2013-03-18T07:00:54Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1086 Posts
    ACCEPTED ANSWER

    Re: RSEG1056 Connection refused. Make sure that the datastore server is runnin

    ‏2013-03-18T07:00:54Z  in response to SystemAdmin
    Hi Chris,

    we've got these message times sometimes as well.

    Normally the reason is a not working TCP/IP connection, forced by wrong firewall rules or routings between client and host.

    So, check, If your PC-firewall is enabled for the ports, needed by RDz, as well as the firewall from any routers in-between (if involved).

    As the client comes to RSE-Server at least (based on the messages you sent), I guess, the ports for the port-range is not include into your firewall. This would be Variable _RSE_PORTRANGE in your rsed.envvars.

    Hope, it helps,
    Cheers,
    Ingo