Topic
4 replies Latest Post - ‏2013-06-20T10:10:06Z by CBS3_Ian_Wilson
CBS3_Ian_Wilson
CBS3_Ian_Wilson
41 Posts
ACCEPTED ANSWER

Pinned topic Implementing the ICN Custom step processor (sample)

‏2013-03-15T10:27:08Z |
Has anybody implemented the ICN Custom step processor, discussed in this artcle below:
ECM Community Blog: IBM Content Navigator Custom Development

I've deployed this into an ICN 2.0.1 system, using the Jar/JSP files supplied. I've followed the instructions to the letter (although I did launch a workflow from WPXT), but when I attempt to open a work item inside ICN, that references the custom step processor, I get an error "Can not find the step processor to launch" (CIWEB1122).

Other work items with the Default ICN Step processor open fine.

I've also typed in the URL to the SP directly into the browser address bar (http://myserver:9081/navigator/customstepprocessor.jsp) and it loads fine, but obviously without a work item. So that proves that the step processor on the server-side is available.

And I registered the JAR plugin fine in ICN Admin console. If it hadn't been available it wouldn't have appeared.

So it sort of points to client-side issues inside the plugin... Anyone had any joy with this?
Updated on 2013-03-26T12:56:46Z at 2013-03-26T12:56:46Z by damorris
  • damorris
    damorris
    769 Posts
    ACCEPTED ANSWER

    Re: Implementing the ICN Custom step processor (sample)

    ‏2013-03-26T12:56:46Z  in response to CBS3_Ian_Wilson
    Somehow I missed this in my email notifications. I'll see if someone can take a look.
  • CBS3_Ian_Wilson
    CBS3_Ian_Wilson
    41 Posts
    ACCEPTED ANSWER

    Re: Implementing the ICN Custom step processor (sample)

    ‏2013-04-21T09:02:58Z  in response to CBS3_Ian_Wilson

    Again, just wondering if anybody has successfully deployed a custom step processor?

  • Patrick van der Horst
    25 Posts
    ACCEPTED ANSWER

    Re: Implementing the ICN Custom step processor (sample)

    ‏2013-06-20T09:11:41Z  in response to CBS3_Ian_Wilson

    Ian,

    is your problem resolved in the mean time? I didn't try it the article yet, so I am not sure if I will run into the same problem.

    You say you deployed the step processor, but did you also configure it in the PCC, as described in the article in the paragraph "Register the Sample Custom ICN Step Processor"

    • CBS3_Ian_Wilson
      CBS3_Ian_Wilson
      41 Posts
      ACCEPTED ANSWER

      Re: Implementing the ICN Custom step processor (sample)

      ‏2013-06-20T10:10:06Z  in response to Patrick van der Horst

      Patrick,

      Yes, I have resolved this now.

      I knew when I had the problem that it was down to PCC configuration, and had followed the instructions.  (I've written Workflow step processors in the past so am familiar with the mechanism).  Bizarrely, when configuring the Step Proc/Web applications in the IR properties, IBM Content Navigator was appearing with an application description of "100", so my suspicion was that something had gone wrong during installation.

      Anyway, the fix was simple - I rebooted the P8 server, and when it came back up, the "100" app description had miraculously transformed back to "IBM Content Navigator". Wierd.

      And after that, I had no trouble writing the step processor and getting it working inside ICN.