Topic
  • 1 reply
  • Latest Post - ‏2013-03-15T13:04:12Z by tscott
tscott
tscott
17 Posts

Pinned topic RPTA0004E A Test could not be launched on Driver: local host.

‏2013-03-15T03:23:45Z |
I'm running RPT 8.2.1.4_iFix001 in a virtual Win 7 environment. Started up a new test schedule and kept getting the following error:

RPTA0004E A Test could not be launched on Driver: local host. The Test Execution Framework was not able to deliver an Executor.

I tried cleanup of all the temporary spaces ({deployment_root}/AppData/Local/Temp, C:/temp, {project}/bin/test from Navigator view, {project}/src/test, tmp), rebuild project, stop RPT, restart agent controller and then start RPT again, but I kept getting the same error. Thought it might have something to do with firewall since most posts seem to point to this as a possible problem. After further investigation, I found what was causing the issue:

The user groups in the schedule were pointed to "Run this group on the local computer". I changed this to "Run this group on the following locations (1 defined). For the location definition, I used Name=localhost, Hostname=127.0.0.1, Directory=C:\temp.

Woohoo, the schedule started running properly. I think it has partly to do with the fact that I'm running on a virtual machine and RPT may have difficulty picking up the localhost name and IP. Hope this helps if others run into this. Note that this might only work for virtual machines.
Thomas
Updated on 2013-03-15T13:04:12Z at 2013-03-15T13:04:12Z by tscott
  • tscott
    tscott
    17 Posts

    Re: RPTA0004E A Test could not be launched on Driver: local host.

    ‏2013-03-15T13:04:12Z  
    Apparently it happens on Win 7/WinServer 2008 as well. Probably a security thing.