Topic
  • 2 replies
  • Latest Post - ‏2013-03-11T15:23:06Z by SystemAdmin
SystemAdmin
SystemAdmin
374 Posts

Pinned topic <FATAL> Cannot start the Java Virtual Machine. Check your CLASSPATH

‏2013-03-11T04:42:26Z |
I am getting this fatal message when running the Data Model Import. Any help on how to set the CLASSPATH would be appreciated. IDA Version 8.5.0.
Updated on 2013-03-11T15:23:06Z at 2013-03-11T15:23:06Z by SystemAdmin
  • reital
    reital
    58 Posts

    Re: <FATAL> Cannot start the Java Virtual Machine. Check your CLASSPATH

    ‏2013-03-11T06:58:03Z  
    Hi ,

    Can you try fix this error by the following steps:
    #1 Go to your IDA Shared Resources Directory such as C:\Program Files\IBM\SDPShared
    #2 Search "Miti" under "plugins" directory and find the latest version plugin named : com.ibm.datatools.metadata.wizards.miti.win32
    #3 Then go to the dir: MetaIntegration\conf to open the file : MIRSetup.xml
    #4 find the following lines and make sure the path highlighted is correct.
    <RunTime>
    <!--
    Purpose: JRE or JDK Executable
    Value: Executable Full Path (Optional)
    e.g. javaw or java in debug mode
    Default: <Meta Integration Home>\jre\bin\javaw.exe
    Win32 e.g. C:\Program Files\Meta Integration\jre\bin\javaw.exe
    Win32 e.g. ..\..\jre\bin\javaw.exe
    Unix e.g. /usr/MetaIntegration/jre/bin/java
    -->
    <Executable>..\..\..\..\..\IDA7.6.0\jdk\jre\bin\javaw.exe</Executable>

    <!--
    Purpose: JRE or JDK execution Options
    Value: Run time option string (optional)
    Default: "-Xmx256m" to allocate more memory
    -->
    <Options></Options>
    </RunTime>

    Thanks .
    -Tao
  • SystemAdmin
    SystemAdmin
    374 Posts

    Re: &lt;FATAL&gt; Cannot start the Java Virtual Machine. Check your CLASSPATH

    ‏2013-03-11T15:23:06Z  
    • reital
    • ‏2013-03-11T06:58:03Z
    Hi ,

    Can you try fix this error by the following steps:
    #1 Go to your IDA Shared Resources Directory such as C:\Program Files\IBM\SDPShared
    #2 Search "Miti" under "plugins" directory and find the latest version plugin named : com.ibm.datatools.metadata.wizards.miti.win32
    #3 Then go to the dir: MetaIntegration\conf to open the file : MIRSetup.xml
    #4 find the following lines and make sure the path highlighted is correct.
    <RunTime>
    <!--
    Purpose: JRE or JDK Executable
    Value: Executable Full Path (Optional)
    e.g. javaw or java in debug mode
    Default: <Meta Integration Home>\jre\bin\javaw.exe
    Win32 e.g. C:\Program Files\Meta Integration\jre\bin\javaw.exe
    Win32 e.g. ..\..\jre\bin\javaw.exe
    Unix e.g. /usr/MetaIntegration/jre/bin/java
    -->
    <Executable>..\..\..\..\..\IDA7.6.0\jdk\jre\bin\javaw.exe</Executable>

    <!--
    Purpose: JRE or JDK execution Options
    Value: Run time option string (optional)
    Default: "-Xmx256m" to allocate more memory
    -->
    <Options></Options>
    </RunTime>

    Thanks .
    -Tao
    Thanks ... this works.