Topic
  • 6 replies
  • Latest Post - ‏2013-03-15T09:47:49Z by Novikov_Alexander
ogpete
ogpete
6 Posts

Pinned topic ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

‏2013-03-02T14:18:16Z |
Hi Guys,

I have a bunch of X366 / X460 Servers with ServeRAID 8i cards in the field; they are all running local copies of ServeRAID Manager for email based fault reporting and RAID maintenance.

One ServeRAID 8i card started showing occasional errors and was duly swapped out with a new part.
The new card discovered the attached arrays, configured itself and all is well with the server... except ServeRAID Manager does not find the card "No controllers were found in this system" is reported instead.

Upon further investigation I find that the ServeRAID Manager Agent Service stops 5 seconds after it is started - presumably this is why no controllers are found?

BIOS, BMC, CPLD, ServeRAID 8i Firmware & BIOS, ServeRAID Manager and ServeRAID Manager Agent Service are all latest versions.

I have uninstalled and reinstalled ServeRAID Manager V9.30 (including the)Agent Service.

OS is Windows.
Any ideas anyone?

Cheers,

Pete
Updated on 2013-03-15T09:47:49Z at 2013-03-15T09:47:49Z by Novikov_Alexander
  • Novikov_Alexander
    Novikov_Alexander
    6877 Posts

    Re: ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

    ‏2013-03-03T15:43:21Z  
    Dear Pete,

    lets check DSA log. Use DSA Portable Edition and post resulted file *.xml.gz.

    Regards,
    Alexander Novikov
    Russia, Moscow
  • ogpete
    ogpete
    6 Posts

    Re: ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

    ‏2013-03-03T15:52:28Z  
    Dear Pete,

    lets check DSA log. Use DSA Portable Edition and post resulted file *.xml.gz.

    Regards,
    Alexander Novikov
    Russia, Moscow
    Hi Alexander,

    Thanks very much for responding.

    I have DSA installed on this machine already so here is the log:
    Best Regards,

    Peter
  • ogpete
    ogpete
    6 Posts

    Re: ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

    ‏2013-03-08T08:58:18Z  
    Alexander,

    I submitted my DSA Log as requested several days ago - did you get it?

    Many thanks,

    Pete
  • Novikov_Alexander
    Novikov_Alexander
    6877 Posts

    Re: ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

    ‏2013-03-08T09:52:24Z  
    • ogpete
    • ‏2013-03-08T08:58:18Z
    Alexander,

    I submitted my DSA Log as requested several days ago - did you get it?

    Many thanks,

    Pete
    Hi Pete,

    first of all update server's software CPLD code (you have mismatched CPLD parts) and HDDs firmware.

    Regards,
    Alexander Novikov
    Russia, Moscow
  • ogpete
    ogpete
    6 Posts

    Re: ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

    ‏2013-03-08T10:42:14Z  
    Alexander,

    OK, I will do this tonight as I have to take the Server off-line for both these updates.

    Whilst I appreciate that these firmwares are out of step; the weird thing is that this configuration worked fine for months before changing the ServeRAID 8i Card - do you know of any other possible reason that ServeRAID Manager might not see the Controller?

    Thanks again,

    Pete
  • Novikov_Alexander
    Novikov_Alexander
    6877 Posts

    Re: ServeRAID Manager Agent Service will not start after ServeRAID 8i card swap

    ‏2013-03-15T09:47:49Z  
    • ogpete
    • ‏2013-03-08T10:42:14Z
    Alexander,

    OK, I will do this tonight as I have to take the Server off-line for both these updates.

    Whilst I appreciate that these firmwares are out of step; the weird thing is that this configuration worked fine for months before changing the ServeRAID 8i Card - do you know of any other possible reason that ServeRAID Manager might not see the Controller?

    Thanks again,

    Pete
    Hi Pete,

    could you inform us about current status. How now worked SR Manager Agent?

    Regards,
    Alexander Novikov
    Russia, Moscow