• No replies
127 Posts

Pinned topic SFS Server ENC-sfs-0051 Unknown file system name

‏2013-03-01T16:39:56Z |
Am Windows XP SP3, TXSeries trying to apply Fixpak but crashed, advising to see the upgrade log being (have cut blank lines):


Install Log Details:

DATE: Fri Mar 01 10:36:44 EST 2013

ACTION: Register/Unregister Cleanup function in case of user cancelation/interrupt
INFO: Registered pre-install cleanup action

ACTION: Check if user is logged in as root or Administrator
INFO: User is logged in as an Administrator or root

ACTION: Check if TXSeries for Multiplatforms V7.1 is already Installed

ACTION: Check for TXSeries processes
ERROR: Following TXSeries processes were found running on the system:
cicsgc.exe 5756 Console 0 2,564 K

.. I had stopped the CICS stuff as instructed so my Windows XP Services indicates:

cics.REGION1 stopped
cicssfs.SGRAHAM stopped
TXSeries LWI Service stopped
.. and according to cicscp:

C:\ghexe>cicscp -v status all
GRAHAM sfs Stopped
REGION1 region Stopped
mig#temp region Stopped
ERZ096002I/0003: cicscp command completed successfully

C:\ghexe>echo Return code CICS was 0
Return code CICS was 0

C:\ghexe>sfsadmin list files -server /.:/cics/sfs/GRAHAM
1 4164 13/03/01-10:48:16.125000 54048c37 W Call to sfs_ListFiles failed with
status ENC-sfs-0051: Unknown file system name.

C:\ghexe>echo Return code SFS was 1
Return code SFS was 1


.. so seems to be a problem with sfsserver!

Truth be known is that I find nothing attractive about SFS and have yet to make a CICS pgm access a VSAM file thereon, always some kind of prob (unbdoubtably mine). But my DB2 CICS pgms run fine which is OK for my present purposes.

So the fact that my SFS is having a hissy fit isn't a big deal because there's little in it and nothing that's ever worked so I don't even mind losing what's there. Might there be a simple command to 'cleanse'?

I googled cicsgc, got nothing, gooled ENC-sfs-0051 and found info well beyond my skill levels (am an app developer working in isolation at home).

Problem is that it's stopping me upgrading. Any help appreciated, thanks,
Graham Hobbs

P.S. I had no problem on my backup machine, the upgrade worked fine. Clearly the SFS thereon is working, but then it gets very little of a workout.