Topic
  • 13 replies
  • Latest Post - ‏2014-08-06T10:03:52Z by GWA
andryi
andryi
29 Posts

Pinned topic Error at starting RPT 8.3

‏2013-02-21T21:38:23Z |
Hi guys, I've got a problem when I starting the RPT 8.3, I've got this message:

Eclipse: "An error occured. See the log file"

and the log says:

!SESSION 2013-02-21 16:38:43.837
eclipse.buildId=unknown
java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows XP x86-32 20121024_126071 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR3_20121024_1635_B126071
JIT - r11.b02_20120924_26343a
GC - R26_Java726_SR3_20121024_1635_B126071
J9CL - 20121024_126071
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_PE
Framework arguments: -product com.ibm.rational.rpt.product.ide
Command-line arguments: -os win32 -ws win32 -arch x86 -product com.ibm.rational.rpt.product.ide

!ENTRY org.eclipse.osgi 4 0 2013-02-21 16:38:45.728
!MESSAGE Application error
!STACK 1
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:613)
at org.eclipse.ui.internal.WorkbenchPlugin.getSplashShell(WorkbenchPlugin.java:1289)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:613)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
Caused by: java.lang.NoClassDefFoundError: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
at org.eclipse.swt.widgets.Shell.<init>(Shell.java:296)
at org.eclipse.swt.widgets.Shell.internal_new(Shell.java:418)
... 19 more
Caused by: java.lang.ClassNotFoundException: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:506)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:689)
... 21 more
Root exception:
java.lang.NoClassDefFoundError: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
at org.eclipse.swt.widgets.Shell.<init>(Shell.java:296)
at org.eclipse.swt.widgets.Shell.internal_new(Shell.java:418)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:613)
at org.eclipse.ui.internal.WorkbenchPlugin.getSplashShell(WorkbenchPlugin.java:1289)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:613)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
Caused by: java.lang.ClassNotFoundException: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:506)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:689)
... 21 more

I try to fix it, but and I don't know how, so, can someone help me?

Attachments

Updated on 2013-02-22T22:12:38Z at 2013-02-22T22:12:38Z by SystemAdmin
  • petersda
    petersda
    401 Posts

    Re: Error at starting RPT 8.3

    ‏2013-02-21T21:45:24Z  
    Try adding a -clean to the end of the launch. Or, create a new workspace.

    "C:\Program Files\IBM\RPT83\eclipse.exe" -product com.ibm.rational.rpt.product.ide -clean
  • andryi
    andryi
    29 Posts

    Re: Error at starting RPT 8.3

    ‏2013-02-21T22:00:26Z  
    • petersda
    • ‏2013-02-21T21:45:24Z
    Try adding a -clean to the end of the launch. Or, create a new workspace.

    "C:\Program Files\IBM\RPT83\eclipse.exe" -product com.ibm.rational.rpt.product.ide -clean
    Hi petersda, I glad to your answered, but where I put these line? in the file config.ini that is in "(C:\Program Files\IBM\SDP\configuration)" or in another config.ini?

    Thank's for reply petersda
  • petersda
    petersda
    401 Posts

    Re: Error at starting RPT 8.3

    ‏2013-02-21T22:03:36Z  
    • andryi
    • ‏2013-02-21T22:00:26Z
    Hi petersda, I glad to your answered, but where I put these line? in the file config.ini that is in "(C:\Program Files\IBM\SDP\configuration)" or in another config.ini?

    Thank's for reply petersda
    If you right click on the thing that you run and say Properties, there is a target line. Add it to the end of the target.
  • andryi
    andryi
    29 Posts

    Re: Error at starting RPT 8.3

    ‏2013-02-21T22:16:24Z  
    • petersda
    • ‏2013-02-21T22:03:36Z
    If you right click on the thing that you run and say Properties, there is a target line. Add it to the end of the target.
    Thank's for reply petersda, ok, I added the line -clean for the target , but I still have the problem
    !SESSION 2013-02-21 17:16:24.560
    eclipse.buildId=unknown
    java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows XP x86-32 20121024_126071 (JIT enabled, AOT enabled)
    J9VM - R26_Java726_SR3_20121024_1635_B126071
    JIT - r11.b02_20120924_26343a
    GC - R26_Java726_SR3_20121024_1635_B126071
    J9CL - 20121024_126071
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_PE
    Framework arguments: -product com.ibm.rational.rpt.product.ide
    Command-line arguments: -os win32 -ws win32 -arch x86 -product com.ibm.rational.rpt.product.ide -clean

    !ENTRY org.eclipse.osgi 4 0 2013-02-21 17:16:36.983
    !MESSAGE Application error
    !STACK 1
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.ui.internal.WorkbenchPlugin.getSplashShell(WorkbenchPlugin.java:1289)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
    Caused by: java.lang.NoClassDefFoundError: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.swt.widgets.Shell.<init>(Shell.java:296)
    at org.eclipse.swt.widgets.Shell.internal_new(Shell.java:418)
    ... 19 more
    Caused by: java.lang.ClassNotFoundException: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:506)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:689)
    ... 21 more
    Root exception:
    java.lang.NoClassDefFoundError: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.swt.widgets.Shell.<init>(Shell.java:296)
    at org.eclipse.swt.widgets.Shell.internal_new(Shell.java:418)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.ui.internal.WorkbenchPlugin.getSplashShell(WorkbenchPlugin.java:1289)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
    Caused by: java.lang.ClassNotFoundException: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:506)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:689)
    ... 21 more

    and I don't know why, help please
  • SystemAdmin
    SystemAdmin
    5507 Posts

    Re: Error at starting RPT 8.3

    ‏2013-02-22T17:46:53Z  
    • andryi
    • ‏2013-02-21T22:16:24Z
    Thank's for reply petersda, ok, I added the line -clean for the target , but I still have the problem
    !SESSION 2013-02-21 17:16:24.560
    eclipse.buildId=unknown
    java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows XP x86-32 20121024_126071 (JIT enabled, AOT enabled)
    J9VM - R26_Java726_SR3_20121024_1635_B126071
    JIT - r11.b02_20120924_26343a
    GC - R26_Java726_SR3_20121024_1635_B126071
    J9CL - 20121024_126071
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_PE
    Framework arguments: -product com.ibm.rational.rpt.product.ide
    Command-line arguments: -os win32 -ws win32 -arch x86 -product com.ibm.rational.rpt.product.ide -clean

    !ENTRY org.eclipse.osgi 4 0 2013-02-21 17:16:36.983
    !MESSAGE Application error
    !STACK 1
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.ui.internal.WorkbenchPlugin.getSplashShell(WorkbenchPlugin.java:1289)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
    Caused by: java.lang.NoClassDefFoundError: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.swt.widgets.Shell.<init>(Shell.java:296)
    at org.eclipse.swt.widgets.Shell.internal_new(Shell.java:418)
    ... 19 more
    Caused by: java.lang.ClassNotFoundException: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:506)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:689)
    ... 21 more
    Root exception:
    java.lang.NoClassDefFoundError: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.swt.widgets.Shell.<init>(Shell.java:296)
    at org.eclipse.swt.widgets.Shell.internal_new(Shell.java:418)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.ui.internal.WorkbenchPlugin.getSplashShell(WorkbenchPlugin.java:1289)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:613)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
    Caused by: java.lang.ClassNotFoundException: com.mercury.ftjadin.hooks.interfaces.WToolkitHookQTJA
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:506)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:689)
    ... 21 more

    and I don't know why, help please
    I am getting the same error when I install RAD 8.5. The installation works fine but when I try starting RAD it throws this same error. I tried teh clean target and it did not work for me either
  • SystemAdmin
    SystemAdmin
    5507 Posts

    Re: Error at starting RPT 8.3

    ‏2013-02-22T22:12:38Z  
    I am getting the same error when I install RAD 8.5. The installation works fine but when I try starting RAD it throws this same error. I tried teh clean target and it did not work for me either
    I was able to fix this error by removing all jvm hooks from my environment variables. I had Quick test professional installed on my machine recently which adds variables like JAVA_OPTIONS in the environment variables on my computer. Getting rid of those helped solve the issue.
  • srikanthreddychada
    srikanthreddychada
    1 Post

    Re: Error at starting RPT 8.3

    ‏2013-05-09T09:17:12Z  
    I was able to fix this error by removing all jvm hooks from my environment variables. I had Quick test professional installed on my machine recently which adds variables like JAVA_OPTIONS in the environment variables on my computer. Getting rid of those helped solve the issue.

    me also getting the same error when launching IBM RSA4WS 8.5.1 Software, HP QTP was also installed in my system

    Attachments

  • manasbehera
    manasbehera
    1 Post

    Re: Error at starting RPT 8.3

    ‏2013-05-16T08:42:35Z  

    Hi, Can you please create new work space and see what is happening?

  • ivyho
    ivyho
    1 Post

    Re: Error at starting RPT 8.3

    ‏2013-06-10T04:05:53Z  

    me also getting the same error when launching IBM RSA4WS 8.5.1 Software, HP QTP was also installed in my system

    How did you launch the product? via shortcut?

    Did you have admin authority to this HP machine?

    Can you try to invoke the eclipse.exe directly and use "run As administrator" and see if this makes any differences?

     

     

  • Rajeshavanthi
    Rajeshavanthi
    120 Posts

    Re: Error at starting RPT 8.3

    ‏2013-06-10T15:16:15Z  

    Hi

    Looking at this error, I feel that RPT is accessing class libraries from another product that is installed on the same machine.

    Firstly, Kill all Java processes on the machine. Then can you open the "Eclipse.ini"   file located under the SDP folder (C:\Program Files (x86)\IBM\SDP), and check what is the Java path set

                       For example : On my machine, I got the following path  " C:\Program Files (x86)\IBM\SDP\jdk\jre\bin\javaw.exe"

    if found any changes, modify and set the correct path accordingly. Once done clean launch RPT by opening the command prompt shell and executing the following:

                  C:\Program Files (x86)\IBM\SDP>eclipse -initialize

                 C:\Program Files (x86)\IBM\SDP>eclipse -clean

     

    Let me know if this helps.

     

  • mpgorospe
    mpgorospe
    1 Post

    Re: Error at starting RPT 8.3

    ‏2013-09-05T02:05:38Z  

    Hi

    Looking at this error, I feel that RPT is accessing class libraries from another product that is installed on the same machine.

    Firstly, Kill all Java processes on the machine. Then can you open the "Eclipse.ini"   file located under the SDP folder (C:\Program Files (x86)\IBM\SDP), and check what is the Java path set

                       For example : On my machine, I got the following path  " C:\Program Files (x86)\IBM\SDP\jdk\jre\bin\javaw.exe"

    if found any changes, modify and set the correct path accordingly. Once done clean launch RPT by opening the command prompt shell and executing the following:

                  C:\Program Files (x86)\IBM\SDP>eclipse -initialize

                 C:\Program Files (x86)\IBM\SDP>eclipse -clean

     

    Let me know if this helps.

     

    Hi,

     

    I just installed the trial version of the RFT 8.5 version and encountering the same issues. Tried all suggestions above and no luck. The error still exists. Anyone tried and got this issue fix?

    Please help share how to fix this issue.

    Thanks in advance.

    Cheers.

  • norihiko
    norihiko
    1 Post

    Re: Error at starting RPT 8.3

    ‏2013-11-27T23:56:47Z  
    • mpgorospe
    • ‏2013-09-05T02:05:38Z

    Hi,

     

    I just installed the trial version of the RFT 8.5 version and encountering the same issues. Tried all suggestions above and no luck. The error still exists. Anyone tried and got this issue fix?

    Please help share how to fix this issue.

    Thanks in advance.

    Cheers.

    Please take a look at the technote I created which solved similar issue I worked on.

    https://www-304.ibm.com/support/docview.wss?uid=swg21656363

    Regards,

  • GWA
    GWA
    6 Posts

    Re: Error at starting RPT and RFT 8.3

    ‏2014-08-06T10:03:52Z  
    • norihiko
    • ‏2013-11-27T23:56:47Z

    Please take a look at the technote I created which solved similar issue I worked on.

    https://www-304.ibm.com/support/docview.wss?uid=swg21656363

    Regards,

    I had the same with RFT. Uninstalling QTP resolved the issue.