Topic
  • 2 replies
  • Latest Post - ‏2013-03-11T06:59:44Z by SystemAdmin
SystemAdmin
SystemAdmin
402 Posts

Pinned topic Cant Resolve Prompts when Run on Command Line

‏2013-02-21T13:57:03Z |
Hi,
When I try to run report using command prompt I get the following error:
RQP-DEF-0354 The query contains one or more unresolved prompts.
I go to /IBM/tivoli/tipv2Components/TCRComponent/bin and run this command
trcmd.sh -user tipadmin -password tipadmin -run -report "CAMID('VMMProvider:tipadmin')/folder/folder/report" -format PDF -locale en -parameters "Pt_Date=12 Feb 2013" -validateParams true

What could be the possible error?

Thanks,
Regards.
Updated on 2013-03-11T06:59:44Z at 2013-03-11T06:59:44Z by SystemAdmin
  • prasudar
    prasudar
    4 Posts

    Re: Cant Resolve Prompts when Run on Command Line

    ‏2013-02-22T14:04:21Z  
    Hi,

    I can see that the 'report' parameter is NOT correct ie. "CAMID('VMMProvider:tipadmin')/folder/folder/report" is not correct.
    Please find this link to find the right 'search path' for the report: http://pic.dhe.ibm.com/infocenter/tivihelp/v3r1/topic/com.ibm.tivoli.tcr.doc_211/rtcr_check_searchpath.html
    Once you get this, you substitute the same in 'report' parameter and then re-run the report.
    It should work good.

    Hope this helps.

    Thanks & Regards,
    Pradeep
    TCR L3 WW Lead
  • SystemAdmin
    SystemAdmin
    402 Posts

    Re: Cant Resolve Prompts when Run on Command Line

    ‏2013-03-11T06:59:44Z  
    • prasudar
    • ‏2013-02-22T14:04:21Z
    Hi,

    I can see that the 'report' parameter is NOT correct ie. "CAMID('VMMProvider:tipadmin')/folder/folder/report" is not correct.
    Please find this link to find the right 'search path' for the report: http://pic.dhe.ibm.com/infocenter/tivihelp/v3r1/topic/com.ibm.tivoli.tcr.doc_211/rtcr_check_searchpath.html
    Once you get this, you substitute the same in 'report' parameter and then re-run the report.
    It should work good.

    Hope this helps.

    Thanks & Regards,
    Pradeep
    TCR L3 WW Lead
    Hi,
    Thanks for your help.But the error was in the date format.It should be CCYY-MM-DD.