Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
18 replies Latest Post - ‏2013-02-26T13:50:43Z by The_Doctor
SystemAdmin
SystemAdmin
6902 Posts
ACCEPTED ANSWER

Pinned topic No Option to create VIOS from HMC???

‏2013-02-21T11:51:11Z |
Hello experts,

We have a new P710 server and it has come with AIX 6.1 pre-installed with all the resources allocated to it. We have PowerVM standard license and VET and POD license codes. We first wanted to create VIOS server and create LPARs later.

However, going to "Create Logic Partitions" in HMC after selecting desired system, ONLY has two options; those are "AIX/LINUX" and "IBM i".

There is potions for creating VIOS logical partition.

Can someone kindly help me figuring out what is needed to be done in order to create Logical Partition for VIOS?

Thank you in advanced.
Updated on 2013-02-26T13:50:43Z at 2013-02-26T13:50:43Z by The_Doctor
  • The_Doctor
    The_Doctor
    93 Posts
    ACCEPTED ANSWER

    Re: No Option to create VIOS from HMC???

    ‏2013-02-21T13:27:45Z  in response to SystemAdmin
    First off there are no experts here..... there's always someone that knows more. And you really need to stop double posting.

    You said -> There is potions for creating VIOS logical partition.

    Did you really mean to say:

    • there is options for creating VIOS logical partition. OR
    • there is no options for creating VIOS logical partition ?

    Some things to do:

    • from HMC, select the server in question, then select PROPERTIES, then select the CAPABILITIES tab. C&P this screen or be precise & tell us if the line -> Virtual I/O Server Capable <- is set to -> TRUE <-
    • if this line is set to -> FALSE <- this suggests your VET code is not authorized for PowerVM.... so C&P your VET code here & let's confirm it's authorized for PowerVM before we go much further.
    • the VET code you have has been entered properly, hasn't it ?
    • failing this, I'm out of ideas. Your next step will be to open a service call with IBM support.
    • SystemAdmin
      SystemAdmin
      6902 Posts
      ACCEPTED ANSWER

      Re: No Option to create VIOS from HMC???

      ‏2013-02-21T14:04:19Z  in response to The_Doctor
      Pardon me...

      I wrote in little haste.

      Actually it should be "NO". i.e. "there is no options for creating VIOS logical partition"

      As mentioned earlier, system has come with pre-installed AIX 6.1 partition with a profile called "default_profile" and in HMC
      Select the manage system --> Select Configuration --> Create Logic Partitions -->

      Has NO option to create VIOS partition. Only AIX/Linux and IBM i.

      First I want to remove that AIX 6.1 pre-installed partition; service partition.

      Then I want to enable PowerVM features and create a VIOS partition.
      Can you provide me help on this topic, it will be highly appreciated.

      Thanks
      P.S. I noticed that in ASMI, in VET Capability Settings, RPA I/O hosting = False. Does that mean PowerVM features are not activated yet?
      • The_Doctor
        The_Doctor
        93 Posts
        ACCEPTED ANSWER

        Re: No Option to create VIOS from HMC???

        ‏2013-02-21T14:23:35Z  in response to SystemAdmin
        You didn't read my entire post:

        Some things to do:
        • from HMC, select the server in question, then select PROPERTIES, then select the CAPABILITIES tab. C&P this screen or be precise & tell us if the line -> Virtual I/O Server Capable <- is set to -> TRUE <-
        • if this line is set to -> FALSE <- this suggests your VET code is not authorized for PowerVM.... so C&P your VET code here & let's confirm it's authorized for PowerVM before we go much further.
        Do this first before we crawl down another rat hole. Let's see your C&P results (both of them).
      • The_Doctor
        The_Doctor
        93 Posts
        ACCEPTED ANSWER

        Re: No Option to create VIOS from HMC???

        ‏2013-02-21T22:03:56Z  in response to SystemAdmin
        P.S. I noticed that in ASMI, in VET Capability Settings, RPA I/O hosting = False. Does that mean PowerVM features are not activated yet?

        Did some more research on your RPA I/O Hosting = False observation. The public information is somewhat scarce on the subject but I did find one claim in my google searches:
        
        Once the VET code has been entered, the following capabilities will show True in the ASMI: - RPA I/O hosting - Subprocessor partitioning - LPAR creation allowed
        

        So you're probably close to the final answer...... sounds like the VET code currently entered on your 710 is not authorized / licensed for PowerVM. But the sure way to check for this is to do as I suggested ealier ...... go the the HMC, select the p710 server, select PROPERTIES, then select the CAPABILITIES tab. The resulting Capabilities screen will tell you for certain.

        You say you have a VET code for your machine. Post that VET code here & I think we can cut directly to the answer. Either:
        • your current VET code (this is the VET code in your hand, not the VET code entered by manufacturing) was never entered into your 710.
        OR
        • your VET code does not include a license for PowerVM.
        • SystemAdmin
          SystemAdmin
          6902 Posts
          ACCEPTED ANSWER

          Re: No Option to create VIOS from HMC???

          ‏2013-02-22T01:41:16Z  in response to The_Doctor
          Hi,

          Currently I am out from the office, so have no access to HMC right now but, surely check on the facts & points that you made and post the screenshots once I get there.

          As of now, I have VET capabilities settings that I captured from ASMI.

          Surprisingly, it says like this..

          RPA I/O hosting = false
          Subprocessor partitioning = false
          LPAR creation allowed = true

          Here is a screenshot from it...

          Also note that System firmware it at AL740_095 and HMC version is at V7R7.3.5 (and this combination is supported according to IBM)

          Thanks
          • SystemAdmin
            SystemAdmin
            6902 Posts
            ACCEPTED ANSWER

            Re: No Option to create VIOS from HMC???

            ‏2013-02-23T12:31:03Z  in response to SystemAdmin
            The VET Code : 15F287EF8117B503CA1F0000100000417C

            Also there is a POD for activating 8 processors.

            Thanks
            • The_Doctor
              The_Doctor
              93 Posts
              ACCEPTED ANSWER

              Re: No Option to create VIOS from HMC???

              ‏2013-02-23T15:05:27Z  in response to SystemAdmin
              AFAIK, your VET code:
              
              15F287EF8117B503CA1F0000100000417C ^^^^ 0000 = Reset to base defaults (No PowerVM) 1xxx = Express 2c00 = Standard 2c20 = Enterprise
              

              appears to be a valid PowerVM Express code, good for 3 LPARs.

              What did the CAPABILITIES SCREEN say from the HMC ? (again.... on HMC, select Server, Properties, Capabilities Tab).

              Regardless, my guess is:
              • at time of mfg, the assembly line entered a basic default VET code.... with no PowerVM. Not unusual for an entry-level machine to be pre-built & boxed up waiting for an order.
              • since the mfg date, your order came in asking for PowerVM Express. IBM now generates a valid PowerVM Express code for your machine..... and puts it on their web site for you. But, no one has entered this new VET code on your machine, yet.

              Fix is easy.... from HMC, enter your new VET code. (select Server, Capacity on Demand (CoD), PowerVM, Enter Activation Code..... then C&P your VET code....)

              While you're in there, might as well enter your current POD code too.

              It's documented here in this redbook -> http://www.redbooks.ibm.com/redpieces/abstracts/sg247940.html?Open <- see section 1.2.3

              If this doesn't fix it, I'm out of ideas. Next up is a call to IBM support.

              Good luck
              • SystemAdmin
                SystemAdmin
                6902 Posts
                ACCEPTED ANSWER

                Re: No Option to create VIOS from HMC???

                ‏2013-02-23T15:43:35Z  in response to The_Doctor
                Few more questions to ask.. Hope you will help me.. :)

                1. What about the "CoD Activation" in ASMI? Do I need to enter code here also? According to attached screenshot, only RPA I/O hosting value has "false". So do I need to enter VET code or any other thing in here (ASMI) also?

                2. As mentioned earlier, I have one service partition running AIX 6.1 already. I know that VIOS partition ID should be 1 if I am going to use IVM. Therefore, if that is the case, I need to remove that service partition which already has all the system resources allocated and partition ID as 1. Am I correct?

                3. Should I enter VET before deleting service partition or after deletion? If I am NOT going to use HMC, from where I should enter VET code? I guess its through ASMI "CoD Activation", am I correct?
                Thank you in advanced.
                • The_Doctor
                  The_Doctor
                  93 Posts
                  ACCEPTED ANSWER

                  Re: No Option to create VIOS from HMC???

                  ‏2013-02-23T16:54:38Z  in response to SystemAdmin
                  HMC is a nice tool to get into the Service Processor (among other things). But if you don't have an HMC, the ASMI interface is a tool to get into the Service Processor too. The codes (VET, CoD, etc) are kept in the Service Processor. How they get there is up to you.

                  From your screen shot, option 4 subprocessor partitioning is set to "false". This also suggests the VET in your machine is not licensed for PowerVM.

                  1. What about the "CoD Activation" in ASMI? Do I need to enter code here also? According to attached screenshot, only RPA I/O hosting value has "false". So do I need to enter VET code or any other thing in here (ASMI) also?

                  just enter your codes in the ASMI or HMC. Whichever works for you. The codes end up in the same place -> the Service Processor.

                  2. As mentioned earlier, I have one service partition running AIX 6.1 already. I know that VIOS partition ID should be 1 if I am going to use IVM. Therefore, if that is the case, I need to remove that service partition which already has all the system resources allocated and partition ID as 1. Am I correct?

                  At one time, on Power5 & Power6 there was a specific sequence that needed to occur to reset the hypervisor back to some defaults once you've had an HMC connected and now going to IVM only. Not sure if this still applies today on Power7.... need to do some reading.

                  3. Should I enter VET before deleting service partition or after deletion?

                  Just enter your codes now. You want to be working with ALL the correct features enabled...... and not wondering why this or that isn't working properly.

                  If I am NOT going to use HMC, from where I should enter VET code? I guess its through ASMI "CoD Activation", am I correct?

                  Without HMC.... ASMI is only choice, correct.
                  • The_Doctor
                    The_Doctor
                    93 Posts
                    ACCEPTED ANSWER

                    Re: No Option to create VIOS from HMC???

                    ‏2013-02-23T18:27:29Z  in response to The_Doctor
                    ok, I think I found the rights docs to reset your m/c to IVM only without HMC.

                    You really should have IBM support work with you on this..... as you will trash your h/w configuration a few times if you listen to me. Anyway a few questions, first:
                    1. I'm confused. In your 1st few posts the HMC is attached. And it's not attached now ?? Which is correct ? Why would you spend $$ on an HMC and NOT keep it attached to your 710 ?
                    2. in ASMI, (referring to your screen shot) is option 4 (subprocessor partitioning) showing TRUE ? It better be ! (assuming you've entered the codes)
                    3. if the HMC is no longer attached, do you plan to re-attach the HMC in the future ?

                    Remember... you can't be going back & forth between HMC / no HMC and hope to keep your sanity. For this to work, pick a configuration & stay with it.
                    • SystemAdmin
                      SystemAdmin
                      6902 Posts
                      ACCEPTED ANSWER

                      Re: No Option to create VIOS from HMC???

                      ‏2013-02-24T11:32:01Z  in response to The_Doctor
                      Hi,

                      "ok, I think I found the rights docs to reset your m/c to IVM only without HMC"

                      Can just tell me what those documents are? I like know what is in there. Infact, this is a

                      "brand new" server. :)

                      Anyway, I just asked questions on HMC and IVM, just to evaluate what is best for the

                      environment.

                      However, I am bit confused / wondering on one thing. That is, from what I have heard,

                      IBM is putting VET code for PowerVM Express at the time of manufacturing. In other

                      words, powerVM express is built-in and there is no need of entering the license code

                      unless you're going to use PowerVM Standard / Enterprise.

                      If that is true then, both RPA I/O hosting and Subprocessor partitioning values should
                      appear as "True", aren't they? Could you kindly clarify this matter for me?
                      Thank you in advanced.
              • SystemAdmin
                SystemAdmin
                6902 Posts
                ACCEPTED ANSWER

                Re: No Option to create VIOS from HMC???

                ‏2013-02-26T07:12:53Z  in response to The_Doctor
                Hi,

                Attached here are the screenshots of Properties/Capabilities and VET code entering history.
                • The_Doctor
                  The_Doctor
                  93 Posts
                  ACCEPTED ANSWER

                  Re: No Option to create VIOS from HMC???

                  ‏2013-02-26T12:57:17Z  in response to SystemAdmin
                  The last Capabilities screen shot you posted confirms you are NOT licensed for PowerVM
                  • Micro-Partitioning Capable
                  • Virtual I/O Server Capable
                  lines are both FALSE.

                  Looks like you entered the POD code ok.... BUT did you enter your new VET code ?

                  Once you do enter the VET code, those two lines will turn to TRUE..... and you're good to go.

                  If the lines still remain at FALSE, you have a bigger problem & you need to contact IBM service.
                  • SystemAdmin
                    SystemAdmin
                    6902 Posts
                    ACCEPTED ANSWER

                    Re: No Option to create VIOS from HMC???

                    ‏2013-02-26T13:11:02Z  in response to The_Doctor
                    Yes, I entered the VET code that I obtained from http://www-912.ibm.com/pod/pod through HMC by going to Capacity on Demand (CoD) --> PowerVM --> Enter Activation Code for the targeted server.

                    I tried the same thing (i.e. entering VET code) through ASMI as well by going to On Demand Utilities --> CoD Activation. But nither worked.

                    The attached images show code entering history and acceptance by HMC.
                    Do you have any idea / clue on what has gone wrong here?
                    Thank you in advanced.
                    • The_Doctor
                      The_Doctor
                      93 Posts
                      ACCEPTED ANSWER

                      Re: No Option to create VIOS from HMC???

                      ‏2013-02-26T13:50:43Z  in response to SystemAdmin
                      AFAIK, you've entered the VET code correctly. Your log seems to be missing several entries but I'm unable to offer you an explanation.

                      FWIW, I was expecting your log to look similar to mine (see the attached screen shot).

                      Looks like IBM service is your next stop.
              • SystemAdmin
                SystemAdmin
                6902 Posts
                ACCEPTED ANSWER

                Re: No Option to create VIOS from HMC???

                ‏2013-02-26T07:17:18Z  in response to The_Doctor
                FYI
              • SystemAdmin
                SystemAdmin
                6902 Posts
                ACCEPTED ANSWER

                Re: No Option to create VIOS from HMC???

                ‏2013-02-26T07:20:17Z  in response to The_Doctor
                FYI
  • DorukAksoy
    DorukAksoy
    7 Posts
    ACCEPTED ANSWER

    Re: No Option to create VIOS from HMC???

    ‏2013-02-21T13:51:44Z  in response to SystemAdmin
    Hi,

    Does your box have the POWER VM ENT. license ?
    You can check from Server Properties/Capabilities :

    Virtual I/O Server Capable True