Topic
1 reply Latest Post - ‏2013-02-18T21:01:22Z by SystemAdmin
SystemAdmin
SystemAdmin
1143 Posts
ACCEPTED ANSWER

Pinned topic "Object reference not set to an instance of an object." with reference.

‏2013-02-18T15:16:22Z |
I'm having trouble with the 2.90 Informix Client SDK dll with a ASP.NET 2.0 application. I'm getting abandoned mutex errors and the connection intermittently hangs until application pool recycles. I read that this was an issue with that version of the DLL (info here: http://publib.boulder.ibm.com/infocenter/idshelp/v10/index.jsp?topic=/com.ibm.relnotes.doc/tc6_r1/defects.html) and decided to upgrade to 3.50. Unfortunately I'm having trouble adding the new dll to the project.

As a test, I created a new web site. I added the 3.50 Client SDK's IBM.Data.Informix.Dll to the website's BIN folder, added a reference to it, and added a blank Default.aspx. As soon as the reference to the DLL is added, I get this error when building:

Error 2 Object reference not set to an instance of an object.

Additionally, I get this warning if the Default.aspx file is open:

Warning 1 d:\websites\informixtest4\Default.aspx: ASP.NET runtime error: Object reference not set to an instance of an object. d:\websites\informixtest4\Default.aspx 1 1 informixtest4

Since I've not yet written a single line of code, I'm not sure what could be causing this. It appears to either be a problem with the dll or the reference, but I haven't been able to find a solution.

Any suggestions?
Updated on 2013-02-18T21:01:22Z at 2013-02-18T21:01:22Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1143 Posts
    ACCEPTED ANSWER

    Re: "Object reference not set to an instance of an object." with reference.

    ‏2013-02-18T21:01:22Z  in response to SystemAdmin
    I'm not sure why this resolved the issue, but I tried installing the 32bit version (the OS is Server 2008 R2 64bit). The web site worked fine with the dll from the 32bit installation. I'll continue to use this as I'd tried for a couple of days to find a way to make the 64bit version work, but had no luck at all.