Topic
  • 3 replies
  • Latest Post - ‏2014-11-06T11:39:38Z by Vijay_tivoli
SystemAdmin
SystemAdmin
9855 Posts

Pinned topic Demo EAI Server problem.

‏2013-02-18T14:21:50Z |
Hello, I've followed these steps to install and deploy the DemoEAIserver in my SAM-WEB solution (ALL AT THE SAME SERVER); but it's not working.

1. I've modified the eai-auth stanza entry: eai-auth= HTTP
2. I've met the requirements: WAS 5.1.1 or later, TAM e-Business JRE and ADKs.
3. I've created an empty file 'eaidemo.conf' under the 'c:\Progra~1\tivoli\pdwebrte\eai_demo' directory and run the command: svrsslcfg -config -f "c:\Program Files\tivoli\pdwebrte\eai_demo\eaidemo.conf" -d "c:\Progra~1\tivoli\pdwebrte\eai_demo" -n eai_demo -s remote -r 1234
4. Locate, install and start the DemoEAIServer.EAR on the WAS.
5. Create a tcp junction to the DemoEAIServer app named /eai, an ACL named unauth that allows unauth access, and attach the ACL to the junction.
6 Configure the URL trigger in webseald.conf: eai-trigger-url = /eai/eaidemo/Simple*
7. Configure this parameter in local-response-redirect: local-response-redirect-url = /eai/eaidemo/TAMOperationHandler
8. (Web browser) Access the DemoEAIServer conf page at s://localhost/eai/eaidemo/eaiconfig.jsp and checked this.
  • The “headers” in this file matches with the WebSEAL configuration file headers and jrte-cfg-url: Progra~1\IBM\WebSphere\AppServer\java\jre\PdPerm.properties

When I try to access a resourse, It doesn't ask me for authentication, and only shows me the webseal form. What's missing?

Thanks.
Updated on 2013-02-25T20:58:53Z at 2013-02-25T20:58:53Z by SystemAdmin
  • hans.vandeweghe@be.ibm.com
    33 Posts

    Re: Demo EAI Server problem.

    ‏2013-02-18T14:41:24Z  
    Hello,

    Can you clarify what you WebSEAL form you are seeing when you say you're not asked to authenticate?
    Are you seeing the normal WebSEAL forms login page?
    I suspect you may be looking for the LRR example page.
    Do you have local-response-redirection enabled - "enable-local-response-redirect = yes" ?

    Sincerely,
    Hans Vandeweghe
  • SystemAdmin
    SystemAdmin
    9855 Posts

    Re: Demo EAI Server problem.

    ‏2013-02-25T20:58:53Z  
    Hello,

    Can you clarify what you WebSEAL form you are seeing when you say you're not asked to authenticate?
    Are you seeing the normal WebSEAL forms login page?
    I suspect you may be looking for the LRR example page.
    Do you have local-response-redirection enabled - "enable-local-response-redirect = yes" ?

    Sincerely,
    Hans Vandeweghe
    Hello,

    Thanks for your help, I've advanced a little bit, when I said that did't ask to authenticate is that I was seeing the normal WebSEAL forms login page. But after enabling this entry -> "enable-local-response-redirect = yes", shows me the EAIDemo authentication forms login page; but also this message after submitting the user: "If you can read this text, you've either misconfigured EAI or you're not going through a WebSEAL junction".
    I'm trying to access to a resourse that is protected by a junction and another ACL, so if asks me for authentication is because is going through the junction, so what's missing in the EAI configuration.

    Thanks.
    MLeon.
  • Vijay_tivoli
    Vijay_tivoli
    1 Post

    Re: Demo EAI Server problem.

    ‏2014-11-06T11:39:38Z  
    Hello,

    Thanks for your help, I've advanced a little bit, when I said that did't ask to authenticate is that I was seeing the normal WebSEAL forms login page. But after enabling this entry -> "enable-local-response-redirect = yes", shows me the EAIDemo authentication forms login page; but also this message after submitting the user: "If you can read this text, you've either misconfigured EAI or you're not going through a WebSEAL junction".
    I'm trying to access to a resourse that is protected by a junction and another ACL, so if asks me for authentication is because is going through the junction, so what's missing in the EAI configuration.

    Thanks.
    MLeon.

    Hello Admin,

    I am looking for TAM EAI authentication for smart card application. Could you please share me the war file and configuration details if you have already.  And also i would like to get DemoEAIServer.EAR file. Please send me the link for download these files. It would be helpful me to develope for my project.