IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 4 replies
  • Latest Post - ‏2013-02-19T13:16:56Z by bwa
bwa
bwa
47 Posts

Pinned topic com.ibm.websphere.startupservice.AppStartUp missing

‏2013-02-18T06:28:44Z |
Tried the lastes Liberty Porfile Beta and got this message

The user-provided class "com.ibm.websphere.startupservice.AppStartUp" needed by the EnterpriseBean could not be found or loaded.

Is StartUp Beans not supported in the Beta maybe? Is there other way to do this ?

/Bjørn-Willy
  • SystemAdmin
    SystemAdmin
    590 Posts

    Re: com.ibm.websphere.startupservice.AppStartUp missing

    ‏2013-02-19T02:57:57Z  
    Hi,

    The Liberty profile does not support Startup Beans. Startup beans require the use of EJB 2.1 beans which are not supported by the Liberty profile. The capability provided by startup beans can be achieved using the EJB 3.1 standard javax.ejb.Startup and javax.ejb.Singleton annotations.

    Thanks
    Alasdair

    Message was edited by: Alasdair Nottingham
  • bwa
    bwa
    47 Posts

    Re: com.ibm.websphere.startupservice.AppStartUp missing

    ‏2013-02-19T07:19:50Z  
    Thanks. Great !

    /Bjørn-Willy
  • bwa
    bwa
    47 Posts

    Re: com.ibm.websphere.startupservice.AppStartUp missing

    ‏2013-02-19T11:23:29Z  
    So, I created a simple EJB 3.1 project with RAD 8.5.1 and deployed it on the Next Alpha

    but get this message. MDB not supported ?

    ERROR CNTR4002E: The ejb31EJB.jar EJB module in the ejb31Test application failed to start. The exception message was: com.ibm.ws.exception.RuntimeError: com.ibm.ejs.container.ContainerException: Failed to initialize BeanMetaData instance - caught Throwable; nested exception is:
    java.lang.UnsupportedOperationException: Message-Driven beans are not supported in the current environment : MDBBean
    /Bjørn-Willy
  • bwa
    bwa
    47 Posts

    Re: com.ibm.websphere.startupservice.AppStartUp missing

    ‏2013-02-19T13:16:56Z  
    Ups, my error.... Did not have the mdb-3.1 installed, only ejblite-3.1 ...

    Works now ...

    /BWA