Topic
3 replies Latest Post - ‏2013-02-16T13:48:12Z by SystemAdmin
SystemAdmin
SystemAdmin
6184 Posts
ACCEPTED ANSWER

Pinned topic Error when trying to run WTX map in Sterling Integrator business process

‏2013-02-15T16:00:43Z |
Windows Server 2008 R2
Sterling Integrator 5.3.2
WTX 8.4.0.3
WTX4IS 8.4.0.3

Has anyone seen the error "Loading map failed - Native function: CMpiMapSet::CMpiMapSet" when attempting to execute a Sterling B2B Integrator business process running WTXMapService. I'm merely trying to run the trivial test map, text_text.mmc, that ships with the WTX4IS example, WTX_IVT_Example_For_SIB2B, within a simple business process that consists of Start-WTXMapService-Stop. The map was deployed to SI from WTX and can be executed successfully on SI from WTX.

Process Data:

Process Name: Test3_jjd Instance ID: 119815
Service Name: WTXMapService
<?xml version="1.0" encoding="UTF-8"?>
<ProcessData>
<PrimaryDocument SCIObjectID="582:26586:13ca6ba1c55:PFGDSMBBDEV001:node1"/>
<Prev_NotSuccess_Adv_Status>Loading map failed - Native function:CMpiMapSet::CMpiMapSet
</Prev_NotSuccess_Adv_Status>
</ProcessData>

Process: Test3_jjd: BPML Specification:

<process name = "Test3_jjd">
<operation name="WTX Map">
<participant name="WTXMapService"/>
<output message="WTXMapServiceTypeInputMessage">
<assign to="." from="*"></assign>
<assign to="MapName">text_text</assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
</process>
Updated on 2013-02-16T13:48:12Z at 2013-02-16T13:48:12Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    6184 Posts
    ACCEPTED ANSWER

    Re: Error when trying to run WTX map in Sterling Integrator business process

    ‏2013-02-15T20:53:58Z  in response to SystemAdmin
    Can you go to SI Dashboard , there should be a Logs sections. Under logs can you enable WTX Extender log. and run your map.

    This should create a WTX logger file under <SI Install> logs. The WTX log should provide the details on where the map is trying to load from.
    • SystemAdmin
      SystemAdmin
      6184 Posts
      ACCEPTED ANSWER

      Re: Error when trying to run WTX map in Sterling Integrator business process

      ‏2013-02-15T22:05:42Z  in response to SystemAdmin
      Thanks, I was unaware of the need to turn the SI WTX log on. Unfortunately, the SI WTX log isn't generated when I run the business process nor is any SI log updated. The SI WTX log is generated when I execute the map from WTX on SI.