Topic
4 replies Latest Post - ‏2013-02-19T12:30:58Z by Jacek_Laskowski
Jacek_Laskowski
Jacek_Laskowski
133 Posts
ACCEPTED ANSWER

Pinned topic bundle org.eclipse.gmf.runtime.emf.type.core missing for WDT 9.0 BETA?

‏2013-02-15T12:00:23Z |
Hi,

I've been trying to install WebSphere Application Server Developer Tools for Eclipse V9.0 BETA and all I got so far was the following error:

Cannot complete the install because one or more required items could not be found. Software being installed: Web Development Tools 9.0.0.v20130201_1811 (com.ibm.wdt.webtools.top.feature.feature.group 9.0.0.v20130201_1811) Missing requirement: Model Plug-in 7.0.400.v20121124_0213 (com.ibm.etools.webtools.model 7.0.400.v20121124_0213) requires 
'bundle org.eclipse.gmf.runtime.emf.type.core [1.0.0,2.0.0)' but it could not be found Cannot satisfy dependency: From: Rich Page Editor - Dojo extensions 1.1.0.v20121124_0213 (com.ibm.etools.rpe.dojo 1.1.0.v20121124_0213) To: bundle com.ibm.etools.webtools.model [7.0.300,8.0.0) Cannot satisfy dependency: From: Dojo Web Tools 1.1.0.v20130117_0011 (com.ibm.etools.webtools.dojo.feature.feature.group 1.1.0.v20130117_0011) To: com.ibm.etools.rpe.dojo [1.1.0.v20121124_0213] Cannot satisfy dependency: From: Web Development Tools 9.0.0.v20130201_1811 (com.ibm.wdt.webtools.top.feature.feature.group 9.0.0.v20130201_1811) To: com.ibm.etools.webtools.dojo.feature.feature.group 1.1.0


Does anyone know how to fix it? I'm on Mac OS with Java 1.7.0 if that matters.

Jacek
Japila :: verba docent, exempla trahunt
  • SystemAdmin
    SystemAdmin
    590 Posts
    ACCEPTED ANSWER

    Re: bundle org.eclipse.gmf.runtime.emf.type.core missing for WDT 9.0 BETA?

    ‏2013-02-15T14:13:17Z  in response to Jacek_Laskowski
    Which version of Eclipse are you using for installing the beta? This beta version only supports Eclipse Eclipse 4.2.2 RC1 for Java EE Developers (Juno SR2 RC1). In case you are using a different version of Eclipse, please installed the required version and try again.

    Here is the link to the detailed instructions:
    https://www.ibm.com/developerworks/mydeveloperworks/blogs/wasdev/entry/download_wlp_eap?lang=en
    You can find the link to the download of the required version of Eclipse on the page.

    Elson
    • Jacek_Laskowski
      Jacek_Laskowski
      133 Posts
      ACCEPTED ANSWER

      Re: bundle org.eclipse.gmf.runtime.emf.type.core missing for WDT 9.0 BETA?

      ‏2013-02-15T22:52:28Z  in response to SystemAdmin
      Hi,

      I'd swear I used the proper version of Eclipse (and still think I was and the issue was an old workspace that causes some plugins problems). I installed Eclipse IDE + WDT again on another laptop and it works fine now. Thanks!

      Jacek
      Japila :: verba docent, exempla trahunt
  • SystemAdmin
    SystemAdmin
    590 Posts
    ACCEPTED ANSWER

    Re: bundle org.eclipse.gmf.runtime.emf.type.core missing for WDT 9.0 BETA?

    ‏2013-02-15T22:14:56Z  in response to Jacek_Laskowski
    Hi Jacek,

    My system is Linux with OpenJDK (IcedTea 7). I was able to install the 4.2.2 milestone and then the WDT 9 Beta.

    After installing WDT, Eclipse began to experience frequent crashes. I installed the IBM JRE 1.7 and used it to run Eclipse and the crashing stopped. I hope your experience is better.

    Regards,
    -james.
  • Jacek_Laskowski
    Jacek_Laskowski
    133 Posts
    ACCEPTED ANSWER

    Re: bundle org.eclipse.gmf.runtime.emf.type.core missing for WDT 9.0 BETA?

    ‏2013-02-19T12:30:58Z  in response to Jacek_Laskowski
    Hi,

    I've finally sorted it out! It happened that Eclipse Juno SR2 CR1 doesn't much like Java 8 and blows up upon installing the WDT tools. You should be using Java 7 instead. You've been warned.

    See the blog entry No joy to install WebSphere Developer Tools for Eclipse V9.0 Beta in Eclipse Juno SR2 RC1 with Java 8 Build b77 under Mac OS for more details.

    Jacek
    Japila :: verba docent, exempla trahunt