Topic
3 replies Latest Post - ‏2013-02-18T19:30:42Z by JMW98
pendyala.ravichandra
39 Posts
ACCEPTED ANSWER

Pinned topic How to create friendly urls for hidden pages in wps8.0

‏2013-02-15T07:26:05Z |
Hi 2 All,
I'm using wps8.0 and I need to create friendly url for a page and it should not be displayed on the navigation state (hidden page), so How to create a friendly url for the hidden page

Plz help me,

Thanks and Regards,
Ravichandra.
Updated on 2013-02-18T19:30:42Z at 2013-02-18T19:30:42Z by JMW98
  • MJonker
    MJonker
    140 Posts
    ACCEPTED ANSWER

    Re: How to create friendly urls for hidden pages in wps8.0

    ‏2013-02-15T08:28:24Z  in response to pendyala.ravichandra
    You can just set the friendly URL field, but you need to make sure that the page has the Hidden parameter set to true (use XML Access)

    <parameter name="com.ibm.portal.Hidden" type="string" update="set"><![CDATAtrue]></parameter>

    When you now change the URL in your browser to the friendly URL, the page is displayed, but the not part of the navigation (if you have the correct theme implementation similar to the Portal80 theme)
    • SystemAdmin
      SystemAdmin
      30895 Posts
      ACCEPTED ANSWER

      Re: How to create friendly urls for hidden pages in wps8.0

      ‏2013-02-15T10:13:39Z  in response to MJonker
      Following URL could contain useful info.

      http://infolib.lotus.com/resources/portal/8.0.0/doc/en_us/PT800ACD004/wcm/wcm_config_wcmviewer_workfriendly.html
      • JMW98
        JMW98
        1082 Posts
        ACCEPTED ANSWER

        Re: How to create friendly urls for hidden pages in wps8.0

        ‏2013-02-18T19:30:42Z  in response to SystemAdmin
        If you put this page under the Hidden Pages label (uniquename=ibm.portal.HiddenPages), be aware that Friendly URLs require that every node (page/label) in the path from the context root must have a friendly URL (e.g. http://.../wps/myportal/friendly1/friendly2/friendly3). ibm.portal.HiddenPages does not have a friendly URL, by default. So, you could either

        a. give it one and address the page by something like http://.../wps/myportal/hiddenpages/friendlyA

        -or-

        b. use a URL mapping instead and address the page by something like http://.../wps/myportal/map1