Topic
  • 4 replies
  • Latest Post - ‏2013-02-14T20:36:52Z by lisaw
SystemAdmin
SystemAdmin
1485 Posts

Pinned topic eXtreme Scale 8.6.0.0 Catalog Server on Liberty fails to start with XIO

‏2013-02-13T04:40:50Z |
When we try to bring up eXtreme Scale Catalog Server on Liberty Profile using XIO transport, it is failing with following Exception

Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:80)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57)
at java.lang.reflect.Constructor.newInstance(Constructor.java:539)
at com.ibm.websphere.objectgrid.server.ServerFactory.initialize(ServerFactory.java:384)
... 41 more
Caused by: java.lang.NoClassDefFoundError: com.ibm.wsspi.runtime.ThreadPoolAlreadyKnownException
at java.lang.J9VMInternals.verifyImpl(Native Method)
at java.lang.J9VMInternals.verify(J9VMInternals.java:85)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:162)
at com.ibm.ws.objectgrid.server.impl.ServerImpl.startXIO(ServerImpl.java:3454)
at com.ibm.ws.objectgrid.server.impl.ServerImpl.<init>(ServerImpl.java:840)
... 46 more
Caused by: java.lang.ClassNotFoundException: com.ibm.wsspi.runtime.ThreadPoolAlreadyKnownException
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:467)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
Here the details about the platform

OS : Windows 7
JVM : IBM JDK 7
Liberty Profile : WAS LP 8.5.0.1
eXtreme Scale (on Liberty Profile) : 8.6.0.0

It works fine when I use ORB (default transport)
Updated on 2013-02-14T20:36:52Z at 2013-02-14T20:36:52Z by lisaw
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: eXtreme Scale 8.6.0.0 Catalog Server on Liberty fails to start with XIO

    ‏2013-02-13T12:26:03Z  
    I tried the same with latest fix pack WXS 8.6.0.1 on Liberty 8.5.0.1 and the issue is still the same.
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: eXtreme Scale 8.6.0.0 Catalog Server on Liberty fails to start with XIO

    ‏2013-02-13T20:35:30Z  
    I tried the same with latest fix pack WXS 8.6.0.1 on Liberty 8.5.0.1 and the issue is still the same.
    Hello Vasu,

    Check if you have jvm.options file in WLP_HOME/etc or in the failing server folder.

    jvm.options file in WLP_HOME/etc should have the following two lines with WLP_HOME as appropriate to your environment:

    -Dorg.osgi.framework.bootdelegation=com.ibm.wsspi.runtime
    -Djava.endorsed.dirs=<WLP_HOME>/wxs/lib/endorsed

    If you do not have the above, please add and give a try.

    If you also have a jvm.options file in the server root, ensure above lines are included in there as well.

    Thank you,
    Rama Boggarapu
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: eXtreme Scale 8.6.0.0 Catalog Server on Liberty fails to start with XIO

    ‏2013-02-14T01:56:18Z  
    Hello Vasu,

    Check if you have jvm.options file in WLP_HOME/etc or in the failing server folder.

    jvm.options file in WLP_HOME/etc should have the following two lines with WLP_HOME as appropriate to your environment:

    -Dorg.osgi.framework.bootdelegation=com.ibm.wsspi.runtime
    -Djava.endorsed.dirs=<WLP_HOME>/wxs/lib/endorsed

    If you do not have the above, please add and give a try.

    If you also have a jvm.options file in the server root, ensure above lines are included in there as well.

    Thank you,
    Rama Boggarapu
    Great. That worked. Thanks Rama.

    • Vasu
  • lisaw
    lisaw
    101 Posts

    Re: eXtreme Scale 8.6.0.0 Catalog Server on Liberty fails to start with XIO

    ‏2013-02-14T20:36:52Z  
    Great. That worked. Thanks Rama.

    • Vasu
    Here's instructions how you install Liberty + WXS on our caching community, Getting Started with Liberty Profile.

    You need to run the java -jar wxs-wlp_###.jar command to install otherwise the jvm.options will be missing. I'm unsure if that caused your issue, but I've seen that behavior happen. Hopefully, both of these solutions help anyone else seeing this problem.

    • Lisa

    Websphere eXtreme Scale Development