Topic
  • 2 replies
  • Latest Post - ‏2013-02-14T03:34:07Z by SystemAdmin
SystemAdmin
SystemAdmin
9029 Posts

Pinned topic Help Needed Updating Portlet

‏2013-02-12T05:54:40Z |
Dear Masters and Friends..
Please forgive my ignorance and stupidity, but i'm really new in this, and my boss want me to modify this portlet **see Attachment1**. The problem is that it looks like the year was hardcoded.

Things i've done :
1. Got the .war file, installed WPF 7, found the .model, but the wpf can't open the .model in model editor. it says "Project does not support current WebSphere Portlet Factory version and cannot be used"
2. Tried to edit the .model in text mode, update the .war through administrator, an error occurred when i tried opening the page. it says "The Generation Engine did not produce a WebApp for btpn/report."

What are the solution for both problems?

I am currently looking for WPF 6 but can't seem to find it. anyone knows where to find one?

thanks in advance.
Updated on 2013-02-14T03:34:07Z at 2013-02-14T03:34:07Z by SystemAdmin
  • mburati
    mburati
    2570 Posts

    Re: Help Needed Updating Portlet

    ‏2013-02-12T16:12:29Z  
    Are you using the original WPF6 project or did you create a new project with WEF 7 and then copy the model into it, or are you trying to use the WEF/WPF 7 designer over the WPF6 workspace? If the latter, there is usally an option to "upgrade" the project if you right click on the project in the project explorer. If you're just copying the model into a WEF7.x project, then I wouldn't have expected that particular error.

    If this is blocking you, you may want to contact customer support and have them help you resolve this version issue.

    I hope that info helps,
    ..Mike Burati
    http://www-10.lotus.com/ldd/pfwiki.nsf/
    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM.
  • SystemAdmin
    SystemAdmin
    9029 Posts

    Re: Help Needed Updating Portlet

    ‏2013-02-14T03:34:07Z  
    • mburati
    • ‏2013-02-12T16:12:29Z
    Are you using the original WPF6 project or did you create a new project with WEF 7 and then copy the model into it, or are you trying to use the WEF/WPF 7 designer over the WPF6 workspace? If the latter, there is usally an option to "upgrade" the project if you right click on the project in the project explorer. If you're just copying the model into a WEF7.x project, then I wouldn't have expected that particular error.

    If this is blocking you, you may want to contact customer support and have them help you resolve this version issue.

    I hope that info helps,
    ..Mike Burati
    http://www-10.lotus.com/ldd/pfwiki.nsf/
    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM.
    I was trying to use WPF 7 over WPF 6 workspace.
    I imported the file in .war, not copying it to a WEF7.x project.
    I also tried the update project solution, but after i right clicked the project, the update project was grey and can't be clicked.

    With all that being said, my main problem, which is adding the year in the combo-box, has finished. I found the .model file using WPF 7, open with text editor, add the year, export it, update the corresponding .war file. not a permanent solution, but to make it parameterized is another story.

    I will contact some friends at IBM to resolve this version issue.

    Thank you for your reply mburati,
    Abdul Hakim Muzani