Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2013-02-13T16:19:38Z by SystemAdmin
SystemAdmin
SystemAdmin
51 Posts
ACCEPTED ANSWER

Pinned topic x240 nodes, EN4093 Switch, tagged vlans and pxe boot

‏2013-02-11T16:03:54Z |
Hi,

I'm trying to get pxe boot working with our new x240 nodes and VMware ESXi. We have 2 EN4093 switches in the chassis, each x240 node is connected to both switches. The EN4093 switches were configures in transparent mode by our IBM partner follwing the document "IBM PureFlexSystem Networking" (don'T know why VLAN 4091 was choosen... there). Each EN4093 is connected to a single Cisco Nexus Switch with 2 ports (EXT1 + ESXT2) and 3 x240 nodes are connectes (INTA1 - INTA3). ip helper was configured for VLAN 153 (VMware Mgmt) on the Cisco switches to forward the packages to the dhcp server.

All VLANs are configured als tagged VLANs on the Cisco Nexus Switch. pxe out of the box does not work with tagged VLANs (AFAIK). So my first pxe boot attempts failed because of the tagged VLAN 153.

I found out that I can activate VLAN support in the Emulex PXESelect ROM of the x240 network adapter (CTRL-P during POST). This works but I would like to avoid to change this for every node in the chassis so I'm looking for a way to configure someting on the EN4093 switch or on the Cisco switch to get tis working out of the box.

I've already tried to change the VLAN 4091 as native vlan (?) in the vnicgroup config to vlan 153 (where ip helper is configured) but this didn't work.

Where/How do I configure this?

If this is not possible with EN4093 switches, my next step would be to ask our networking team to change the native vlan of the trunk to 153, but I'd like to sole this inside the flex system.

spanning-tree mode disable
portchannel 1 port ext1-ext10 enable
vnic enable
vnic vnicgroup 1
vlan 4091
port inta1-inta14
trunk 1
enable
failover
exit
write memory
switch A

#show vnic vnicgroup 1

vNIC Group 1: enabled

VLAN : 4091
Failover : enabled

vNIC Link



Port Link


INTA1 up
INTA2 up
INTA3 up
INTA4 down
INTA5 down
INTA6 down
INTA7 down
INTA8 down
INTA9 down
INTA10 down
INTA11 down
INTA12 down
INTA13 down
INTA14 down

UplinkPort Link


EXT1* up
EXT2* up
  • = The uplink port is in trunk 1
switch B

#show vnic vnicgroup 1

vNIC Group 1: enabled

VLAN : 4091
Failover : enabled

vNIC Link



Port Link


INTA1 up
INTA2 up
INTA3 up

UplinkPort Link


EXT1* up
EXT2* up
  • = The uplink port is in trunk 1
Updated on 2013-02-13T16:19:38Z at 2013-02-13T16:19:38Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    51 Posts
    ACCEPTED ANSWER

    Re: x240 nodes, EN4093 Switch, tagged vlans and pxe boot

    ‏2013-02-13T16:19:38Z  in response to SystemAdmin
    Problem solved. Our networking team configured it as nativ vlan on the Nexus uplinks.