Topic
  • 2 replies
  • Latest Post - ‏2013-02-11T17:36:40Z by SystemAdmin
SystemAdmin
SystemAdmin
340 Posts

Pinned topic upgrade from ILMT7.2.2 to 7.5

‏2013-02-11T09:01:33Z |
Hello All,

Currently we have ILMT 7.2.2.28 version installed on AIX6.1 and I am planning to upgrade it to version 7.5
I was going through the upgrade document and have following questions for the upgrade:
1. Is WAS8 base version supported for ILMT7.5?
2. In the document it's been mentioned as to first manually uninstall the License Metric Tool 7.2.2 instance from Base WebSphere Application Server 6.1. I am afraid if something goes wrong during the upgrade I might loose the entire ILMT set up.

I am referring document
http://pic.dhe.ibm.com/infocenter/tivihelp/v53r1/topic/com.ibm.lmt75.doc/com.ibm.license.mgmt.upgrading.doc/upgrade_guide_lmt.pdf

Can you please suggest how I should plan the upgrade?

Regards,
Harish.
Updated on 2013-02-11T17:36:40Z at 2013-02-11T17:36:40Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: upgrade from ILMT7.2.2 to 7.5

    ‏2013-02-11T10:23:09Z  
    Hello Harish,

    1. No, WAS 8.0 is not supported. ILMT 7.5 supports WAS in version 7.0.
    2. What do you refer by saying ILMT set up? Anything that is related to WAS will be lost anyway, because WAS does not provide any upgrade procedure but uninstalling and installing new version. Let me write here my advice:
    • First of all create valid audit reports till the current day (minus couple of days required for aggregate the data), sign and save them before starting the upgrade.
    • Secondly do the TLMA database backup (db2 backup) as well as WAS backup (binary copying of whole WAS folder)
    • Follow the instruction from the upgrade documentation

    Some additinal hints:
    You can skip step of uninstalling ILMT server and WAS 6.1. In such way when anything goes wrong you can come back to version 7.2.2. You will need just to restore TLMA database from previously created backup and use ILMT 7.2.2 server on WAS 6.1 that is already configured. However you must be very careful here and remember to stop all the processes that are related to WAS 6.1 prior to begin upgrade procedure. The reason is to avoid the situation when two ILMT servers installed on base WebSphere Application Server (7.2.2 and 7.5) may access TLMA database. Such situation will corrupt the database. When installation of LMT 7.5 passes successfully you can uninstall server 7.2.2 from WAS 6.1 and if required uninstall WAS 6.1 as well.

    Please let me know if my post answers your question.

    Regards,
    Michał Klak
    ILMT Central Team


    The postings on this site are my own and do not necessarily represent IBM's positions, strategies or opinions.
    Please contact product support if you need IBM's official advice.

    If you want to extend your knowledge of ILMT, you may check this site:
    https://www.ibm.com/developerworks/mydeveloperworks/wikis/home/wiki/IBM+License+Metric+Tool
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: upgrade from ILMT7.2.2 to 7.5

    ‏2013-02-11T17:36:40Z  
    Thanks Michał for your response.
    Your post answered all of my questions so far.

    Regards,
    Harish.