Topic
15 replies Latest Post - ‏2014-02-13T17:19:12Z by TiloMaster
SystemAdmin
SystemAdmin
1959 Posts
ACCEPTED ANSWER

Pinned topic Cognos Real time Monitoring Installation Error(Web Page)

‏2013-02-08T15:29:27Z |
We have installed Cognos Real time Monitoring 10.1.1 on Windows 7 64 -bit Operating System and deployed the Realtime.ear file on Websphere application server 7.0 and configured IBM HTTP server 7 as the Webserver and completed all the installation steps as per the Installation document.

While accessing the Realtime Workbench using the URL http://servername/cognos/realtime/landing/landingpage.htm. We are getting the below error:
Webpage error details:
=================
Message: Object doesn't support this property or method
Line: 189
Char: 7
Code: 0
URI: http://localhost:84/cognos/realtime/com/cognos/obi/i18n.js?v=1360306935597
Message: 'null' is null or not an object
Line: 21
Char: 1
Code: 0
URI: http://localhost:84/cognos/realtime/com/ui/l10n.js?v=1360306935597
Message: Object doesn't support this property or method
Line: 189
Char: 7
Code: 0
URI: http://localhost:84/cognos/realtime/com/cognos/obi/i18n.js?v=1360306935691
Message: 'null' is null or not an object
Line: 21
Char: 1
Code: 0
URI: http://localhost:84/cognos/realtime/com/ui/l10n.js?v=1360306935692
Message: 'this._CurrentLocaleDictionary' is null or not an object
Line: 62
Char: 94
Code: 0
URI: http://localhost:84

Can anyone please help me in resolving the issue

Thanks in advance
Regards
Updated on 2013-02-12T16:36:55Z at 2013-02-12T16:36:55Z by Carlos.Hernandez
  • SystemAdmin
    SystemAdmin
    1959 Posts
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2013-02-10T13:08:06Z  in response to SystemAdmin
    Hi Phil,

    Actually, when I access the static page from Browser(IE8) (http://localhost:84/cognos/realtime/landing/landingpage.htm) to HTTP server, it loads the java script in static page but it displays blank page and at the bottom left(Done) I am getting the above Error.

    Any idea??
    Thanks in advance
    • Carlos.Hernandez
      Carlos.Hernandez
      59 Posts
      ACCEPTED ANSWER

      Re: Cognos Real time Monitoring Installation Error(Web Page)

      ‏2013-02-12T16:36:55Z  in response to SystemAdmin
      just to rule out IE, try another browser. do you get the same results?
    • cwoliveira
      cwoliveira
      3 Posts
      ACCEPTED ANSWER

      Re: Cognos Real time Monitoring Installation Error(Web Page)

      ‏2013-06-20T22:41:10Z  in response to SystemAdmin

      Same error here, after installation and initial configuration. Ideas are welcome.

       

      - Windows 2008 Server R2 64-bit

      - WAS / IHS 7.0.0.25 (same machine)

      - Cognos RTM 10.1 FP1

      - SQL Server 2008 R2 Databases (remote machine)

       

      Regards,

      Carlos.

  • ThiagoReale
    ThiagoReale
    1 Post
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2013-06-03T19:41:12Z  in response to SystemAdmin

    Hello!

    I'm having the same problem here. Blank splashscreen.htm AND landingpage.htm. It redirects correctly from splashscreen to landingpage, but it doesn't show nothing on both pages. I double checked all the IIS7 configuration, but maybe I'm still missing something.

    I also tried to turn off Websphere and logon on my /ibmcognos/realtime, but the behavior is the same (both pages blank). I did this just to verify if there were some configurations missing on WebSphere.. but I think I should get an error the time RTM log in and try to communicate with WebSphere (so my best guess is that the problem is before it communicates with the app server.. maybe a flat configuration file or something on IIS…)

    Anyone?

    ---------------------------------

    Windows Server 2008 Enterprise

    WebSphere 8.5.0.2

    IIS 7

    RTM 10.2

    ---------------------------------

  • renaldmartin
    renaldmartin
    2 Posts
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2013-06-07T14:30:25Z  in response to SystemAdmin

    Same problem here, but with another architecture.

    RTM 10.2 server on one side on a Linux, and static webcontent on another server (also Linux).

    I didn't manage to get it work with Apache 2.2, so I used HTTP Server. When connecting to index page, I'm also well redirected to splash and then landing, but with blank page, and errors at same line / same character.

     

    I also managed to get an incredible bug with IE 10, in compatibility mode with "Alt+S" shortcut in debugger, which puts all code of the page into the <title> tag !! Then you can copy all content, put it into the code page by editing it, and you see links and images of landingpage.htm. Really weird.

     

    If anybody finds the source of this problem, i'd be really greatful.

  • cwoliveira
    cwoliveira
    3 Posts
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2013-06-19T18:10:55Z  in response to SystemAdmin

    I have the same problem with my system:

     

    Windows 2008 Server 64-bit R2 SP1

    WAS 7.0.0.25

    IHS 7.0.0.25 (same machine of WAS)

    Cognos RTM 10.1 Fixpack 1

     

    I found this document, but I already deployed realtime.ear with "file.encoding=utf8" JVM argument.

    http://www-01.ibm.com/support/docview.wss?uid=swg21380143

     

    If someone solved this issue, a tip will be welcome.

     

    Regards,

    Carlos

  • renaldmartin
    renaldmartin
    2 Posts
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2013-07-03T12:43:26Z  in response to SystemAdmin

    Ok guys, I got a solution.

    go to HTTPServer root directory. You should have a conf.d directory with a realtime.conf inside. If not, that's your problem.

    To do it the right way, you need to go on WAS admin interface via IE 8+ (compatibily mode), then your need to declare a Web server in server lists.

    THen you need to validate your installation (In administration tab), to generate the new conf file.

    Go to RTM server, in conf, and copy realtime.conf to your IBM HTTP server conf.d folder.

     

    If you have 2 servers (so it means you have a static content) you need to edit the file and replace "localhost" by your RTM server entry point like 192.168.1.1:8090.

    then in httpd.conf, add "Include conf.d/*.conf" or "Include conf.d/realtime.conf"

     

    Restart RTM Server

    Restart IBM HTTP server

    try again in IE, and you're in ;)

     

    If you have a DNS name, don't forget to add entries in you /etc/hosts file.

     

    I don't any other knowledge about the exact issue right now, and I will surely have problems to enter more into details later. It's still foggy for me.

    • cwoliveira
      cwoliveira
      3 Posts
      ACCEPTED ANSWER

      Re: Cognos Real time Monitoring Installation Error(Web Page)

      ‏2013-12-16T15:04:53Z  in response to renaldmartin

      Hi,

      As update, I solved my case updating jars to the endorsing directory of WAS.

      I missed this procedure (WAS endorsing directory) during installation, as mentioned by installation guide.

      Thanks,

      Carlos.

  • BharathIndia
    BharathIndia
    3 Posts
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2014-01-07T18:19:03Z  in response to SystemAdmin

    Hie , 

    Did anyone got a solution for this , I am having exactly the same issue .

    Configuration is successful , when i give "http://<rtm server name>/" in browser it is getting redirected to "landingpage.htm" , while opening developers tools in IE I am able to see the entire landingpage.htm html code , but there are some script errors , the same errors as the OP posted ,

    Will be really helpful if anyone could give a solution for this , 

    thanks in advance.

    Bharath.

     

     

     

     

    Updated on 2014-01-07T18:19:59Z at 2014-01-07T18:19:59Z by BharathIndia
    • NiravParmar
      NiravParmar
      3 Posts
      ACCEPTED ANSWER

      Re: Cognos Real time Monitoring Installation Error(Web Page)

      ‏2014-01-17T11:50:56Z  in response to BharathIndia

      Hi,

      I am having the same problem with RTM 10.2 installation and getting the error in IE 7 like "this._CurrentLocaleDictionary is null or not an object".

      I have set the variable in WAS Application Server 8.5 "-Dfile.encoding=utf8".

      Let me know if you have solution for this.

      Thanks,

      Nirav Parmar

      • BharathIndia
        BharathIndia
        3 Posts
        ACCEPTED ANSWER

        Re: Cognos Real time Monitoring Installation Error(Web Page)

        ‏2014-01-17T12:28:20Z  in response to NiravParmar

        Hie, You have to set the JVM arguments first in jvm settings in WAS.

        Add this in 'Generic JVM arguments'

         "-DBOOTPROPS=c:/Program Files (x86)/ibm/cognos/c10_64/realtime/configuration/realtime.properties" -Dcom.cognos.obi.bootstrap.envpropname=BOOTPROPS -Dfile.encoding=utf8 -Danonymousaccessenabled=true

        Thanks,

        Bharath.

         

         

        • NiravParmar
          NiravParmar
          3 Posts
          ACCEPTED ANSWER

          Re: Cognos Real time Monitoring Installation Error(Web Page)

          ‏2014-01-17T13:48:57Z  in response to BharathIndia

          here is my Generic JVM aruguments

          -Dfile.encoding=utf8 -Djaxws.payload.highFidelity=true "-Dicm.shared.folder=C:\Program Files (x86)\IBM\CaseManagement\configure\properties" -DmaxHttpCacheAge=5 "-DBOOTPROPS=C:/Progra~1/IBM/cognos/c10_64/realtime/configuration/realtime.properties" -Dcom.cognos.obi.bootstrap.envpropname=BOOTPROPS -Danonymousaccessenabled=true

          But still getting the same error. Is there any IE settings i need to do? i debug some js and i found that my locale is not setting up through the IE.

          Well i am not sure on that.

          Thanks

          Nirav

          • BharathIndia
            BharathIndia
            3 Posts
            ACCEPTED ANSWER

            Re: Cognos Real time Monitoring Installation Error(Web Page)

            ‏2014-01-17T15:09:16Z  in response to NiravParmar

            Are you getting a blank IE screen , I got this error and re installed RTM 10.1 as per the configurations given in the manual , 

            But my problem was because of these arguments only ..

             

            Thanks,

            Bharath

             

            • NiravParmar
              NiravParmar
              3 Posts
              ACCEPTED ANSWER

              Re: Cognos Real time Monitoring Installation Error(Web Page)

              ‏2014-01-21T06:28:26Z  in response to BharathIndia

              Yes getting the blank screen with java script error mentioned in above blog. I am using Real Time Monitoring 10.2 not 10.1.

              Thanks,

              Nirav

  • TiloMaster
    TiloMaster
    1 Post
    ACCEPTED ANSWER

    Re: Cognos Real time Monitoring Installation Error(Web Page)

    ‏2014-02-13T17:19:12Z  in response to SystemAdmin

    had the issue with blank page, missing buttons

    after change JVM and remove "-Dclient.encoding.override=UTF-8" (Not sure why this was in here) and added

    -Dfile.encoding=utf8

    it works now. (Win and WAS 7)