Topic
  • 2 replies
  • Latest Post - ‏2013-02-08T05:53:57Z by SystemAdmin
SystemAdmin
SystemAdmin
300 Posts

Pinned topic Unable to Install new software with Studio 5.0.5

‏2013-02-08T00:29:46Z |
Hello,

I installed Worklight Studio 5.0.5 standalone (not in an existing Eclipse). Things work fine until I attempt to Help -> Install new software.
Error message reads "Cannot complete the request. This installation has not been configured properly for Software Updates. See the error log for details." The error log details are:
eclipse.buildId=unknown
java.version=1.7.0_13
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product com.ibm.iws.product.ide
Command-line arguments: -os win32 -ws win32 -arch x86 -product com.ibm.iws.product.ide
Warning
Fri Feb 08 08:31:42 CST 2013
Could not locate the running profile instance. The eclipse.p2.data.area and eclipse.p2.profile properties may not be set correctly in this application's config.ini file.
I searched the forums and found a problem that was resolved by adding this to the eclipse.ini file:
osgi.bundles=org.eclipse.equinox.common@2:start,org.eclipse.update.configurator@3:start,org.eclipse.core.runtime@start,org.eclipse.equinox.ds@start
I did that and it worked on my machine running Windows 7 (run as administrator) but the one on Windows XP still fails with the same problem.

Any assistance?
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Unable to Install new software with Studio 5.0.5

    ‏2013-02-08T00:54:16Z  
    Try running Eclipse with the -clean flag. If you use the Worklight.cmd command script, add the -clean flag there. If that doesn't work, see note below.
    Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

    See the Forum Migration announce post for more details. Thank you.
    Barbara Hampson, Manager, IBM Worklight
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Unable to Install new software with Studio 5.0.5

    ‏2013-02-08T05:53:57Z  
    Try running Eclipse with the -clean flag. If you use the Worklight.cmd command script, add the -clean flag there. If that doesn't work, see note below.
    Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

    See the Forum Migration announce post for more details. Thank you.
    Barbara Hampson, Manager, IBM Worklight
    That seemed to work ... not sure why my Win7 one picked it up auto-matically, but ... no worries.
    Thanks!