Topic
13 replies Latest Post - ‏2013-04-29T09:20:04Z by DFS4_alex_goryachev
SystemAdmin
SystemAdmin
14225 Posts
ACCEPTED ANSWER

Pinned topic [RSA] Show Code View does not appear and react to edit UAL code

‏2013-02-06T19:48:09Z |
http://RSA 8.5 Show Code View does not appear in context menu of diagramm elements and when opened from window>Show View>Code View does not react when any diagramm eşement is selected.

Any solution?

Thanks in regards
Updated on 2013-02-20T11:44:22Z at 2013-02-20T11:44:22Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: [RSA] Show Code View does not appear and react to edit UAL code

    ‏2013-02-16T15:40:15Z  in response to SystemAdmin
    Does not anybody have the same problem? Any help would be great..
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: [RSA] Show Code View does not appear and react to edit UAL code

    ‏2013-02-16T15:40:20Z  in response to SystemAdmin
    Does not anybody have the same problem? Any help would be great..
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: [RSA] Show Code View does not appear and react to edit UAL code

    ‏2013-02-19T05:12:31Z  in response to SystemAdmin
    Hi

    Which diagram are you trying to use? Usually, the UAL editor should work with selections on diagrams. Please give me a description of the actions you performed and what you see in the code view. Does the code view display a string like "Select a model element to edit the behavioral code" or do you see something else?
    • SystemAdmin
      SystemAdmin
      14225 Posts
      ACCEPTED ANSWER

      Re: [RSA] Show Code View does not appear and react to edit UAL code

      ‏2013-02-19T11:08:43Z  in response to SystemAdmin
      Hey

      The code view displays a string "Select a model element to edit the behavioral code", and when i select an element for example in ActivityDiagramm(Opaque Action,Transition) or in Statemachine (State,transition ),the code view does not react.
      The active language of model execution is set to UAL in Settings.

      Thanks in advance!
    • SystemAdmin
      SystemAdmin
      14225 Posts
      ACCEPTED ANSWER

      Re: [RSA] Show Code View does not appear and react to edit UAL code

      ‏2013-02-19T11:12:32Z  in response to SystemAdmin
      Here is a Screenshot
      • SystemAdmin
        SystemAdmin
        14225 Posts
        ACCEPTED ANSWER

        Re: [RSA] Show Code View does not appear and react to edit UAL code

        ‏2013-02-20T06:09:22Z  in response to SystemAdmin
        Would it be possible for you to try the same on RSA 8.5.1? I can verify that this works on 8.5.1 but cannot remember if this was available in 8.5.
        You can try editing code by selecting the same elements in the project explorer. That should enable the code view.
        • SystemAdmin
          SystemAdmin
          14225 Posts
          ACCEPTED ANSWER

          Re: [RSA] Show Code View does not appear and react to edit UAL code

          ‏2013-02-20T08:38:48Z  in response to SystemAdmin
          I am using 8.5.1 .It also does not work with the project explorer here is a screenshot attached.

          Is there any other configuration that i have to make before working with ual code?
          I already have the active language as UAL and the project is Executable UML project.Also in the Setting>Capabilities all capabilites are selected(inclusive Modelling).
          • SystemAdmin
            SystemAdmin
            14225 Posts
            ACCEPTED ANSWER

            Re: [RSA] Show Code View does not appear and react to edit UAL code

            ‏2013-02-20T09:17:24Z  in response to SystemAdmin
            No other configuration should be necessary. One thing you can verify is whether the model's default language is set to UAL or not.
            This can be verified in the properties view. When the model is selected, the properties view shows a language tab. The value there should be UAL. You can try changing the active language and see if the code editor comes up. Try either OCL or Analysis and see if that changes anything.
            Is your RSA installation a default installation or did you select/unselect any components during install? Do you see any unresolved bundle errors during startup? Can you clear the log file under your workspace metadata folder, restart RSA, repeat your steps and see if the error log shows any errors? Please attach the log here.
            Also, please mention the exact version of RSA that is installed (should be something like 8.5.1000.RSAO851-I20120924_2025)
            • SystemAdmin
              SystemAdmin
              14225 Posts
              ACCEPTED ANSWER

              Re: [RSA] Show Code View does not appear and react to edit UAL code

              ‏2013-02-20T10:43:34Z  in response to SystemAdmin
              I tried changing the language in properties view of the (BlankexecutableUmlModel) package but it does not change anything.
              In installation i choose all under modeldrivendevelopment category and also simulation category.There are also various points selected under other categories.Also architect minimal+ standart ,Mdd for java minimal+standart and service architect is selected under the category ibm rational software architect 8.5.1.

              So i cleared the log file and started new and tried again here is the log file:

              !SESSION 2013-02-20 11:08:13.898
              eclipse.buildId=unknown
              java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows 7 x86-32 20121024_126071 (JIT enabled, AOT enabled)
              J9VM - R26_Java726_SR3_20121024_1635_B126071
              JIT - r11.b02_20120924_26343a
              GC - R26_Java726_SR3_20121024_1635_B126071
              J9CL - 20121024_126071
              BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_AT
              Command-line arguments: -os win32 -ws win32 -arch x86

              !ENTRY org.eclipse.core.resources 2 10035 2013-02-20 11:08:31.696
              !MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

              !ENTRY org.eclipse.ui 2 0 2013-02-20 11:08:34.214
              !MESSAGE Warnings while parsing the commands from the 'org.eclipse.ui.commands' and 'org.eclipse.ui.actionDefinitions' extension points.
              !SUBENTRY 1 org.eclipse.ui 2 0 2013-02-20 11:08:34.215
              !MESSAGE Commands should really have a category: plug-in='com.ibm.xtools.modeler.ui.diagrams.statechart', id='com.ibm.xtools.modeler.ui.diagrams.statechart.moveLeft', categoryId='com.ibm.xtools.modeler.ui.diagrams.statechart.moveTransitiontools.modeler.ui.diagrams.statechart.moveTransition'

              !ENTRY com.ibm.xtools.emf.ram.ui 4 0 2013-02-20 11:09:20.157
              !MESSAGE RAM Client is not installed. Please install the RAM Client to enable the RAM integration functionality.

              !ENTRY org.eclipse.ui.workbench 2 0 2013-02-20 11:10:34.774
              !MESSAGE A handler conflict occurred. This may disable some commands.
              !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2013-02-20 11:10:34.774
              !MESSAGE Conflict for 'org.eclipse.ui.edit.copy':
              HandlerActivation(commandId=org.eclipse.ui.edit.copy,
              handler=ActionHandler(org.eclipse.gmf.runtime.common.ui.action.internal.actions.global.GlobalCopyAction@d8c974dc),
              expression=AndExpression(AndExpression(org.eclipse.ui.SubActionBars$1@6dbffb4,ActivePartExpression(org.eclipse.ui.navigator.resources.ProjectExplorer@276abf7e)),WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@781149f)),sourcePriority=1064961)
              HandlerActivation(commandId=org.eclipse.ui.edit.copy,
              handler=ActionHandler(org.eclipse.gmf.runtime.common.ui.action.internal.actions.global.GlobalCopyAction@d8c974dc),
              expression=AndExpression(AndExpression(org.eclipse.ui.SubActionBars$1@6dbffb4,ActivePartExpression(org.eclipse.ui.navigator.resources.ProjectExplorer@276abf7e)),WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@781149f)),sourcePriority=1064961)

              !ENTRY org.eclipse.osgi 4 0 2013-02-20 11:21:04.414
              !MESSAGE Either the manifest file or the signature file has been tampered in this jar: C:\Program Files (x86)\IBM\IBMIMShared\plugins\org.eclipse.m2e.maven.runtime_1.2.0.20120903-0645
              !STACK 0
              java.security.SignatureException: Either the manifest file or the signature file has been tampered in this jar: C:\Program Files (x86)\IBM\IBMIMShared\plugins\org.eclipse.m2e.maven.runtime_1.2.0.20120903-0645
              at org.eclipse.osgi.internal.signedcontent.SignatureBlockProcessor.verifyManifestAndSignatureFile(Unknown Source)
              at org.eclipse.osgi.internal.signedcontent.SignatureBlockProcessor.processSigner(Unknown Source)
              at org.eclipse.osgi.internal.signedcontent.SignatureBlockProcessor.process(Unknown Source)
              at org.eclipse.osgi.internal.signedcontent.SignedBundleFile.setBundleFile(Unknown Source)
              at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(Unknown Source)
              at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(Unknown Source)
              at org.eclipse.ui.internal.about.AboutBundleData.isSigned(Unknown Source)
              at org.eclipse.ui.internal.about.AboutPluginsPage$1.run(Unknown Source)
              at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
              i attach also the bak.0 file under metadata folder

              PS: Can you tell me where can i find the exact version number?Than i would post it too
              Thanks!!

              Attachments

            • SystemAdmin
              SystemAdmin
              14225 Posts
              ACCEPTED ANSWER

              Re: [RSA] Show Code View does not appear and react to edit UAL code

              ‏2013-02-20T10:44:24Z  in response to SystemAdmin
              I have found another file where some bundleexceptions are reported under C:\Program Files (x86)\IBM\SDP\configuration\1360761661247 i attach it also
            • SystemAdmin
              SystemAdmin
              14225 Posts
              ACCEPTED ANSWER

              Re: [RSA] Show Code View does not appear and react to edit UAL code

              ‏2013-02-20T10:54:24Z  in response to SystemAdmin
              So i also have found the IBm rational Software Architect Plug-In version 8.5.1.v20121024_2339
              • SystemAdmin
                SystemAdmin
                14225 Posts
                ACCEPTED ANSWER

                Re: [RSA] Show Code View does not appear and react to edit UAL code

                ‏2013-02-20T11:44:22Z  in response to SystemAdmin
                I have just confirmed that this is a problem introduced late in 8.5.1 and escaped undetected. So, if you can, please revert to an older version of 8.5.1 or to RSA 8.5. Also, please create an APAR so that we can deliver a patch on 8.5.1 to fix this problem
  • DFS4_alex_goryachev
    DFS4_alex_goryachev
    1 Post
    ACCEPTED ANSWER

    Re: [RSA] Show Code View does not appear and react to edit UAL code

    ‏2013-04-29T09:20:04Z  in response to SystemAdmin

    I have the same problem.

    I was told to not downgrade to 8.5 from 8.5.1 since 8.5.1 is supposed to have many improvements in the code view/editor.

    How can I go back to an older 8.5.1?

    Thanx