Topic
  • 3 replies
  • Latest Post - ‏2013-03-26T07:36:21Z by YuanFeng
SystemAdmin
SystemAdmin
1632 Posts

Pinned topic Problem when using Default Schema Filter

‏2013-02-06T18:55:11Z |
In DS V3.2, we would like to use Default Schema Filter in the Properties of the connection, to exclude DB2 system tables since we don't want to worry about them when working with the database. The way we set up the filter is Properties -> Default Schema Filter -> Expression -> Name -> Does not start with the characters -> SYS.

The filtering seems to work fine except that as soon as we use it, the 'Copy from Left to Right' and 'Copy from Right to Left' icons in the Database Compare result view are grey out, thus we are not able to choose differences to apply from one database to the other, by using the Database Compare function.

Is this expected behavior? Any resolution or alternatives?

Thanks
Updated on 2013-03-26T07:36:21Z at 2013-03-26T07:36:21Z by YuanFeng
  • YuanFeng
    YuanFeng
    78 Posts

    Re: Problem when using Default Schema Filter

    ‏2013-03-12T02:19:07Z  
    Hi,Jie Wu
    It's glad to know you are using data studio in your work.
    Can you please help me better understand how you do the actions?Could you tell me which path are you actor?
    1. Launch by the Data Source Explorer->right click->select the menu compare with
    2. Launch by the Administration Explorer->right click->Migrate/Compar&Migrate Objects
  • SystemAdmin
    SystemAdmin
    1632 Posts

    Re: Problem when using Default Schema Filter

    ‏2013-03-12T15:08:23Z  
    • YuanFeng
    • ‏2013-03-12T02:19:07Z
    Hi,Jie Wu
    It's glad to know you are using data studio in your work.
    Can you please help me better understand how you do the actions?Could you tell me which path are you actor?
    1. Launch by the Data Source Explorer->right click->select the menu compare with
    2. Launch by the Administration Explorer->right click->Migrate/Compar&Migrate Objects
    Hi,
    I used: Data Source Explorer->right click->select the menu compare with

    I like to get it work with the Compare With function since the Custom Filter works there, but not in the Migrate function. (See another thread I posted in this forum: Custom Filter Configuration not working for Compare and Migrate function, last post Feb 05, 2013 07:56:04 PM )

    Thanks
  • YuanFeng
    YuanFeng
    78 Posts

    Re: Problem when using Default Schema Filter

    ‏2013-03-26T07:36:21Z  
    Hi,
    I used: Data Source Explorer->right click->select the menu compare with

    I like to get it work with the Compare With function since the Custom Filter works there, but not in the Migrate function. (See another thread I posted in this forum: Custom Filter Configuration not working for Compare and Migrate function, last post Feb 05, 2013 07:56:04 PM )

    Thanks
    Sorry,I failed to reproduce the problem on my local