Topic
8 replies Latest Post - ‏2013-02-08T00:02:24Z by SystemAdmin
SystemAdmin
SystemAdmin
2327 Posts
ACCEPTED ANSWER

Pinned topic Problem: Error deploying Worklight application

‏2013-02-06T12:19:15Z |
Hi! I have the same problem GernotAHummer posted last year. Tried the fix described in the thread to avail, therefore asking again :)

Configuration:
RHEL 6.3 (OpenClient)
2.6.32-279.19.1.el6.x86_64
Eclipse Juno 20120920-0800, JDT freshly unpacked, workspace clean, no additional plugins installed, so no ADT yet
Worklight 5.0.5 Enterprise
OpenJDK 1.7.0
I can proceed as far as creating the Hello World example according to the getting started documentation, but upon running the example I get this output:
An internal error occurred during: "Worklight application builder". loader constraint violation: when resolving method "org.apache.commons.io.FileUtils.iterateFiles(Ljava/io/File;Lorg/apache/commons/io/filefilter/IOFileFilter;Lorg/apache/commons/io/filefilter/IOFileFilter;)Ljava/util/Iterator;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/worklight/builder/skins/impl/SkinBuilderImpl, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, org/apache/commons/io/FileUtils, have different Class objects for the type o/filefilter/IOFileFilter;Lorg/apache/commons/io/filefilter/IOFileFilter;)Ljava/util/Iterator; used in the signature

Jetty server did run though, I can see an admin page, but no app deployed.

By the way, Eclipse would not start if automatic building is enabled. It gets stuck while loading com.worklight.studio.plugin.

The older thread: http://www.ibm.com/developerworks/forums/thread.jspa?messageID=14921142

Many thanks!
  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: Problem: Error deploying Worklight application

    ‏2013-02-06T13:09:08Z  in response to SystemAdmin
    Hi,
    Please try to run Eclipse with -clean as command line parameter.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    • SystemAdmin
      SystemAdmin
      2327 Posts
      ACCEPTED ANSWER

      Re: Problem: Error deploying Worklight application

      ‏2013-02-07T12:49:56Z  in response to IdanAdar
      Thanks!

      I tried starting Eclipse with -clean. It got stuck while loading worklight plugin, makes sense because it might have renabled automatic building.
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: Problem: Error deploying Worklight application

    ‏2013-02-06T14:53:30Z  in response to SystemAdmin
    -clean may not work. If so do this: stop eclipse, backup and then delete all files in your workspace \workspace\worklight\.metadata\.plugins\org.eclipse.core.resources\.projects. Then restart eclipse.

    Jerry
    • SystemAdmin
      SystemAdmin
      2327 Posts
      ACCEPTED ANSWER

      Re: Problem: Error deploying Worklight application

      ‏2013-02-07T12:57:26Z  in response to SystemAdmin
      Thanks!

      I did what you suggested, but still got stuck while loading worklight plugin, perhaps due to the same reason hypothesized above.

      So I deleted Eclipse and the workspace completely, made sure JVM in use is IBM 1.7, did a fresh install of Eclipse + Worklight IDE plugin, created the project, and still got the same error as the original thread says.
      • ozair
        ozair
        15 Posts
        ACCEPTED ANSWER

        Re: Problem: Error deploying Worklight application

        ‏2013-02-07T14:34:15Z  in response to SystemAdmin
        Try using the pre-packaged Worklight Studio 5.0.5 with Worklight server instead of the eclipse plugins.
      • SystemAdmin
        SystemAdmin
        2327 Posts
        ACCEPTED ANSWER

        Re: Problem: Error deploying Worklight application

        ‏2013-02-07T15:18:38Z  in response to SystemAdmin
        Use Oracle/Sun JDK instead of IBM's

        Jerry
      • SystemAdmin
        SystemAdmin
        2327 Posts
        ACCEPTED ANSWER

        Re: Problem: Error deploying Worklight application

        ‏2013-02-08T00:02:24Z  in response to SystemAdmin
        Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

        See the Forum Migration announce post for more details. Thank you.

        Barbara Hampson, Manager, IBM Worklight
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: Problem: Error deploying Worklight application

    ‏2013-02-07T19:57:47Z  in response to SystemAdmin
    My experience was I have to use a particular version of Eclipse which is Indigo. And also JDK 1.6. You will hit another bug in the adapter if you use JDK 1.7.

    I remembered trying Juno and I remember having some strange problem. As soon as I switched back to Indigo, everything was fine. Give that a try. Thanks.