Topic
1 reply Latest Post - ‏2013-02-13T13:04:01Z by ChristianSmith
SystemAdmin
SystemAdmin
1283 Posts
ACCEPTED ANSWER

Pinned topic Gateway JDBC don't write

‏2013-02-06T10:43:44Z |
I configured everything well, at least I think. I did a test is generated so that a critical event and then I tried to see if the event had been written about DB2, but it did not work.

I tried looking at the log file:

/opt/IBM/tivoli/netcool/omnibus/log

and find a common mistake:

013-02-06T10:14:37: Error: E-GJA-000-000: ngjava: G_JDBC: pool-1-thread-15: java.sql.SQLException: Simulated transaction error
* at com.ibm.tivoli.netcool.integrations.jdbc.GWJdbcNullPreparedStatement(GWJdbcNullPreparedStatement.java:595)*
* at com.ibm.tivoli.netcool.integrations.jdbc.GWJdbcBatchProcessor(GWJdbcBatchProcessor.java:491)*
* at com.ibm.tivoli.netcool.integrations.jdbc.GWJdbcBatchProcessor(GWJdbcBatchProcessor.java:323)*
* at java.util.concurrent.ThreadPoolExecutor$Worker(ThreadPoolExecutor.java:897)*
* at java.util.concurrent.ThreadPoolExecutor$Worker(ThreadPoolExecutor.java:919)*
* at java.lang.Thread(Thread.java:736)*

How can I fix?

Attachments

Updated on 2013-02-13T13:04:01Z at 2013-02-13T13:04:01Z by ChristianSmith
  • ChristianSmith
    ChristianSmith
    2 Posts
    ACCEPTED ANSWER

    Re: Gateway JDBC don't write

    ‏2013-02-13T13:04:01Z  in response to SystemAdmin
    You've not configured your Gate.Jdbc.Driver property to point to the DB2 driver class. You're currently using the default built in Null JDBC driver, which simply discards all it's data and simulates errors. It's used internally for testing.

    The manual gives details and examples, including example settings for DB2:
    http://publib.boulder.ibm.com/infocenter/tivihelp/v8r1/topic/com.ibm.netcool_OMNIbus.doc/gateways/jdbcgw/jdbcgw/wip/reference/jdbcgw_config_db_connection.html