Topic
  • 1 reply
  • Latest Post - ‏2013-02-05T19:33:25Z by thanh
thanh
thanh
36 Posts

Pinned topic Prerequisite RPMs for Common & Platform Agents 6.3

‏2013-02-05T19:20:45Z |
When I tried to install Common Agent 6.3 on a RHEL 6.2 system, it ended with lots of "needed by" messages and the final message as below:
....
libc.so.6 is needed by ISDCommonAgent-6.3.0-1.noarch
libdl.so.2 is needed by ISDCommonAgent-6.3.0-1.noarch
libstdc++.so.5 is needed by ISDCommonAgent-6.3.0-1.noarch
libgcc_s.so.1 is needed by ISDCommonAgent-6.3.0-1.noarch
libm.so.6 is needed by ISDCommonAgent-6.3.0-1.noarch
libnsl.so.1 is needed by ISDCommonAgent-6.3.0-1.noarch
libpam.so.0 is needed by ISDCommonAgent-6.3.0-1.noarch
libpthread.so.0 is needed by ISDCommonAgent-6.3.0-1.noarch
librt.so.1 is needed by ISDCommonAgent-6.3.0-1.noarch
The main set of RPMs will not install due to unsatisfied dependencies.

Which is the recommended way to download these RPMs? From where?

Thanks in advance for any pointers.
Updated on 2013-02-05T19:33:25Z at 2013-02-05T19:33:25Z by thanh
  • thanh
    thanh
    36 Posts

    Re: Prerequisite RPMs for Common & Platform Agents 6.3

    ‏2013-02-05T19:33:25Z  
    The ISD 6.3 online document list these dependencies for Common Agent:

    libcrypt.so.1
    libc.so.6
    libdl.so.2
    libstdc++.so.5
    libgcc_s.so.1
    libm.so.6
    libnsl.so.1
    libpam.so.0
    libpthread.so.0
    librt.so.1
    unzip
    bind-utils
    net-tools
    libstdc++.so.6
    libuuid.so.1
    libexpat.so.0

    For Platform Agent dependencies:

    libstdc++.so.5
    bind-utils
    net-tools
    libpam.so.0
    libstdc++.so.6
    libuuid.so.1
    libcrypt.so.1
    unzip
    libexpat.so.0

    That's quite a lot to download and install. Any suggestion would be appreciated.