Topic
11 replies Latest Post - ‏2013-02-08T00:00:44Z by SystemAdmin
SystemAdmin
SystemAdmin
2327 Posts
ACCEPTED ANSWER

Pinned topic Deployment Issue on WL 5.0.5 to Tomcat

‏2013-02-05T16:07:29Z |
Deployed .war into Tomcat server. In application console, there is no apps and adapters shown up. Try to deploy any .wlapp or .adapter will get an error message:

SyntaxError: Unexpected token <

Please help to solve this issue.

Jerry
  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: Deployment Issue on WL 5.0.5 to Tomcat

    ‏2013-02-05T16:11:58Z  in response to SystemAdmin
    Logs? Worklight project to test with?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    • SystemAdmin
      SystemAdmin
      2327 Posts
      ACCEPTED ANSWER

      Re: Deployment Issue on WL 5.0.5 to Tomcat

      ‏2013-02-05T16:18:38Z  in response to IdanAdar
      Not first day deal with WL. There are no error messages in log. Server started successfully.

      The problem will occur when delete all adapters and apps. Then try to install them again. It will also appear when sometimes try to update .wlapp. Quite strange in most of cases...

      Jerry
    • SystemAdmin
      SystemAdmin
      2327 Posts
      ACCEPTED ANSWER

      Re: Deployment Issue on WL 5.0.5 to Tomcat

      ‏2013-02-05T17:28:16Z  in response to IdanAdar
      By the way, the Chrome version of browser is Version 24.0.1312.57 m.
      • SystemAdmin
        SystemAdmin
        2327 Posts
        ACCEPTED ANSWER

        Re: Deployment Issue on WL 5.0.5 to Tomcat

        ‏2013-02-05T18:23:33Z  in response to SystemAdmin
        It is possible the folders (work, temp, worklight.home) deleted in clean process. The server is started successfully but could not deploy any apps. Looks strange behavior in such case...

        Jerry
        • ShmulikB
          ShmulikB
          20 Posts
          ACCEPTED ANSWER

          Re: Deployment Issue on WL 5.0.5 to Tomcat

          ‏2013-02-06T07:16:43Z  in response to SystemAdmin
          Hi
          I tested this issue on Tomcat and IBM Worklight 5.0.5 and had no problem deleting or re-installing applications.
          Can you provide us the project that you're trying to work with?
          • SystemAdmin
            SystemAdmin
            2327 Posts
            ACCEPTED ANSWER

            Re: Deployment Issue on WL 5.0.5 to Tomcat

            ‏2013-02-06T14:47:10Z  in response to ShmulikB
            What I am trying to do is to deploy multiple worklight apps into one Tomcat instance. Initially is to clean all temporary folders and to a re-deployment to all worklight apps.

            Is it a good practice to deploy multiple worklight server app into one Tomcat server?

            Jerry
            • SystemAdmin
              SystemAdmin
              2327 Posts
              ACCEPTED ANSWER

              Re: Deployment Issue on WL 5.0.5 to Tomcat

              ‏2013-02-07T19:46:56Z  in response to SystemAdmin
              Anyone have experience on multiple Worklight Application delopyment?

              Thanks!

              Jerry
              • SystemAdmin
                SystemAdmin
                2327 Posts
                ACCEPTED ANSWER

                Re: Deployment Issue on WL 5.0.5 to Tomcat

                ‏2013-02-07T20:03:42Z  in response to SystemAdmin
                You mean multiple Apps(wlapp files) on a WL server? We do that all the time.

                Not sure about your original issue. Is your wlapp files not corrupted?
                Maybe send us the wlapp file and we can try on our system just to see if your wlapp files are good. Thanks.
                • SystemAdmin
                  SystemAdmin
                  2327 Posts
                  ACCEPTED ANSWER

                  Re: Deployment Issue on WL 5.0.5 to Tomcat

                  ‏2013-02-07T20:21:52Z  in response to SystemAdmin
                  No. Multiple wars in same server sharing same database.

                  The wlapp is fine. Have several Worklight apps (internals and externals). Could not share back end because security constrains.

                  Jerry
                  • SystemAdmin
                    SystemAdmin
                    2327 Posts
                    ACCEPTED ANSWER

                    Re: Deployment Issue on WL 5.0.5 to Tomcat

                    ‏2013-02-08T00:00:44Z  in response to SystemAdmin
                    Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

                    See the Forum Migration announce post for more details. Thank you.

                    Barbara Hampson, Manager, IBM Worklight
  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: Deployment Issue on WL 5.0.5 to Tomcat

    ‏2013-02-07T21:15:24Z  in response to SystemAdmin
    There can be only 1 Worklight war file at a time.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform