Topic
4 replies Latest Post - ‏2013-06-21T18:47:50Z by Matt_Wear
SystemAdmin
SystemAdmin
3234 Posts
ACCEPTED ANSWER

Pinned topic Cannot upgrade IBM custom esxi 5.0 to IBM custom esxi 5.1

‏2013-02-05T13:33:25Z |
We are trying to upgrade our HS 22 (7870) Blades to esxi 5.1 using the IBM customization. Our current 5.0 hosts were installed using IBM 5.0 Customization. The upgrade errors out with several VIB errors. (I don’t recall the exact text.)Most of the errors seemed like they revolved around the LSI VIB's. Has anyone else run into this issue? Any help would be greatly appreciated.
Updated on 2013-03-12T13:20:30Z at 2013-03-12T13:20:30Z by SystemAdmin
  • Mr.Stowell
    Mr.Stowell
    12 Posts
    ACCEPTED ANSWER

    Re: Cannot upgrade IBM custom esxi 5.0 to IBM custom esxi 5.1

    ‏2013-02-05T15:41:28Z  in response to SystemAdmin
    I haven't updated any of my x3550 M2 or HS21 systems but I had a similar issue with some Dell servers. I ended up having to manually uninstall the custom VIBs via CLI and then I was able to apply the customized image via update manager.
    • SystemAdmin
      SystemAdmin
      3234 Posts
      ACCEPTED ANSWER

      Re: Cannot upgrade IBM custom esxi 5.0 to IBM custom esxi 5.1

      ‏2013-03-08T12:29:06Z  in response to Mr.Stowell
      Thank you for the reply. We have removed all the VIB's and are still running into a problem. VMware support is telling us that we need to verify that the IBM build has a specific patch applied.(vSphere 5.1 with download patch ESXi510-201210001) Does anyone know if this patch is included in the IBM build or how I can find out?
      • SystemAdmin
        SystemAdmin
        3234 Posts
        ACCEPTED ANSWER

        Re: Cannot upgrade IBM custom esxi 5.0 to IBM custom esxi 5.1

        ‏2013-03-12T13:20:30Z  in response to SystemAdmin
        Does IBM monitor this forum at all?
        • Matt_Wear
          Matt_Wear
          1 Post
          ACCEPTED ANSWER

          Re: Cannot upgrade IBM custom esxi 5.0 to IBM custom esxi 5.1

          ‏2013-06-21T18:47:50Z  in response to SystemAdmin

          I had the same problem.  Here is what I did to fix:

          The error message was pretty long but in a nut shell the LSIProvider_500.04.V0.24-261033 vib in the 5.0 customized version cannot be upgraded / replaced by the lsiprovider_500.04.V0.30-4000000 version on the 5.1 customized key.

          if you ssh into your esxi host and run 'esxcli software vib list' you should have this line:

          LSIProvider           500.04.V0.24-261033                 LSI                 VMwareAccepted    2012-09-07  

          Remove it with:

          esxcli software vib remove -n LSIProvider

          After it has been removed you can reboot esxi and then you can push out the customized 5.1 upgrade with update manager.

          -Matt