Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
5 replies Latest Post - ‏2014-09-29T13:09:19Z by srinivasjambiga
Victor.w
Victor.w
1 Post
ACCEPTED ANSWER

Pinned topic Cannot connect to the server process. Make sure the server is already start

‏2013-02-04T16:02:44Z |
Hi All,

I received "Cannot connect to the server process. Make sure the server is already started." when trying to start the WASV8 test env on RAD 804. No background processes or services are found related to WAS, I am not able to start the server.
  • ivyho
    ivyho
    67 Posts
    ACCEPTED ANSWER

    Re: Cannot connect to the server process. Make sure the server is already start

    ‏2013-06-10T04:22:30Z  in response to Victor.w

    You may want to go to the command line and see if you can start the server.

    e.g. you WASv8 is installed on IBM\wehsphere\AppServer\profiles\ApprSrv01\bin

    AppSrv01 is your profile

    invoke startServer.bat  server1

    See if you can start the server. If you cannot, something is wrong with your server.

    • alladisk
      alladisk
      2 Posts
      ACCEPTED ANSWER

      Re: Cannot connect to the server process. Make sure the server is already start

      ‏2014-01-22T19:01:38Z  in response to ivyho

      I am also encountered similar Problem, tried invoking from the command line, no use.  as mentioned by the 'ivyho' something wrong with your server. what is the something wrong.

      I have created new profiles, new work spaces in new folder, delted servers and added new, but still it is showing same thing.  I am using RAD 8.5 for Portal Server

       

      Thanks

       

      • ivyho
        ivyho
        67 Posts
        ACCEPTED ANSWER

        Re: Cannot connect to the server process. Make sure the server is already start

        ‏2014-01-22T19:53:03Z  in response to alladisk

        You probably want to open a ticket to support  to check what is wrong with the server if you cannot start it on the command line.

        Normally if we cannot start the WAS server inside the RAD tooling server tools, one of the tests we did is to to try to start it on the command line to do some problem isolation to see which team we should contact for issues.

         

        1. if you cannot start your WAS server on the command line, then for sure you will not be able to start the server inside the RAD tooling. So you can contact the server team to diagnose the issue.

        2.If you can start the WAS server from the command line,  but you cannot start the WAS server inside RAD tooling, then it may be an issue with the communications/handshake of the tooling with the server.

        The above applies to WAS server.,  sorry that I did not specify this clearly. If you are using a portal server,

        you may want to contact portal server team to check.

         

         

         

        • davidbrunstein
          davidbrunstein
          1 Post
          ACCEPTED ANSWER

          Re: Cannot connect to the server process. Make sure the server is already start

          ‏2014-07-03T17:39:55Z  in response to ivyho

          Hi all,

          I've experienced the same problem, and took several steps to get it resolved.

          After each step I've stopped/started the server and double checked status with the command line BAT files at C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\bin. Try to start the Application Server on each step.

          1) Add -clean to RAD shortcut

           

          2) Delete the Profile temp directories files:

          C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\tranlog\MblCell\MblNode\server1\transaction\tranlog
          C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\tranlog\MblCell\MblNode\server1\transaction\partnerlog
          C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\temp
          C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\config\temp
          C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\wstemp
           

          3) Deleted files from .metada directory: .lock, .log. and version.ini

          4) If the previous steps do not work, then delete and recreate the Profile. In my case, this last step addressed the problem

           

          On a side note I suggest you to double check the start server log file @ C:\Program Files\IBM\WebSphere\AppServer\profiles\MblProfile_v85\logs\server1. It show NullPointerException in LaunchCommand.java, this was part of the symptoms

          I hope this information helps you.

           

          Davo Brunstein

          Winnipeg, MB

           

           

          • srinivasjambiga
            srinivasjambiga
            1 Post
            ACCEPTED ANSWER

            Re: Cannot connect to the server process. Make sure the server is already start

            ‏2014-09-29T13:09:19Z  in response to davidbrunstein

            Hi

            I am getting below while i starting the server from command prompt.How can apply license

             

            WSVR0028I:The product has expired.
            Please re-install or purchase the product