• 1 reply
  • Latest Post - ‏2013-02-06T13:37:03Z by rizwan.shamim
5 Posts

Pinned topic RPT test script is not working as designed

‏2013-02-04T10:41:03Z |
OS : WIN2007

I have an RPT scripts which was executing correctly. Now the same script is not working as its have been designed.

I have added an 'if' condition. It is not checking that condition and even when the if condition is false, it executes the if code block. I am not getting any error on the RPT side. I tried restarting RPT and also cleaned the workspace, but it did not work.

This kind of issue is not regular. I mean the same script is working on other RPT instances, and was working on this RPT instance also.

Have anyone else has seen these kind of issues and what could be a definite solution for the same.

Updated on 2013-02-06T13:37:03Z at 2013-02-06T13:37:03Z by rizwan.shamim
  • rizwan.shamim
    5 Posts

    Re: RPT test script is not working as designed

    Hello Harshit,

    Can you clarify as to which version of RPT are you using?

    If there is no change to the test between the situation where it is working and not working, then I would start by investigating the 'if' condition and the data you use.

    What does your 'if' compare?
    What are the arguments that you pass? e.g do you compare custom code, datapools, a reference or static text?
    Are there any other conditions you specify such as negation?
    Have you tried to add logging (writing to the test log) and confirmed that the items being compared are what you expect?