Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
9 replies Latest Post - ‏2013-02-12T17:08:37Z by brrgn2
brrgn2
brrgn2
5 Posts
ACCEPTED ANSWER

Pinned topic Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

‏2013-02-04T01:25:10Z |
I have the following questions/issues:

1. Has anyone got TM1 Perspectives 10.1.1 working with 64-bit Microsoft Office Excel 2013? Do I need to downgrade to an older version of Office?
2. I am unable to start a Local Server. In Architect, I changed the directory to C:\Program Files\IBM\cognos\tm1_64\samples\tm1\PData, but clicking File > Start Local Server still does nothing. Are there any logfiles, etc. that I need to investigate? Or is it because this is a single-server install (and all servers are therefore Local Servers) or something?

Thanks to all who reply.
Updated on 2013-02-12T17:08:37Z at 2013-02-12T17:08:37Z by brrgn2
  • SystemAdmin
    SystemAdmin
    658 Posts
    ACCEPTED ANSWER

    Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

    ‏2013-02-04T01:29:49Z  in response to brrgn2
    Hi brrgn2,

    TM1 Perspectives needs the 32 bit version of Office to run. Excel 2003, 2007 and 2010 (32 Bit) are supported.

    Cognos Express is configured by default to only run the CXMD TM1 server.

    Hope this helps.

    Rod
    • brrgn2
      brrgn2
      5 Posts
      ACCEPTED ANSWER

      Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

      ‏2013-02-04T01:38:07Z  in response to SystemAdmin
      Thank you for the quick reply! I'll try installing the 32-bit version of Office 2013 (and if that doesn't work, the 32-bit version of Office 2010).

      I didn't understand your statement about Cognos Express (or the 'CXMD TM1 Server'). Was it in response to my second issue?
      • SystemAdmin
        SystemAdmin
        658 Posts
        ACCEPTED ANSWER

        Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

        ‏2013-02-04T01:43:04Z  in response to brrgn2
        Hi brrgn2,

        Yes, in response to your second issue, Cognos Express, by default, is designed to run only 1 TM1 instance (server name CXMD). If you have an existing TM1 environment you could migrate this into the CXMD instance.

        Hope this helps.

        Rod
        • SystemAdmin
          SystemAdmin
          658 Posts
          ACCEPTED ANSWER

          Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

          ‏2013-02-04T01:48:02Z  in response to SystemAdmin
          Hi brrgn2,

          Apologies, I thought you were running Cognos Express, hence my response.

          For TM1 you should be able to run multiple servers (within the constraints of your machines capabilities).

          If the second server instance did not start up then check the tm1s.cfg file:
          • ensure the server name and port number is not the same as an existing instance
          • confirm you have selected the right admin host
          • ensure the data directory and logging directory are correctly referenced

          Depending on how far TM1 got with loading the database then check the tm1s.log and tm1server.log files for more information.

          Apologies again for the confusion, hope this helps.

          Rod
          • brrgn2
            brrgn2
            5 Posts
            ACCEPTED ANSWER

            Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

            ‏2013-02-11T17:50:12Z  in response to SystemAdmin
            Thank you RodJager. I have been messing with this for a week now and I still can't get my sample local server up and running.

            I reinstalled TM1 10.1.1 on the single machine and can start the other sample servers (+SData+, Planning Sample and +GO_New_Stores+) just fine. I even changed the port to 5000 (for a local server), but clicking File > Start Local Server in Architect still does nothing.

            Also, if anyone else is curious, tm1p.xla (TM1 Perspectives 10.1.1) loads fine with 32-bit Excel 2013. I will report if I come across any issues.
            • SystemAdmin
              SystemAdmin
              658 Posts
              ACCEPTED ANSWER

              Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

              ‏2013-02-12T12:48:56Z  in response to brrgn2
              Local Server option does not seems to supported under TM1 10.1 series or higher.
              Since TM1 Servers are started from Cognos Configuration for instead.

              Product documentation and UI might not be updated.
              • brrgn2
                brrgn2
                5 Posts
                ACCEPTED ANSWER

                Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

                ‏2013-02-12T14:16:58Z  in response to SystemAdmin
                Are you certain? If that is the case, why is the option to start a local server even available?
                • SystemAdmin
                  SystemAdmin
                  658 Posts
                  ACCEPTED ANSWER

                  Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

                  ‏2013-02-12T14:40:19Z  in response to brrgn2
                  Not sure why the feature is still available with that point it may be better to contact support.

                  You are using 64 bit version. If you need to do some test now, how about installing 32-bit server instances?
                  I guess in your case product cannot find tm1s.exe(32 bit) to launch local server.

                  Do you have tm1s.exe in your install path?
                  • brrgn2
                    brrgn2
                    5 Posts
                    ACCEPTED ANSWER

                    Re: Questions re: POC/Demo install of 64-bit TM1 10.1.1 on a single server

                    ‏2013-02-12T17:08:37Z  in response to SystemAdmin
                    How do you know that the 'Local Server' feature has been deprecated in Cognos 10.1? I can't find this information anywhere. Can other experienced TM1 admins/users chime in?

                    Anyway, there's no point in testing with 32-bit binaries as the final install will be 64-bit.