Topic
2 replies Latest Post - ‏2013-02-08T00:19:35Z by SystemAdmin
EtienneNoiret
EtienneNoiret
6 Posts
ACCEPTED ANSWER

Pinned topic 5.0.5 regression with CI (HTTP?) adapter when making SSL request 401 error?

‏2013-02-01T17:39:50Z |
Hello,

I had a former 5.0.2 application using a Cast Iron adapter that connects to a URL using https. This application still works fine but when I take the adapter and run it in 5.0.5 (Developer Edition within Eclipse Studio or Consumer Edition from Liberty instance) I receive a 401 unauthorized response... what has changed that could prevent the same adapter code from running? Note that the adapter procedure is not protected.

Thanks

Etienne
  • raanan
    raanan
    50 Posts
    ACCEPTED ANSWER

    Re: 5.0.5 regression with CI (HTTP?) adapter when making SSL request 401 error?

    ‏2013-02-05T07:43:25Z  in response to EtienneNoiret
    Hi Etienne.

    There are a few changes in the authentication mechanism between 5.0.0.2 and 5.0.5 (they were made in 5.0.0.3).
    There is a tech note about what are the changes you need to do manually at:
    http://www-01.ibm.com/support/docview.wss?uid=swg27036063
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 5.0.5 regression with CI (HTTP?) adapter when making SSL request 401 error?

    ‏2013-02-08T00:19:35Z  in response to EtienneNoiret
    Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

    See the Forum Migration announce post for more details. Thank you.

    Barbara Hampson, Manager, IBM Worklight