• 1 reply
  • Latest Post - ‏2013-02-06T14:53:34Z by Kevin.R
3 Posts

Pinned topic Searchable Spec

‏2013-02-01T16:58:15Z | mdm-migration

I am having trouble with the "searchable" feature for Specs. I have added the "searchable" annotation to the element in the internal xsd. The searchable annotation is reflected in the database table SPECFMT internal and external xsd fields. The database table ENTITYSPECUSE has a SEARCHABLE_IND of Y.

I am expecting a row to be added to PRODUCTVALINDEX. However, when I add a product with the searchable element populated, no record is added to PRODUCTVALINDEX.

I have tried many things but am at a loss of what to try next. Any suggestions would be greatly appreciated.

Thank you!

  • Kevin.R
    3 Posts

    Re: Searchable Spec

    It seems I probably had a misunderstanding. I was expecting that once I modified an internal xsd to add a searchable field that when we used the deployment feature (workbench export of the spec) that a record would be added to the SPECSRCHATTR table. That did not happen (if it was supposed to). But, once I added the record manually, I saw a different error message. I added with a status type of 1 but did not locate the status type definitions in the MDMDevelopersGuide-Platform guide or the other MDMDeveloperGuide-x documents. I was able to eventually locate the status definitions in the MDMSystemManagementGuide. Once I made the change to a status of 3, the search worked correctly.