Topic
  • 5 replies
  • Latest Post - ‏2013-02-01T21:30:28Z by SystemAdmin
SystemAdmin
SystemAdmin
435 Posts

Pinned topic Text Analytics - term pushpin column in Type shows X for every entry

‏2013-01-31T19:28:41Z |
In the interactive workbench, Resources... I sometimes have one type that shows an "X" in the pushpin column, regardless of whether there is a matching term in another Type.

I can click to insert a pushpin (no other choice is indicated), or click again to remove pushpin and the "X" remains.
The only way to reset the Type's confusion, is to make a copy of the Type in another Library.. then delete the original Type, and copy the new type back into the original library.

Or one can manually delete the term within the Type, and redefine it again (but must be done for every term)

Anyone have an idea while a Type would think it's terms are all duplicated in another Type/Library when they are not?

This is in a 14.1 installation.

Tony
  • SystemAdmin
    SystemAdmin
    435 Posts

    Re: Text Analytics - term pushpin column in Type shows X for every entry

    ‏2013-02-01T11:57:50Z  
    pushpins are used to force a type in two cases:
    • the template contains duplicates, that is you have a same term that is defined under two different types. In that cases, adding a pushpin on 1 term will force this term to be analyzed with the forced type and not the other.
    • you want to override a type that comes from the compiled named entities dictionaries. for instance, london is typed as Location and you want it to be typed as Organization. SInce you do not have access to the compiled dictionaries, the only workaround is to add term london under the Organization type and force it with a pushpin.
    The only time I notices pushpins that I didn't have added myself was when adding/importing libraries and removing some of them.
    Can you give me a specific case you're seeing on a 14.1 version? (template and libraries used).
    Thanks
  • SystemAdmin
    SystemAdmin
    435 Posts

    Re: Text Analytics - term pushpin column in Type shows X for every entry

    ‏2013-02-01T20:58:10Z  
    pushpins are used to force a type in two cases:
    • the template contains duplicates, that is you have a same term that is defined under two different types. In that cases, adding a pushpin on 1 term will force this term to be analyzed with the forced type and not the other.
    • you want to override a type that comes from the compiled named entities dictionaries. for instance, london is typed as Location and you want it to be typed as Organization. SInce you do not have access to the compiled dictionaries, the only workaround is to add term london under the Organization type and force it with a pushpin.
    The only time I notices pushpins that I didn't have added myself was when adding/importing libraries and removing some of them.
    Can you give me a specific case you're seeing on a 14.1 version? (template and libraries used).
    Thanks
    Marie Claude,

    This was from a modified version of the Product Satisfaction TAP. In this cause the <Features> Type.

    Here are some details, as well as a screen shot.
    I had about 230 terms in the Type, and one day I opened it and there were Zero terms. There were also Zero terms in another <Budget> Type (in another library).

    I recopied the terms from an earlier version of the stream back into <Features> and <Budget>.

    Later, I discovered that all of the <Features> terms had "X" even though it was the only term. There were a few "real" pushpins. Click the phantom Xs and you get a red pushpin (but no list of other terms to select from. Click again and you get an X again.
    I "fixed" the phantom "x"s by either making a copy of the Type, and deleting the old one. Or deleting each term and recopying it back into the Type.

    I then RENAMED, and PUBLISHED all libraries. I also created a new Template and TAP.
    Unfortunately, the phantom X's come back occasionally.
    I just opened a copy of the stream (no work done, just made a copy of STR file), and the phantom X's are there again.
    SCREEN SHOT ENCLOSED.

    Note there is a "Never Published" (circle /) icon on all the libraries (even though they were published last time stream was worked on.

    Opening the prior copy of the same stream (stream never opened between making file copies)... and same phantom X's... although in this case the Library Publish icon is (unknown published state) "?"

    ---

    Another colleague of mine has also noticed the "missing terms" in Type error under 14.1.

    I thought maybe it was too long between publishing libraries... but in this case I have published all new libraries and templates.

    --

    • Tony
  • SystemAdmin
    SystemAdmin
    435 Posts

    Re: Text Analytics - term pushpin column in Type shows X for every entry

    ‏2013-02-01T21:05:23Z  
    pushpins are used to force a type in two cases:
    • the template contains duplicates, that is you have a same term that is defined under two different types. In that cases, adding a pushpin on 1 term will force this term to be analyzed with the forced type and not the other.
    • you want to override a type that comes from the compiled named entities dictionaries. for instance, london is typed as Location and you want it to be typed as Organization. SInce you do not have access to the compiled dictionaries, the only workaround is to add term london under the Organization type and force it with a pushpin.
    The only time I notices pushpins that I didn't have added myself was when adding/importing libraries and removing some of them.
    Can you give me a specific case you're seeing on a 14.1 version? (template and libraries used).
    Thanks
    I could try creating for you a Template of a subset of the libraries with the pushpin issue, if you want. Although don't know if it is machine install related or embedded in the stream/template itself across multiple 14.1 installations

    Tony
  • SystemAdmin
    SystemAdmin
    435 Posts

    Re: Text Analytics - term pushpin column in Type shows X for every entry

    ‏2013-02-01T21:26:14Z  
    I could try creating for you a Template of a subset of the libraries with the pushpin issue, if you want. Although don't know if it is machine install related or embedded in the stream/template itself across multiple 14.1 installations

    Tony
    Now I see phantom pushpins in both <Features> and <Budget>

    I have saved these 2 screenshots, as well as a Template containing only the 2 libraries that contain <Features> and <Budget>

    Note: Modeler 14.1

    Don't know if you open this Template in your own Modeler, you will see the same issue.

    Tony
  • SystemAdmin
    SystemAdmin
    435 Posts

    Re: Text Analytics - term pushpin column in Type shows X for every entry

    ‏2013-02-01T21:30:28Z  
    Now I see phantom pushpins in both <Features> and <Budget>

    I have saved these 2 screenshots, as well as a Template containing only the 2 libraries that contain <Features> and <Budget>

    Note: Modeler 14.1

    Don't know if you open this Template in your own Modeler, you will see the same issue.

    Tony
    Feature and Budget screenshots... phantom pushpins