Topic
2 replies Latest Post - ‏2013-02-08T00:32:51Z by SystemAdmin
SystemAdmin
SystemAdmin
2327 Posts
ACCEPTED ANSWER

Pinned topic failed to start: org/apache/commons/logging/Log

‏2013-01-31T08:26:44Z |
Hello IBMer,

When I use Run As ->Build All and Disploy ,eclipse pop some error like following:


2013-01-31 16:15:37 FWLST0011E: ====== Worklight Project todo-project-customization failed to start: org/apache/commons/logging/Log
2013-01-31 16:15:37 Activation failed. Bundle didn't start:/Users/blue/Documents/workspace/todo/bin/todo-customization.jar


I go to url "http://localhost:8080/console/" . This page says:
Error: no active project
The Worklight Server must have an active project in order to see the Worklight Console.

Right-click the project in Worklight Studio and select "Start Worklight Server" from the context menu.
A green triangle will be added to the project's icon to show it is active.


And I do above steps to Start worklight server , it pops following error:


2013-01-31 16:16:14 FWLST0011E: ====== Worklight Project todo-project-customization failed to start: loader constraint violation: loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) previously initiated loading for a different type with name "org/apache/commons/logging/Log"
2013-01-31 16:16:14 Activation failed. Bundle didn't start:/Users/blue/Documents/workspace/todo/bin/todo-customization.jar



How should I do to solve this problem?
thx!
  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: failed to start: org/apache/commons/logging/Log

    ‏2013-01-31T09:55:50Z  in response to SystemAdmin
    Judging from the text when trying to load Worklight Console, it seems to me you are using an older version of Worklight.
    I would recommend upgrading to the latest version, 5.0.5.1. Could you try that please?

    A possible workaround might be to remove the .bundle files in the .Eclipse folder under C:\Users\your-user\

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: failed to start: org/apache/commons/logging/Log

    ‏2013-02-08T00:32:51Z  in response to SystemAdmin
    Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

    See the Forum Migration announce post for more details. Thank you.

    Barbara Hampson, Manager, IBM Worklight