Topic
  • 10 replies
  • Latest Post - ‏2013-02-01T01:58:16Z by SystemAdmin
SystemAdmin
SystemAdmin
623 Posts

Pinned topic IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

‏2013-01-29T10:27:56Z |
Hello guys !
Here i came cross a strange problem! The detail information are all in accessory.
The model and the dat file are both the ooriginal document provided by the software .I use winform platform to call the model and the dat .But things always go wrong.
Plus:all these things works well in V12.4)
Updated on 2013-02-01T01:58:16Z at 2013-02-01T01:58:16Z by SystemAdmin
  • rdumeur
    rdumeur
    63 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-29T12:39:30Z  
    Dear polarbear_gh,

    What behavior do you expect for this program?
    When I run it, a window pops up which contains a button.
    When clicking on the button another window pops up and display: OBJECTIVE: 457
    Looking at the button1_Click method of the Form1 class, everything looks fine!
    Could you please provide more details about the problem you are encountering?

    Cheers,

    Renaud
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T09:47:10Z  
    Hello rdumeur!
    Thanks for your attention on my problem.
    Here is the picture which provides the detail information when clicking on the button .
    Thanks again!
    (plus: my computer system is Windows professional 64.
    V12.4 and V12.5 are both installed in my computer.
    V12.4 has its own environment variables.But V12.5 donesn't.)
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T09:50:33Z  
    Hello rdumeur!
    Thanks for your attention on my problem.
    Here is the picture which provides the detail information when clicking on the button .
    Thanks again!
    (plus: my computer system is Windows professional 64.
    V12.4 and V12.5 are both installed in my computer.
    V12.4 has its own environment variables.But V12.5 donesn't.)
    Picture again!
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T09:52:00Z  
    Picture again!
    Picture again!
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T09:55:28Z  
    Picture again!
    The more information!
  • rdumeur
    rdumeur
    63 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T11:03:12Z  
    The more information!
    Dear polarbear_gh,

    Unfortunately, I cannot access these pictures... I get redirected to:
    
    http:
    //www.ibm.com/common/errorpages/502.html
    

    Could you try uploading them with non-chinese filenames, maybe the server has trouble coping with them.
    Cheers,

    Renaud
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T15:04:40Z  
    • rdumeur
    • ‏2013-01-30T11:03:12Z
    Dear polarbear_gh,

    Unfortunately, I cannot access these pictures... I get redirected to:
    <pre class="jive-pre"> http: //www.ibm.com/common/errorpages/502.html </pre>
    Could you try uploading them with non-chinese filenames, maybe the server has trouble coping with them.
    Cheers,

    Renaud
    Picture again
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-30T15:05:50Z  
    Picture again
    more detail picture
  • rdumeur
    rdumeur
    63 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-01-31T14:26:21Z  
    more detail picture
    Dear polarbear_gh

    I've moved to a Windows 64 bits machine and there, I can't even load the project into the MSVC environment development. It says the .csproj file is corrupted but I suspect the presence of chinese characters is troubling this software.
    Nevertheless, I see that your solution references the oplall DLL and the problem may come from it. I'm contacting the relevant team to try determine what could be the problem.
  • SystemAdmin
    SystemAdmin
    623 Posts

    Re: IBM ILOG CPLEX Optimization Studio V12.5doesn't work well with c#(winform)

    ‏2013-02-01T01:58:16Z  
    • rdumeur
    • ‏2013-01-31T14:26:21Z
    Dear polarbear_gh

    I've moved to a Windows 64 bits machine and there, I can't even load the project into the MSVC environment development. It says the .csproj file is corrupted but I suspect the presence of chinese characters is troubling this software.
    Nevertheless, I see that your solution references the oplall DLL and the problem may come from it. I'm contacting the relevant team to try determine what could be the problem.
    Hello rdumeur!
    I try V12.5(32bit).Everything is ok now .So i think maybe the Visual Studio isn't incompatible with the 64bit.
    Thanks anymore!!