Topic
3 replies Latest Post - ‏2014-05-14T14:21:36Z by JohnHarris
SystemAdmin
SystemAdmin
5837 Posts
ACCEPTED ANSWER

Pinned topic DB2 Express-C 10.1.0.2 instance not auto starting

‏2013-01-28T10:15:10Z |
Hi!

I'm using DB2 Express-C 10.1.0.2 on Linux. During the installation I set that the instance should be auto-started, but after reboot it is not.
db2set reveals:
DB2COMM=TCPIP
DB2AUTOSTART=YES

What am I missing?

Best regards,
Kovi
Updated on 2013-01-29T08:25:57Z at 2013-01-29T08:25:57Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    5837 Posts
    ACCEPTED ANSWER

    Re: DB2 Express-C 10.1.0.2 instance not auto starting

    ‏2013-01-29T07:54:02Z  in response to SystemAdmin
    Hi!

    What I found till now is that DB2 fault monitor is responsible for autostarting DB2 instance.
    There is a command db2fm that can maintain db2fmcd (DB2 fault monitor deamon).

    At boot time I see that db2fmcd is running, but is not starting DB2 instance.
    "sudo ./db2fm -s -S" gives:
    Gcf module 'fault monitor' is INSTALLED PROPERLY but NOT ALIVE
    Gcf module '/opt/ibm/db2/V10.1/lib64/libdb2gcf.so' is INSTALLED PROPERLY but NOT ALIVE

    If I bring the service and deamon up using
    sudo ./db2fm -u -U
    DB2 instance is started.

    dmesg gives me a lot of this lines:
    db2fmcd1094 general protection ip:7f06966e5154 sp:7fff2e2f2150 error:0 in libc-2.15.so7f0696677000+1b3000
    init: db2fmcd main process (1094) killed by SEGV signal
    init: db2fmcd main process ended, respawning
    • SystemAdmin
      SystemAdmin
      5837 Posts
      ACCEPTED ANSWER

      Re: DB2 Express-C 10.1.0.2 instance not auto starting

      ‏2013-01-29T08:25:57Z  in response to SystemAdmin
      Hi!

      Workaround for this is to pu following lines to /etc/rc.local
      cd /opt/ibm/db2/V10.1/bin/
      ./db2fm -i db2inst1 -u -U
      ./db2fm -i db2inst1 -s -S

      Now DB2 instance is started at boot time and even if I kill the db2syscs process it comes back. :)
      This does not solve the crashing of db2fmcd process, but gets your instance running.

      Best regards,
      Kovi
      • JohnHarris
        JohnHarris
        1 Post
        ACCEPTED ANSWER

        Re: DB2 Express-C 10.1.0.2 instance not auto starting

        ‏2014-05-14T14:21:36Z  in response to SystemAdmin

        Auto starting/stopping DB2 on Linux/Unix

        Log in as root and enter the following commands

        su - db2inst1                               à where db2inst1 is ID of the instance owner

         

        Setting DB2 to automatically start at system reboot

        db2iauto -on db2inst1          -à where db2inst1 is name of the instance that should be auto-started

              Setting DB2 not to automatically start at system reboot

              db2iauto -off db2inst1

         

        On some instances of Linux it might be necessary to update the DB2 registry AUTOSTART (undocumented) / DB2AUTOSTART variables

                    Check whether or not the auto starting variables are set

                               db2set -all

                    e.g.

        MyLinux:~ # su - db2inst1

        db2inst1@MyLinux:~> db2set -all

        [i] AUTOSTART=YES

        [i] DB2COMM=TCPIP

        [i] DB2AUTOSTART=YES

        [g] DB2SYSTEM=MyLinux

        [g] DB2INSTDEF=db2inst1

        [g] DB2ADMINSERVER=dasusr1

         

                          checking for

                               AUTOSTART=YES

                    DB2AUTOSTART=YES

         

        OR

         

        Manually verify the AUTOSTART and DB2AUTOSTART registry variables set for the instance

        • db2set DB2AUTOSTART [-i instance_name]
        • db2set AUTOSTART [-i instance_name]

        e.g.

        db2inst1@MyLinux:~> db2set AUTOSTART -i db2inst1

              YES

        db2inst1@ MyLinux:~> db2set DB2AUTOSTART -i db2inst1

              YES

                                          

        The above commands should return YES if they are currently set

        If it doesn't issue the following commands

        • db2set AUTOSTART=YES
        • db2set DB2AUTOSTART=YES
        • db2iauto -on instance_name

         

         

        Regards

         

        John Harris

        Updated on 2014-05-14T14:22:04Z at 2014-05-14T14:22:04Z by JohnHarris