Topic
  • 5 replies
  • Latest Post - ‏2013-03-01T13:05:29Z by SystemAdmin
SystemAdmin
SystemAdmin
51 Posts

Pinned topic x240 node + VMware vSphere + vSwitchUSB0 = host profile error

‏2013-01-25T16:48:53Z |
Hi,

I'm trying to create an ESXi host profile for our new x240 nodes but I always get "A general system error occured: "Invalid value chosen for standbyNics".

This seems to be related to the vSwitchUSB0 for IMM_Network0 (http://www-01.ibm.com/support/docview.wss?uid=isg3T1018919). vSwitchUSB0 was automaticially created during install of the ESXi 5.1 host with the customized IBM image (ESXi-5.1.0-799733-IBM-20120919.iso). If I remove vSwitchUSB0 I can create the host profile without error, but after 60 seconds vSwitchUSB0 will be recreated and the host profile is then useless because the host is then "Noncompliant".

Is there a solution for this problem? First of all I don't understand what the error "Invalid value chosen for standbyNics" is at all or why it prevents the host profile from being created. vSphere depends heavyly on host profiles because of auto deploy, so there must be a way to use profiles with x240 nodes.
Updated on 2013-03-01T13:05:29Z at 2013-03-01T13:05:29Z by SystemAdmin
  • esarakaitis
    esarakaitis
    38 Posts

    Re: x240 node + VMware vSphere + vSwitchUSB0 = host profile error

    ‏2013-01-27T20:20:36Z  
    have you tried modifying the host profile to remove the USB reference?
    IBM PureFlex Admins
  • esarakaitis
    esarakaitis
    38 Posts

    Re: x240 node + VMware vSphere + vSwitchUSB0 = host profile error

    ‏2013-01-27T20:20:56Z  
    have you tried modifying the host profile to remove the USB reference?
    IBM PureFlex Admins
  • SystemAdmin
    SystemAdmin
    51 Posts

    Re: x240 node + VMware vSphere + vSwitchUSB0 = host profile error

    ‏2013-01-28T07:59:03Z  
    have you tried modifying the host profile to remove the USB reference?
    IBM PureFlex Admins
    I could not create the profile because of the error, thus I could not modify the profile. But in the mean time I found a workaround. I temporary removed vusb0 interface from vSwitchUSB0 and then created the profile. After that I disabled vSwitchUSB0 and IMM_Network0 in profile configuration. This works but it's a dirty hack.

    This is our first IBM Flex System, I thought it would work better with VMware vSphere.
  • esarakaitis
    esarakaitis
    38 Posts

    Re: x240 node + VMware vSphere + vSwitchUSB0 = host profile error

    ‏2013-01-28T13:49:41Z  
    I could not create the profile because of the error, thus I could not modify the profile. But in the mean time I found a workaround. I temporary removed vusb0 interface from vSwitchUSB0 and then created the profile. After that I disabled vSwitchUSB0 and IMM_Network0 in profile configuration. This works but it's a dirty hack.

    This is our first IBM Flex System, I thought it would work better with VMware vSphere.
    Makes sense, although I don't use host profiles. I build from script, then verify with script.

    VMware Admins PureFlex
  • SystemAdmin
    SystemAdmin
    51 Posts

    Re: x240 node + VMware vSphere + vSwitchUSB0 = host profile error

    ‏2013-03-01T13:05:29Z  
    I could not create the profile because of the error, thus I could not modify the profile. But in the mean time I found a workaround. I temporary removed vusb0 interface from vSwitchUSB0 and then created the profile. After that I disabled vSwitchUSB0 and IMM_Network0 in profile configuration. This works but it's a dirty hack.

    This is our first IBM Flex System, I thought it would work better with VMware vSphere.
    You can disable vSwitchUSB in x240 node: open IMM gui interface > go to Setting Network