Topic
5 replies Latest Post - ‏2013-02-02T11:25:57Z by pientka
michaelff
michaelff
5 Posts
ACCEPTED ANSWER

Pinned topic WASCE + IBM Data Studio

‏2013-01-25T14:00:10Z |
Hi Folks,
Really struggling here and not getting anywhere

Windows XP, Data Studio v3.2, WASCE v3.0.0

In Data Studio I want to add new server for WASCE on the same box, but the WASCE adapters are not installed.
so in Server veiw, hit New, then on Define a New Server, I hit the link Download additional Server adapters and the Install New Extension appears and "WASCE v3.0 Server Adapter Assembly" is at the bottom of the lit.
Selected that hit next and get the error:
Cannot complete the install because one of more required items could not be found
Software being installed: WASCE v3.0 Server Adapter Assembly 3.0.1.v20121120-1806220 (com.ibm.wasce.v30.feature.feature.group 3.0.1.v20121120-180620)
Updated on 2013-02-02T11:25:57Z at 2013-02-02T11:25:57Z by pientka
  • michaelff
    michaelff
    5 Posts
    ACCEPTED ANSWER

    Re: WASCE + IBM Data Studio

    ‏2013-01-25T14:17:24Z  in response to michaelff
    Hi Folks,

    Sorry only post part of the inf
    Really struggling here and not getting anywhere

    Windows XP, Data Studio v3.2, WASCE v3.0.0

    In Data Studio I want to add new server for WASCE on the same box, but the WASCE adapters are not installed.
    so in Server veiw, hit New, then on Define a New Server, I hit the link Download additional Server adapters and the Install New Extension appears and "WASCE v3.0 Server Adapter Assembly" is at the bottom of the lit.
    Selected that hit next and get the error:
    Cannot complete the install because one of more required items could not be found
    Software being installed: WASCE v3.0 Server Adapter Assembly 3.0.1.v20121120-1806220 (com.ibm.wasce.v30.feature.feature.group 3.0.1.v20121120-180620)
    Missing requirment: WASCE V3.0 Server Adapater Assembly 3.0.1.v20121120-180620 (com.ibm.wasce.v30.feature.feature.group 3.0.1.v20121120-180620) reeuoires 'org.eclipse.jst.server_ui.feature.group.3.2.0.v201005241530' but could not be found

    What do I do to get around this one?

    I have seen http://www.ibm.com/developerworks/forums/thread.jspa?messageID=14875353 but that has not helped.

    when I go to Help, Install New Software and Enable the Website http://download.boulder.ibm.com/ibmdl/pub/software/websphere/wasce/updates and select to work that sites
    I get a message saying
    Artifact not found http://download.boulder.ibm.com/ibmdl/pub/software/websphere/wasce/updates/content.jar
    org.eclipse.equinox.p2.core.ProvisionException

    So to avoid an issue with firewall at the customer site I download it

    I can get to the site from Internet Explorer http://download.boulder.ibm.com/ibmdl/pub/software/websphere/wasce/updates, so I downloaded the
    WASCE 3.0 WTP Server Adapter update site package here -- at the end of the page

    And then in Help, Install New Software I added a new site of type archive with these details
    Name: MF WASCE Adapter - C:/ibm_data_studio/wasce_eclipse-plugin-3.0.0.3-updates.zip
    Location: jar:file:/C:/ibm_data_studio/wasce_eclipse-plugin-3.0.0.3-updates.zip!/

    Even with this I am still getting the above error, so what I am missing, what do I need to to get this to work?

    Thanks
    Michale
    • michaelff
      michaelff
      5 Posts
      ACCEPTED ANSWER

      Re: WASCE + IBM Data Studio

      ‏2013-01-25T16:07:59Z  in response to michaelff
      Sorry should have also mentioned that if I am in Data Studio
      Help, Install new software and I have selected my local/archive repository
      I see
      WTP Servers Adapaters
      WASCE V3.0 Server Adapater Assembly version 3.0.1.v20121120-180620

      If I hit next here I get the message
      Cannot complete the install because one or more required items could not be found.

      Software being installed: WASCE v3.0 Server Adapter Assembly 3.0.1.v20121120-180620 (com.ibm.wasce.v30.feature.feature.group 3.0.1.v20121120-180620)

      Missing requirement: JST Server UI 3.2.4.v20110323-7A5FEn9xFc7TCFKWBBINHK43A (org.eclipse.jst.server_ui.feature.feature.group 3.2.4.v20110323-7A5FEn9xFc7TCFKWBBINHK43A) requires 'org.eclipse.jst.server_userdoc.feature.feature.group http://3.3.0.v201005241530-2-Eo7w3121162A3329' but it could not be found

      Cannot satisfy dependency:

      From: WASCE v3.0 Server Adapter Assembly 3.0.1.v20121120-180620 (com.ibm.wasce.v30.feature.feature.group 3.0.1.v20121120-180620)

      To: org.eclipse.jst.server_ui.feature.feature.group 3.2.0.v201005241530
      • michaelff
        michaelff
        5 Posts
        ACCEPTED ANSWER

        Re: WASCE + IBM Data Studio

        ‏2013-01-25T18:28:51Z  in response to michaelff
        Hi Folks,

        This turned out to a network config issue where there network security is tight (but not extremely tight) and their proxy were stripping out the message headers and those Eclipse could not identify/contact the repositories and pull in the correct dependencies.

        I must get more details when I am next talking to their network guys and add in here for future note.

        but after switching to the wireless network which is not going through their proxies it works but even still I had to follow the suggestions in
        http://www.ibm.com/developerworks/forums/thread.jspa?messageID=14875353
        • adding the WASCE sites in fact I worked with the local download I had
        • adding the Helios sites -(2 sites) - Helios - http://download.eclipse.org/releases/helios/201006230900 and Helios Milestone Repository - http://download.eclipse.org/release/helios
        • adding the Geronimo - htpp://www.apache.org/dist/geronimo/eclipse/updates
        • adding the TM updates - (2 sites) - http://download.eclipse.org/dsdp/tm/updates/3.2 and http://download.eclipse.org/tm/updates/3.2 (remember Select Expand TM and RSE Uncategorized 3.2.2 and select the Target Management Terminal option on this one as per http://www.ibm.com/developerworks/forums/thread.jspa?messageID=14875353)

        Now in the Servers view I can define my new server and I see IBM WASCE V3.0 Server, so I can get on with define my web services.

        Michael
        • michaelff
          michaelff
          5 Posts
          ACCEPTED ANSWER

          Re: WASCE + IBM Data Studio

          ‏2013-01-28T16:08:46Z  in response to michaelff
          Hi,

          Sent the following email to the customer to get a better understanding of what it is their proxy server is doing:-

          My question is I want to get a better understanding of the headers that you mentioned were being stripped by the Proxy Server, to see if there is an alternative way to work around these issues besides switching to the wireless network.

          For example when I was adding the adapters to allow Data Studio to connect IBM WebSphere Application Server (WAS) Community Edition (CE) it was failing when I was connected to LAN network with a proxy server specified, but when we connected to the Wireless network which does not need a proxy it was successfully able to install the adapters.

          Is that a correct summation of the situation? (that's what I have in my head! so please correct me if I have this wrong)

          You mentioned that the proxy server strips some headers from the message being sent (I think you called them "macina" headers - hope I got that right???) and this would affect all Eclipse plugins... so I am just trying to understand this issue
          1. for my own education
          2. to see if there is a way around for future occasions rather than having to connect to a wireless network that does not use the proxy server.

          If you could let me know if I have the correct understanding above then I will do some investigating from my side to see if there any other alternative solutions than switching the wireless network

          Thank you,
          Michael

          Response from customer was

          Hi,

          We’ve encountered the issue using Maven – which I assume is what Eclipse is using under the hood to resolve it’s dependencies, being a Java IDE. It’s a known issue in here and we have our own internal Maven Nexus repository which we use – this proxies the connections itself and don’t go through the normal proxies which cause the problems. I have no idea how to resolve the issue inside Data Studio I’m afraid.

          Thanks

          Our Solution was

          Was to switch to the wireless network that was available and not use the proxy config if I remember correctly and apply the plugins mentioned in my previous reply,
          but perhaps there is a better solution than this, anyone care to help me out here or make suggestion?
          • This seems a bit like this issue https://bugs.eclipse.org/bugs/show_bug.cgi?id=265277

          Any better recommendations, anyone able to explain this better to those of us who are not eclipse experts?
          Would appreciate the explanation of what is going on so that I can explain it to future customers.
          • pientka
            pientka
            9 Posts
            ACCEPTED ANSWER

            Re: WASCE + IBM Data Studio

            ‏2013-02-02T11:25:57Z  in response to michaelff
            please note
            http://www-01.ibm.com/support/docview.wss?uid=swg27024313
            64 bit operating systems and Java Runtime Environment 7 is now supported.
            Support for IBM WebSphere Application Server Community Edition (CE) for web services, is being deprecated and will be removed in the next release.