Topic
2 replies Latest Post - ‏2013-02-09T21:17:25Z by SystemAdmin
SystemAdmin
SystemAdmin
1632 Posts
ACCEPTED ANSWER

Pinned topic SQL1031N The database directory cannot be found

‏2013-01-24T00:41:19Z |
I am new to use the Data Studio. On my laptop (Windows 7 prof 64bit), I installed DB2 V10.1 FP2, Data Studio client V3.2, and Data Studio 3.2.0.1 Web Console. The database connections were imported to the Web Console and then imported to the Data Studio client.

I cam able to connect to the database connections (all z/OS DB2 V9, V10) successfully. When I ran an application on my laptop to access a remote database (which I can connect using Data Studio client), I got the SQL1031N The database directory can not be found on the indicated tile system. SQLSTATE=58031. From the CLP, tried the follow commands.
db2 => list database directory
SQL1031N The database directory cannot be found on the indicated file system.
SQLSTATE=58031
db2 => list node directory
SQL1027N The node directory cannot be found.

Any suggestions?
Updated on 2013-02-09T21:17:25Z at 2013-02-09T21:17:25Z by SystemAdmin
  • ledezma@us.ibm.com
    ledezma@us.ibm.com
    23 Posts
    ACCEPTED ANSWER

    Re: SQL1031N The database directory cannot be found

    ‏2013-02-07T06:05:23Z  in response to SystemAdmin
    Hi,

    When importing connections into Data Studio, they get persisted as connection profiles in the Data Studio workspace. However, Data Studio does not catalog these connections on the local DB2 client. In order to connect to a remote database outside of Data Studio, you would have to catalog the database using the CATALOG DATABASE command. This command is usually issued on the DB2 CLP (command line processor).

    For reference, see the following DB2 topic on configuring connections using the CLP: http://pic.dhe.ibm.com/infocenter/db2luw/v10r1/index.jsp?topic=%2Fcom.ibm.db2.luw.qb.client.doc%2Fdoc%2Ft0007243.html

    While Data Studio currently does not catalog a database connection automatically, you may issue these commands in the SQL editor by using the CLP runner to execute the commands.

    To do this, connect to the database, create a new SQL script, and choose "Command Line Processor" as the Run method.

    See attached screenshot

    Thanks,

    -Sal.