Topic
  • 6 replies
  • Latest Post - ‏2013-01-25T07:06:45Z by SystemAdmin
SystemAdmin
SystemAdmin
37421 Posts

Pinned topic 404 page not found smartcloud control desk

‏2013-01-23T12:50:22Z |
Hi,

I'm installing SmartCloud Control Desk on Middleware. After installation I tried to open Maximo Console - SMP (http://host:port/maximo) but Browser gives me error 404 - page not found

error.log in HTTPServer\logs contains following:

Mon Jan 21 08:12:52 2013 notice Parent: Received shutdown signal -- Shutting down the server.
Mon Jan 21 08:12:52 2013 notice Child 6968: Exit event signaled. Child process is ending.
Mon Jan 21 08:12:53 2013 notice Child 6968: Released the start mutex
Mon Jan 21 08:12:54 2013 notice Child 6968: All worker threads have exited.
Mon Jan 21 08:12:54 2013 notice Child 6968: Child process is exiting
Mon Jan 21 08:12:54 2013 notice Parent: Child process exited successfully.
Mon Jan 21 08:12:56 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: WebSphere Plugins loaded.
Mon Jan 21 08:12:56 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: --------------------Plugin Information-----------------------
Mon Jan 21 08:12:56 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld version: 7.0.0
Mon Jan 21 08:12:56 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld date: Apr 6 2011, 01:33:06
Mon Jan 21 08:12:56 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Webserver: IBM_HTTP_Server
Mon Jan 21 08:12:56 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header:
Mon Jan 21 08:12:56 2013 notice Using config file C:/Program Files/IBM/HTTPServer/conf/httpd.conf
Mon Jan 21 08:12:56 2013 notice IBM_HTTP_Server/7.0.0.17 (Win32) configured -- resuming normal operations
Mon Jan 21 08:12:56 2013 notice Server built: Mar 7 2011 15:45:47
Mon Jan 21 08:12:56 2013 notice Parent: Created child process 3852
Mon Jan 21 08:12:58 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: WebSphere Plugins loaded.
Mon Jan 21 08:12:58 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: --------------------Plugin Information-----------------------
Mon Jan 21 08:12:58 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld version: 7.0.0
Mon Jan 21 08:12:58 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld date: Apr 6 2011, 01:33:06
Mon Jan 21 08:12:58 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Webserver: IBM_HTTP_Server
Mon Jan 21 08:12:58 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header:
Mon Jan 21 08:12:58 2013 notice Using config file C:/Program Files/IBM/HTTPServer/conf/httpd.conf
Mon Jan 21 08:12:58 2013 notice Child 3852: Child process is running
Mon Jan 21 08:12:58 2013 notice Child 3852: Acquired the start mutex.
Mon Jan 21 08:12:58 2013 notice Child 3852: Starting 600 worker threads.
Mon Jan 21 08:12:58 2013 notice Child 3852: Starting thread to listen on port 82.
Mon Jan 21 08:17:44 2013 error http://client 192.168.2.131 File does not exist: C:/Program Files/IBM/HTTPServer/htdocs/maximo

There is really no maximo file

Plugin config file (default_host) contains this:

<?xml version="1.0" encoding="ISO-8859-1" ?>
  • <!-- HTTP server plugin config file for the cell ctgCell01 generated on 2013.01.23 at 07:03:51 AM EST
-->
  • <Config ASDisableNagle="false" AcceptAllContent="false" AppServerPortPreference="HostHeader" ChunkedResponse="false" FIPSEnable="false" FailoverToNext="false" HTTPMaxHeaders="300" IISDisableNagle="false" IISPluginPriority="High" IgnoreDNSFailures="false" RefreshInterval="60" ResponseChunkSize="64" SSLConsolidate="true" TrustedProxyEnable="false" VHostMatchingCompat="false">
<Log LogLevel="Error" Name="c:\Program Files\IBM\WebSphere\Plugins\logs\http_plugin.log" />
<Property Name="ESIEnable" Value="true" />
<Property Name="ESIMaxCacheSize" Value="1024" />
<Property Name="ESIInvalidationMonitor" Value="false" />
<Property Name="ESIEnableToPassCookies" Value="false" />
<Property Name="PluginInstallRoot" Value="c:\Program Files\IBM\WebSphere\Plugins\" />
  • <VirtualHostGroup Name="default_host">
<VirtualHost Name="*:8008" />
<VirtualHost Name="*:82" />
<VirtualHost Name="*:9443" />
<VirtualHost Name="*:5060" />
<VirtualHost Name="*:5061" />
<VirtualHost Name="*:443" />
<VirtualHost Name="*:80" />
<VirtualHost Name="*:9080" />
</VirtualHostGroup>
  • <ServerCluster CloneSeparatorChange="false" GetDWLMTable="false" IgnoreAffinityRequests="true" LoadBalance="Round Robin" Name="dmgr_ctgCellManager01_Cluster" PostBufferSize="64" PostSizeLimit="-1" RemoveSpecialHeaders="true" RetryInterval="60">
<Server ConnectTimeout="0" ExtendedHandshake="false" MaxConnections="-1" Name="ctgCellManager01_dmgr" ServerIOTimeout="0" WaitForContinue="false" />
  • <PrimaryServers>
<Server Name="ctgCellManager01_dmgr" />
</PrimaryServers>
</ServerCluster>
  • <ServerCluster CloneSeparatorChange="false" GetDWLMTable="false" IgnoreAffinityRequests="true" LoadBalance="Round Robin" Name="MXServer_ctgNode01_Cluster" PostBufferSize="64" PostSizeLimit="-1" RemoveSpecialHeaders="true" RetryInterval="60">
  • <Server ConnectTimeout="5" ExtendedHandshake="false" MaxConnections="-1" Name="ctgNode01_MXServer" ServerIOTimeout="60" WaitForContinue="false">
<Transport Hostname="2003-SE-Server.ibm.com" Port="9080" Protocol="http" />
  • <Transport Hostname="2003-SE-Server.ibm.com" Port="9443" Protocol="https">
<Property Name="keyring" Value="c:\Program Files\IBM\WebSphere\Plugins\etc\plugin-key.kdb" />
<Property Name="stashfile" Value="c:\Program Files\IBM\WebSphere\Plugins\etc\plugin-key.sth" />
</Transport>
</Server>
  • <PrimaryServers>
<Server Name="ctgNode01_MXServer" />
</PrimaryServers>
</ServerCluster>
  • <UriGroup Name="default_host_MXServer_ctgNode01_Cluster_URIs">
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/*" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/*.jsp" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/*.jsv" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/*.jsw" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/j_security_check" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/IBM_WS_SYS_RESPONSESERVLET/ibm_security_logout" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/*" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/help/*" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/maximo/*" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/mbo/*" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/meaweb/*" />
<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/maxrest/*" />
</UriGroup>
<Route ServerCluster="MXServer_ctgNode01_Cluster" UriGroup="default_host_MXServer_ctgNode01_Cluster_URIs" VirtualHostGroup="default_host" />
  • <RequestMetrics armEnabled="false" loggingEnabled="false" rmEnabled="false" traceLevel="HOPS">
  • <filters enable="false" type="URI">
<filterValues enable="false" value="/snoop" />
<filterValues enable="false" value="/hitcount" />
</filters>
  • <filters enable="false" type="SOURCE_IP">
<filterValues enable="false" value="255.255.255.255" />
<filterValues enable="false" value="254.254.254.254" />
</filters>
  • <filters enable="false" type="JMS">
<filterValues enable="false" value="destination=aaa" />
</filters>
  • <filters enable="false" type="WEB_SERVICES">
<filterValues enable="false" value="wsdlPort=aaa:op=bbb:nameSpace=ccc" />
</filters>
</RequestMetrics>
</Config>

http.conf is in attachments

How can I solve this problem?
Thank you

Attachments

Updated on 2013-01-25T07:06:45Z at 2013-01-25T07:06:45Z by SystemAdmin
  • gas
    gas
    948 Posts

    Re: 404 page not found smartcloud control desk

    ‏2013-01-23T13:16:46Z  
    Hi,

    Looks like plugin is not recognizing /maximo URI.

    Ensure that this is the correct plugin-cfg.xml file (have you configured webserver1 in console and propagated config correctly?):
    WebSpherePluginConfig "C:\Program Files\IBM\HTTPServer/Plugins/config/webserver1/plugin-cfg.xml"

    as I can see one path pointing to
    C:\Program Files\IBM\*HTTPServer*/Plugins

    and the other pointing to:
    c:\Program Files\IBM\*WebSphere*\Plugins

    if this one is correct you can increase LogLevel to Trace and check http_plugin.log file
    <Log LogLevel="Error" Name="c:\Program Files\IBM\WebSphere\Plugins\logs\http_plugin.log" />
  • SystemAdmin
    SystemAdmin
    37421 Posts

    Re: 404 page not found smartcloud control desk

    ‏2013-01-24T08:25:40Z  
    • gas
    • ‏2013-01-23T13:16:46Z
    Hi,

    Looks like plugin is not recognizing /maximo URI.

    Ensure that this is the correct plugin-cfg.xml file (have you configured webserver1 in console and propagated config correctly?):
    WebSpherePluginConfig "C:\Program Files\IBM\HTTPServer/Plugins/config/webserver1/plugin-cfg.xml"

    as I can see one path pointing to
    C:\Program Files\IBM\*HTTPServer*/Plugins

    and the other pointing to:
    c:\Program Files\IBM\*WebSphere*\Plugins

    if this one is correct you can increase LogLevel to Trace and check http_plugin.log file
    <Log LogLevel="Error" Name="c:\Program Files\IBM\WebSphere\Plugins\logs\http_plugin.log" />
    gas, thank for the answer!

    All required plugin files is in the

    C:\Program Files\IBM\*HTTPServer*\Plugins ( \etc\plugin-key.crl, .kdb, .rdb, .sth )
    C:\Program Files\IBM\*HTTPServer*\Plugins\config\webserver1 contains the same files + plugin-cfg.hml
    http_plugin.log is in C:\Program Files\IBM\*HTTPServer*\Plugins\logs\webserver1

    There is no folder Plugins in c:\Program Files\IBM\*WebSphere*\, only AppServer and UpdateInstaller

    Changing *\HTTPServer* to *\WebSphere* in Webserver1 settings gave nothing.
    When can I change this:
    <Property Name="keyring" Value="c:\Program Files\IBM\WebSphere\Plugins\etc\plugin-key.kdb" />
    <Property Name="stashfile" Value="c:\Program Files\IBM\WebSphere\Plugins\etc\plugin-key.sth" />
    to appropriate location (*\HTTPServer\*)? Tough edit +\WebSphere\Appserver\profiles\ctgAppSrv01\...+\plugin-cfg.xml gave no result

    Shall I somehow generate file which is not exist: C:/Program Files/IBM/HTTPServer/htdocs/*maximo* ?
  • gas
    gas
    948 Posts

    Re: 404 page not found smartcloud control desk

    ‏2013-01-24T10:06:59Z  
    gas, thank for the answer!

    All required plugin files is in the

    C:\Program Files\IBM\*HTTPServer*\Plugins ( \etc\plugin-key.crl, .kdb, .rdb, .sth )
    C:\Program Files\IBM\*HTTPServer*\Plugins\config\webserver1 contains the same files + plugin-cfg.hml
    http_plugin.log is in C:\Program Files\IBM\*HTTPServer*\Plugins\logs\webserver1

    There is no folder Plugins in c:\Program Files\IBM\*WebSphere*\, only AppServer and UpdateInstaller

    Changing *\HTTPServer* to *\WebSphere* in Webserver1 settings gave nothing.
    When can I change this:
    <Property Name="keyring" Value="c:\Program Files\IBM\WebSphere\Plugins\etc\plugin-key.kdb" />
    <Property Name="stashfile" Value="c:\Program Files\IBM\WebSphere\Plugins\etc\plugin-key.sth" />
    to appropriate location (*\HTTPServer\*)? Tough edit +\WebSphere\Appserver\profiles\ctgAppSrv01\...+\plugin-cfg.xml gave no result

    Shall I somehow generate file which is not exist: C:/Program Files/IBM/HTTPServer/htdocs/*maximo* ?
    > Shall I somehow generate file which is not exist: C:/Program Files/IBM/HTTPServer/htdocs/*maximo* ?
    No, do not create this file, as they should be served from WAS

    Login to DMgr WAS administrative console and fix webserver1 configuration (remove it and create again as it looks like it points to c:\Program Files\IBM\WebSphere\Plugins as plugin home, instead of C:\Program Files\IBM\*HTTPServer*\Plugins\

    While you are recreating webserver1 config, ensure that all applications are mapped to this webserver.

    Generate and propagate plugin file.

    Ensure that path to the plugin-cfg.xml file in the httpd.conf file points to the correct file.

    If you will still have problems, stop http server, change LogLevel to Trace, remove http_plugin.log, access maximo url again and put http_plugin.log file here.
  • SystemAdmin
    SystemAdmin
    37421 Posts

    Re: 404 page not found smartcloud control desk

    ‏2013-01-24T13:21:31Z  
    • gas
    • ‏2013-01-24T10:06:59Z
    > Shall I somehow generate file which is not exist: C:/Program Files/IBM/HTTPServer/htdocs/*maximo* ?
    No, do not create this file, as they should be served from WAS

    Login to DMgr WAS administrative console and fix webserver1 configuration (remove it and create again as it looks like it points to c:\Program Files\IBM\WebSphere\Plugins as plugin home, instead of C:\Program Files\IBM\*HTTPServer*\Plugins\

    While you are recreating webserver1 config, ensure that all applications are mapped to this webserver.

    Generate and propagate plugin file.

    Ensure that path to the plugin-cfg.xml file in the httpd.conf file points to the correct file.

    If you will still have problems, stop http server, change LogLevel to Trace, remove http_plugin.log, access maximo url again and put http_plugin.log file here.
    Thank you, gas!
    I rebuilt webserver1, changed in httpd.conf location of plugin-cfg and I moved further!

    Now I receive "HTTP 500 Internal Server Error",
    Error.log contains
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: WebSphere Plugins loaded.
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: --------------------Plugin Information-----------------------
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld version: 7.0.0
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld date: Apr 6 2011, 01:33:06
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Webserver: IBM_HTTP_Server
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header:
    Thu Jan 24 07:25:42 2013 notice Using config file C:/Program Files/IBM/HTTPServer/conf/httpd.conf
    Thu Jan 24 07:25:42 2013 notice Child 3968: Child process is running
    Thu Jan 24 07:25:42 2013 notice Child 3968: Acquired the start mutex.
    Thu Jan 24 07:25:42 2013 notice Child 3968: Starting 600 worker threads.
    Thu Jan 24 07:25:42 2013 notice Child 3968: Starting thread to listen on port 82.

    At the installation of Middleware I changed httpserver port from 80 to 82 (80 was busy)

    In appserver console I added port 82 to default_host and didn't delete port 80
    Also I added port 8008 (administrative server) (in admin_error.log also failed listening on port 8008)
    Then updated global Web server plug-in configuration and ensured that default_host is chosen to all apps (MAXIMO and MXIEHS)

    Appserver console -> Application Servers -> MXServers -> Ports looks this way:

    BOOTSTRAP_ADDRESS 2003-SE-Server.ibm.com 9810 No associated transports
    CSIV2_SSL_MUTUALAUTH_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9406 No associated transports
    CSIV2_SSL_SERVERAUTH_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9405 No associated transports
    DCS_UNICAST_ADDRESS * 9354 View associated transports
    IPC_CONNECTOR_ADDRESS localhost 9633 No associated transports
    ORB_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9102 No associated transports
    SAS_SSL_SERVERAUTH_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9404 No associated
    SIB_ENDPOINT_ADDRESS * 7276 View associated
    SIB_ENDPOINT_SECURE_ADDRESS * 7286 View associated
    SIB_MQ_ENDPOINT_ADDRESS * 5558 View associated
    SIB_MQ_ENDPOINT_SECURE_ADDRESS * 5578 View associated
    SIP_DEFAULTHOST * 5060 View associated
    SIP_DEFAULTHOST_SECURE * 5061 View associated
    SOAP_CONNECTOR_ADDRESS 2003-SE-Server.ibm.com 8880 No associated
    WC_adminhost * 9061 View associated
    WC_adminhost_secure * 9044 View associated transports
    WC_defaulthost * 9080 View associated transports
    WC_defaulthost_secure * 9443 View associated transports

    I changed ports WC_adminhost from 9061 to 8008 and WC_defaulthost from 9080 to 82 - no result (HTTP 500), so I returned previous values

    May be I missed some places when port have to be changed?
  • gas
    gas
    948 Posts

    Re: 404 page not found smartcloud control desk

    ‏2013-01-24T13:53:18Z  
    Thank you, gas!
    I rebuilt webserver1, changed in httpd.conf location of plugin-cfg and I moved further!

    Now I receive "HTTP 500 Internal Server Error",
    Error.log contains
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: WebSphere Plugins loaded.
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: --------------------Plugin Information-----------------------
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld version: 7.0.0
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Bld date: Apr 6 2011, 01:33:06
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header: Webserver: IBM_HTTP_Server
    Thu Jan 24 07:25:42 2013 notice PLUGIN: mod_was_ap22_http: apache_log_header:
    Thu Jan 24 07:25:42 2013 notice Using config file C:/Program Files/IBM/HTTPServer/conf/httpd.conf
    Thu Jan 24 07:25:42 2013 notice Child 3968: Child process is running
    Thu Jan 24 07:25:42 2013 notice Child 3968: Acquired the start mutex.
    Thu Jan 24 07:25:42 2013 notice Child 3968: Starting 600 worker threads.
    Thu Jan 24 07:25:42 2013 notice Child 3968: Starting thread to listen on port 82.

    At the installation of Middleware I changed httpserver port from 80 to 82 (80 was busy)

    In appserver console I added port 82 to default_host and didn't delete port 80
    Also I added port 8008 (administrative server) (in admin_error.log also failed listening on port 8008)
    Then updated global Web server plug-in configuration and ensured that default_host is chosen to all apps (MAXIMO and MXIEHS)

    Appserver console -> Application Servers -> MXServers -> Ports looks this way:

    BOOTSTRAP_ADDRESS 2003-SE-Server.ibm.com 9810 No associated transports
    CSIV2_SSL_MUTUALAUTH_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9406 No associated transports
    CSIV2_SSL_SERVERAUTH_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9405 No associated transports
    DCS_UNICAST_ADDRESS * 9354 View associated transports
    IPC_CONNECTOR_ADDRESS localhost 9633 No associated transports
    ORB_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9102 No associated transports
    SAS_SSL_SERVERAUTH_LISTENER_ADDRESS 2003-SE-Server.ibm.com 9404 No associated
    SIB_ENDPOINT_ADDRESS * 7276 View associated
    SIB_ENDPOINT_SECURE_ADDRESS * 7286 View associated
    SIB_MQ_ENDPOINT_ADDRESS * 5558 View associated
    SIB_MQ_ENDPOINT_SECURE_ADDRESS * 5578 View associated
    SIP_DEFAULTHOST * 5060 View associated
    SIP_DEFAULTHOST_SECURE * 5061 View associated
    SOAP_CONNECTOR_ADDRESS 2003-SE-Server.ibm.com 8880 No associated
    WC_adminhost * 9061 View associated
    WC_adminhost_secure * 9044 View associated transports
    WC_defaulthost * 9080 View associated transports
    WC_defaulthost_secure * 9443 View associated transports

    I changed ports WC_adminhost from 9061 to 8008 and WC_defaulthost from 9080 to 82 - no result (HTTP 500), so I returned previous values

    May be I missed some places when port have to be changed?
    > I changed ports WC_adminhost from 9061 to 8008 and WC_defaulthost from 9080 to 82 - no result (HTTP 500), so I returned previous values

    Unfortunately these changes are not correct ;-)
    Leave WC_adminhost as 9061.
    8008 is admin port of the IHS not WAS (defined in the admin.conf if I remember correctly). To start IHS admin server go to:
    c:\prog files\ibm\htttpserver\bin
    and run:
    > adminctl start
    You should also have Http admin service in Windows services, if you installed it as service. (this service is only available for IHS, so if you have plain Apache it wont be available).

    Leave WC_defaulthost as 9080, if you change it to 82 either WAS or IHS will not start as they would conflict against using same port.
    82 is a port on which HTTP server listens (not WAS), and then forwards these requests to WAS.
    If 80 port is busy on your machine, it would suggest that you already have some other HTTP server installed.

    So unfrotunately you have to rollback some changes ;-)
    And if your HTTP server listnes on 82 port you need to access maximo using:
    http://yourHost:82/maximo (must use port as it is not default 80)

    Gas
  • SystemAdmin
    SystemAdmin
    37421 Posts

    Re: 404 page not found smartcloud control desk

    ‏2013-01-25T07:06:45Z  
    • gas
    • ‏2013-01-24T13:53:18Z
    > I changed ports WC_adminhost from 9061 to 8008 and WC_defaulthost from 9080 to 82 - no result (HTTP 500), so I returned previous values

    Unfortunately these changes are not correct ;-)
    Leave WC_adminhost as 9061.
    8008 is admin port of the IHS not WAS (defined in the admin.conf if I remember correctly). To start IHS admin server go to:
    c:\prog files\ibm\htttpserver\bin
    and run:
    > adminctl start
    You should also have Http admin service in Windows services, if you installed it as service. (this service is only available for IHS, so if you have plain Apache it wont be available).

    Leave WC_defaulthost as 9080, if you change it to 82 either WAS or IHS will not start as they would conflict against using same port.
    82 is a port on which HTTP server listens (not WAS), and then forwards these requests to WAS.
    If 80 port is busy on your machine, it would suggest that you already have some other HTTP server installed.

    So unfrotunately you have to rollback some changes ;-)
    And if your HTTP server listnes on 82 port you need to access maximo using:
    http://yourHost:82/maximo (must use port as it is not default 80)

    Gas
    Port 80 in use by System process, there is routine way to make free port 80, so I chose port 82.

    I always start maximo using http://host:82/maximo

    What I figured out: attempts to start httpserver and adminserver now stop on threading to listen on port (82&8008)

    Maybe some settings corrupted, where can I check it? Maybe reinstall httpserver?

    Gas, thanks a lot, You really help me very much!