Topic
4 replies Latest Post - ‏2013-02-26T08:55:34Z by imsiva
PRDUSER
PRDUSER
5 Posts
ACCEPTED ANSWER

Pinned topic Seeing SRVE0133E exceptions in systemout.logs when the server is busy

‏2013-01-18T17:49:14Z |
E com.ibm.ws.webcontainer.srt.SRTServletRequest parseParameters SRVE0133E: An error occurred while parsing parameters. {0}
java.io.IOException: Async IO operation failed (3), reason: RC: 107 Transport endpoint is not connected
at com.ibm.io.async.AsyncLibrary$IOExceptionCache.<init>(AsyncLibrary.java:891)
at com.ibm.io.async.AsyncLibrary$IOExceptionCache.get(AsyncLibrary.java:904)
at com.ibm.io.async.AsyncLibrary.getIOException(AsyncLibrary.java:918)
at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:705)
at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)

We are seeing this errors in the server systemout logs during peak load, did anyone encountered this problem and fixed it? or someone know the root cause of this problem, please suggest.
We tried with ConnectionIOTimeOut set for 10 seconds at the webcontainer >> custom properties, still we see the issue.
Updated on 2013-02-26T08:55:34Z at 2013-02-26T08:55:34Z by imsiva
  • SystemAdmin
    SystemAdmin
    30899 Posts
    ACCEPTED ANSWER

    Re: Seeing SRVE0133E exceptions in systemout.logs when the server is busy

    ‏2013-02-01T09:14:18Z  in response to PRDUSER
    I guess the issue is with the timeout of the request which happens during the server busy.
    You can try the following solution:-

    Increase the value of the ConnectionIOTimeOut parameter to avoid receiving an exception on the server.

    For the Dashboard WebSphere_Portal application server:
    Log into the administrative console for the WebSphere Portal node.
    To change the timeout values for the WebSphere_Portal application server:
    Click Application Servers > WebSphere_Portal > Web container settings > web container transport chains.
    Increase the timeout values. For each entry listed in the web container transport chains section, complete the following steps to increase the timeout values:

    Click HTTP Inbound Channel.
    Change the Read timeout value to 180.
    Change the Write timeout value to 180.
    Save the configuration changes.

    Hope this solves the issue.
    • PRDUSER
      PRDUSER
      5 Posts
      ACCEPTED ANSWER

      Re: Seeing SRVE0133E exceptions in systemout.logs when the server is busy

      ‏2013-02-01T16:06:38Z  in response to SystemAdmin
      Thanks for your response.
      One question on the suggestion.
      Are you suggesting to change ConnectionIOTimeOut value also for each entry listed in the web container transport chains section..?
      • SystemAdmin
        SystemAdmin
        30899 Posts
        ACCEPTED ANSWER

        Re: Seeing SRVE0133E exceptions in systemout.logs when the server is busy

        ‏2013-02-05T05:55:25Z  in response to PRDUSER
        Yes.For each entry listed in the web container transport chains section, complete the steps to increase the timeout values.
  • imsiva
    imsiva
    1 Post
    ACCEPTED ANSWER

    Re: Seeing SRVE0133E exceptions in systemout.logs when the server is busy

    ‏2013-02-26T08:55:34Z  in response to PRDUSER
    Hi,

    I'm facing the same problem in my prod environment. Has the increase in timeout resolved your problem ? Please let me know if there was any alternate solution take care for this issue.

    Regards,
    Siva.