Topic
3 replies Latest Post - ‏2013-01-17T15:27:42Z by vica
SystemAdmin
SystemAdmin
270 Posts
ACCEPTED ANSWER

Pinned topic Getting "Forbidden: DFHWU4301" on single region login

‏2013-01-17T14:03:23Z |
CICS Explorer works fine with our WUI's, but when I try to set up a region to accept a login, it fails, as stated in the title. All the CO* and CWXN transactions needed are set up for use. Tried the DFH$WUTC TCPIP service with both authenticate NO and BASIC.

CICS/TS 4.2, CICS Explorer 1.1.1.3
Updated on 2013-01-17T15:27:42Z at 2013-01-17T15:27:42Z by vica
  • SystemAdmin
    SystemAdmin
    270 Posts
    ACCEPTED ANSWER

    Re: Getting "Forbidden: DFHWU4301" on single region login

    ‏2013-01-17T14:05:27Z  in response to SystemAdmin
    Should also mention the region is part of a CICSPlex and a CPSM workload.
  • SystemAdmin
    SystemAdmin
    270 Posts
    ACCEPTED ANSWER

    Re: Getting "Forbidden: DFHWU4301" on single region login

    ‏2013-01-17T14:59:46Z  in response to SystemAdmin
    My experience has been that if a region is being managed by CPSM, there is no way to connect the CICS Explorer directly to the region. You must manage the region through the Explorer's connection to the WUI. I suppose there's really no need to be able to connect directly to a managed region.

    With that said, I really wish you were given a better message than just "Forbidden". Heck -- how difficult could it be to simply return a message that says the region is managed & therefore you must connect to the WUI.
  • vica
    vica
    6 Posts
    ACCEPTED ANSWER

    Re: Getting "Forbidden: DFHWU4301" on single region login

    ‏2013-01-17T15:27:42Z  in response to SystemAdmin
    Hmm interesting I thought that worked? Has the region been given the setup that it needs to connect directly, did you enable TCPIP in the region and define a unique port in TCPIPS for the single region? If you used the CICS supplied definition it uses port 1490 if that port is already being used for the CPSM connection to the WUI Server perhaps that is causing the issue.