Topic
  • 8 replies
  • Latest Post - ‏2013-01-28T17:02:26Z by lisaw
Bleddyn
Bleddyn
30 Posts

Pinned topic Patching WAS 6 client with WXS 8.5 to Fixpack 1

‏2013-01-16T17:01:16Z |
Hi,

I have installed the WAS 6 client for 8.5 using the InstallManager. I have then downloaded the WAS 6 client file update and I have tried installing it. However nothing is getting picked up. I cannot make a remote connection from the machines I am using so I have disabled the service lookup. It was tryng to get there based on the message that it was getting and looking at the xml file I can see the definition. But to install the fixpack will it need to make a remote connection? As I say with service lookup disabled it just says it cannot find any fixes.

Thanks Bleddyn
Updated on 2013-01-28T17:02:26Z at 2013-01-28T17:02:26Z by lisaw
  • lisaw
    lisaw
    101 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-16T21:34:53Z  
    It sounds like you have installed WXS 8.5.0.0 client on top of a WebSphere Application Server V6. That worked for you. Now you want to upgrade to WXS fix pack 8.5.0.1.

    In Installation Manager:

    • Add your repository that has the 8.5.0.1 fix pack by clicking File->Preferences->Repositories and add the zip file you downloaded.
    • Click the update button.
    • Select the package group name that has your WAS6 + WXS8.5 already installed.
    • You should see the update packages available for you then, such as IBM WebSphere eXtreme Scale Client for WebSphere Application Server V6 - Version 8.5.0.1
    • Accept the license agreement, and select the features to install
    • Click Update

    Let me know if you have an error following these steps.

    • Lisa

    Websphere eXtreme Scale Development
  • Bleddyn
    Bleddyn
    30 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-16T22:12:55Z  
    • lisaw
    • ‏2013-01-16T21:34:53Z
    It sounds like you have installed WXS 8.5.0.0 client on top of a WebSphere Application Server V6. That worked for you. Now you want to upgrade to WXS fix pack 8.5.0.1.

    In Installation Manager:

    • Add your repository that has the 8.5.0.1 fix pack by clicking File->Preferences->Repositories and add the zip file you downloaded.
    • Click the update button.
    • Select the package group name that has your WAS6 + WXS8.5 already installed.
    • You should see the update packages available for you then, such as IBM WebSphere eXtreme Scale Client for WebSphere Application Server V6 - Version 8.5.0.1
    • Accept the license agreement, and select the features to install
    • Click Update

    Let me know if you have an error following these steps.

    • Lisa

    Websphere eXtreme Scale Development
    Hi Lisa,

    Yes I installed the WXS 8.5.0.0 client from the installation manager, I first removed the 7.1.1.0 version that was on there. That install worked fine but as yet I have not added the WXS 8.5.0 code into my websphere application server config.

    I then added in the repository where I had extracted the client file that I downloaded from here

    http://www-01.ibm.com/support/docview.wss?uid=swg24032847

    I got the 8.5.0-WS-WXS-WAS6-FP0000001.zip file.

    As I mentioned if I leave the option checked for it to make a remote connection under the repository config, then I know its checking the repository because it tells me it can't reach the site within the repository xml definition. So I turned off the remote access and then it just straight away tells me that there is no update available.

    Thanks Bleddyn
  • Bleddyn
    Bleddyn
    30 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-17T13:10:03Z  
    Hi Lisa,

    I have tried editing the repository.xml file and removing the link thats in there. But it appeared to still read from somewhere that there is a remote location for it to connect to. I can't see why the two things are not matching up. I was able to go and augment the WXS profile into my existing WAS 6.1 profile so I know that 8.5 is there fine. I just can't see why it won't install that fixpack?

    Bleddyn
  • lisaw
    lisaw
    101 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-18T17:13:17Z  
    • Bleddyn
    • ‏2013-01-17T13:10:03Z
    Hi Lisa,

    I have tried editing the repository.xml file and removing the link thats in there. But it appeared to still read from somewhere that there is a remote location for it to connect to. I can't see why the two things are not matching up. I was able to go and augment the WXS profile into my existing WAS 6.1 profile so I know that 8.5 is there fine. I just can't see why it won't install that fixpack?

    Bleddyn
    The eXtreme Scale Client for Websphere Application Server V6 must be installed in the same folder of WebSphere Application V6.1

    You can also validate this by going into your WebSphere Application Server and running version info. <WAS61_INSTALL>/bin/versionInfo

    
    -------------------------------------------------------------------------------- Name                     IBM WebSphere Application Server - ND Version                  6.1.0.45 ID                       ND Installed Product -------------------------------------------------------------------------------- Name                     IBM WebSphere eXtreme Scale Version                  8.5.0.0 ID                       WXS --------------------------------------------------------------------------------
    


    You can potentially see errors in the Installation Manager log by going to file->view log. Open the log by clicking the rightmost icon on the top. This might help you debug why it can't find an update.

    eXtreme Scale fix pack 3 will be out very shortly, watch the forum for the link, so you may wish to try that as well.

    • Lisa

    Websphere eXtreme Scale Development
  • Bleddyn
    Bleddyn
    30 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-28T16:16:15Z  
    Hi Lisa,

    I have been away last week just looked and I see Fixpack 3 is out for 8.5 .

    I have downloaded it though and get exactly the same issue.

    I say update and it shows me thatI have IBM WXS Client installed for WebSphere Application Server V6 8.5.0.0.

    But it then says that it can't find any fixes.

    Thanks Bleddyn
  • Bleddyn
    Bleddyn
    30 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-28T16:23:07Z  
    Hi Lisa,

    A couple of other things

    When I run versionInfo I see

    WAS ND is at 6.1.0.41

    WXS is at

    8.5.0.0

    Build Level a1216.20150800
    Build Date 4/20/12

    I tried file and view but there are no errors apart from when I let it try the remote connection. That just says it cannot find www.ibm.com but thats not surprising because the boxes cannot see the Internet all they should get is the local repository I have setip.

    Thanks Bleddyn
  • Bleddyn
    Bleddyn
    30 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-28T16:32:03Z  
    Hi,

    Sorry for all the updates to anyone getting the feed of messages.

    I just noticed that if I say install rather than update the repository is being read as it tells me that its 8.5.0.3 that is there. However I can't install into the same location. So just making sure here should I be uninstalling 8.5.0.0 first then reinstalling 8.5.0.3, rather than just selecting the update option, which seemed so obvious with a fixpack? That seems a little extreme given its a fixpack but at least I know the repository is fine also the docs say update so why can install work and update fail?

    Thanks Bleddyn
  • lisaw
    lisaw
    101 Posts

    Re: Patching WAS 6 client with WXS 8.5 to Fixpack 1

    ‏2013-01-28T17:02:26Z  
    • Bleddyn
    • ‏2013-01-28T16:32:03Z
    Hi,

    Sorry for all the updates to anyone getting the feed of messages.

    I just noticed that if I say install rather than update the repository is being read as it tells me that its 8.5.0.3 that is there. However I can't install into the same location. So just making sure here should I be uninstalling 8.5.0.0 first then reinstalling 8.5.0.3, rather than just selecting the update option, which seemed so obvious with a fixpack? That seems a little extreme given its a fixpack but at least I know the repository is fine also the docs say update so why can install work and update fail?

    Thanks Bleddyn
    The "update button" path is the correct one, however, since there is no errors to go off of, it's hard to see why it is not allowing you to update.

    In this process I tried updating my own machine with similar WAS and WXS versions at the same time using IM 1.6.1 on a Windows 7 machine and it found the update and worked.

    If you can workaround this issue by uninstalling and installing, I would let you know the drawbacks. If you have profiles augmented with eXtreme Scale, they will be unaugmented and then you will have to re-configure them. Once you reinstall, the profiles can be augmented again. If you are simply using the wsogclient jar in an application, this probably won't matter. If you happen to have catalog service domains configured, sessions created, the wxs resources adapter configured, or created catalog or container servers in WAS itself, etc, that means your WAS configuration probably should be backed up since it will be blown away.

    If you backupConfig your cell, and do a restoreConfig on it, you might be able to workaround your update problem.

    I would of course test this out on a test server to make sure nothing is lost before you start uninstalling on production. The best case is also to figure out why the update still isn't working, and may be a corrupted installation of WAS+WXS to begin with or IM is the issue.

    • Lisa

    Websphere eXtreme Scale Development