Topic
4 replies Latest Post - ‏2013-01-18T15:08:13Z by JohnKnutson
bluejoni2306
bluejoni2306
19 Posts
ACCEPTED ANSWER

Pinned topic CICS 5.1 and CICS Explorer

‏2013-01-16T05:16:26Z |
We will be moving to from CICS 3.2 shortly and currently run PD Tools V11 on Z/os v1.13

If we go CICS 5.1 from what I can work out, we will need to go CICS Explorer 5.1 (which requires PD tools at V12) first ; So the process of upgrade will be :

Update PD Tools from V11 to V12 for
IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for z/OS V12.1, or later
IBM Fault Analyzer for z/OS, V12.1, or later
IBM File Manager for z/OS V12.1, or later

Upgrade CICS Explorer from CICS Explorer 1.3 to 5.1

Upgrade CICS from 3.2 to 5.1

*bold*IS THIS CORRECT? or is Cics Explorer 5.1 downward compatible with CICS 3.2 and Z/os PD Tools V11?
*bold*Where do I find this information online?

Link: URL http://www-01.ibm.com/support/docview.wss?rs=1083&uid=swg24033579
This is cross reference information but does not include PD tools

Link: URL http://www-01.ibm.com/software/htp/cics/explorer/requirements/
This is the requirements page but does not include PD Tools

Link: URL http://www-01.ibm.com/support/docview.wss?uid=swg21577571
This is cross reference information but des not include the PD tools on Z/os
Updated on 2013-01-18T15:08:13Z at 2013-01-18T15:08:13Z by JohnKnutson
  • JohnKnutson
    JohnKnutson
    126 Posts
    ACCEPTED ANSWER

    Re: CICS 5.1 and CICS Explorer

    ‏2013-01-16T11:23:11Z  in response to bluejoni2306
    Hi Bluejon - I hope that I can help - things should be much easier than you think.

    1. CICS Explorer V5.1 supports all prior releases of CICS TS - V3.1, V3.2, V4.1, V4.2, as well as VSE.
    2. CICS Explorer V5.1 does NOT pre-req PD Tools V12 plug-ins, though it does come preloaded with the URL of the PD Tools V12 update site. However, I see no reason why you shouldn't install the V11 plug-ins, which you can download from here http://www-01.ibm.com/software/awdtools/deployment/pdtplugins/. You won't need to update your PD Tools right away - though you will probably need to move to V12 to get their support for CICS TS V5.1.

    You are correct to point out that the PD Tools pages don't show the the PD Tools CICS Explorer requirements, I'll speak to the PD Tools team about that. For info, the PD Tools didn't start to tightly integrate with CICS Explorer until V12, before that they simply shell-shared, so they would run in most versions of CICS Explorer. With V12, they now use the CICS Explorer connection framework, and V12 is dependent on CICS Explorer V5.1. The V12 plug-ins are also dependent on the V12 PD Tools server code, in particular, the new V12 common server component.

    So, it sounds like a reasonable upgrade plan would be:
    1. Upgrade to CICS Explorer V5.1
    2. Install and use the PD Tools V11 plug-ins
    3. Upgrade PD Tools server and plug-ins to V12
    4. Upgrade to CICS TS V5.1

    I'll ask one of the PD Tools team to comment on whether you should / can upgrade the PD Tools one at a time or all at once.

    Post back if you have more questions.

    John
    • kevmeist
      kevmeist
      249 Posts
      ACCEPTED ANSWER

      Re: CICS 5.1 and CICS Explorer

      ‏2013-01-16T11:46:47Z  in response to JohnKnutson
      I can confirm some of what John says. We are running Explorer V5.1 with PA V3.2 on the mainframe and the PA V5.1 plugin in Explorer. I haven't seen any issues with that so far. We do not run DT with CICS Explorer (we use RD/z with DT V11 currently though), so cannot confirm that.

      Having the update sites pre-loaded in Explorer V5.1 certainly made upgrading to the PA V5.1 plugin much easier.

      Our sysprogs are downloaded PA V5.1 (mainframe) for installation. They are also in the midst of installing DT V12 although I don't have that available to me yet.

      John K.....maybe when you announce future versions of CICS EXplorer...you can provide a cheat sheet for which versions are current for plugins in a single place (maybe with a pinned post to these forums)?

      Regards,

      Kevin
    • bluejoni2306
      bluejoni2306
      19 Posts
      ACCEPTED ANSWER

      Re: CICS 5.1 and CICS Explorer

      ‏2013-01-18T03:50:26Z  in response to JohnKnutson
      Thx John,

      So will CICS TS V5.1 and CICS Explorer V5.1 both work with PD tools V11?

      ie. we could leave the upgrade of PD tools from V11 to V12 until after the CICS TS 5.1 upgrade?

      i.e.

      1. Upgrade to CICS Explorer V5.1
      2. Install and use the PD Tools V11 plug-ins
      3. Upgrade to CICS TS V5.1
      4. Upgrade PD Tools server and plug-ins to V12
      If not what is the dependancy?

      Regards Joni
      • JohnKnutson
        JohnKnutson
        126 Posts
        ACCEPTED ANSWER

        Re: CICS 5.1 and CICS Explorer

        ‏2013-01-18T15:08:13Z  in response to bluejoni2306
        Joni, Looks like you can defer most of the PD Tools upgrades - only APA must be at V12. This from the PD Tools team:

        All the PD Tools V11's except APA support CICS TS 5.1
        Specifically...
        Application Performance Analyzer V12 PTF PM73601
        Debug Tool V12 PTF UK90229 V11 PTF UK90228
        Workload Simulator No specific version / maintenance needed
        File Manager No specific version / maintenance needed
        Fault Analyzer V12 PTF UK83720 V11 PTF UK83847