Topic
  • 1 reply
  • Latest Post - ‏2013-01-16T08:04:05Z by fjb_saper
SystemAdmin
SystemAdmin
4179 Posts

Pinned topic XSLT 2.0 in WMB 8

‏2013-01-15T21:53:19Z |
Hi,
Does WMB 8.0 support XSLT 2.0? Documentation says it supports XSLT 2.0 as well as XSL 2.0. When I used the stylesheet with xslt version = "2.0", I got this error.

Stylesheet declaration:

<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
version="2.0"
>
Error:
RecoverableException File:CHARACTER:XMLTransformNode.java Line:INTEGER:987 Function:CHARACTER:transformData Type:CHARACTER: Name:CHARACTER: Label:CHARACTER: Catalog:CHARACTER:BIPmsgs Severity:INTEGER:3 Number:INTEGER:4447 Text:CHARACTER:Error during transformation Insert Type:INTEGER:5 Text:CHARACTER:SUB_INVOKE_SERVICE.Xform to Service Message Insert Type:INTEGER:5 Text:CHARACTER:Transformation failure when processing Stylesheet *********.xsl
javax.xml.transform.TransformerConfigurationException: Could not compile stylesheet
at org.apache.xalan.xsltc.trax.TransformerFactoryImpl.newTemplates(TransformerFactoryImpl.java:866)
at com.ibm.xsl.exmlt.StylesheetCache.preprocessStylesheet(StylesheetCache.java:740)
at com.ibm.xsl.exmlt.StylesheetCache.getPreprocessedStylesheet(StylesheetCache.java:644)

Anyone have any ideas?

Appreciate everyone's help.
Updated on 2013-01-16T08:04:05Z at 2013-01-16T08:04:05Z by fjb_saper
  • fjb_saper
    fjb_saper
    125 Posts

    Re: XSLT 2.0 in WMB 8

    ‏2013-01-16T08:04:05Z  
    Did you deploy the XSLT node "vanilla"?
    I believe you have to specify on the node that you want it to use the 2.0 level, otherwise it is by default 1.0