Topic
  • 6 replies
  • Latest Post - ‏2013-01-17T13:58:24Z by SystemAdmin
SystemAdmin
SystemAdmin
5842 Posts

Pinned topic When view attachment,it redirects to start center

‏2013-01-15T17:41:38Z |
Hello Dears ,

i'm facing a problem with attachments
i followed the Maximo Asset Management Administration , but after uploading attachment , when i try to view it , the browser automatically redirect me to start center , i tried to reconfigure attachments properties but with no hope ,

Note : the uploading process is working correctly as when i open doclinks/attachments folder , i find the file in it

can you please help me in this issue ?

System Information :
App Server IBM WebSphere Application Server 7.0

Version IBM Maximo Asset Management 7.5.0.1 Build 20111019-1635 DB Build V7501-00
Tivoli's process automation engine 7.5.0.1 Build 20111019-1635 DB Build V7501-134

Server OS Windows Server 2008 6.0 build 6002 Service Pack 2

Server DB DB2/NT 9.7 (SQL09074)
Thanks in Advance
Updated on 2013-01-17T13:58:24Z at 2013-01-17T13:58:24Z by SystemAdmin
  • SASHULL
    SASHULL
    302 Posts

    Re: When view attachment,it redirects to start center

    ‏2013-01-16T00:34:44Z  
    If the file is being uploaded to the server fine, that means the issue is most likely related to the mxe.doclink.path01 property OR isn't properly configured in Microsoft IIS or IBM HTPPServer. The property takes the file path in the docinfo table and translates it into a URL.

    For instance:
    System Properties
    mxe.doclink.doctypes.defpath & mxe.doclink.doctypes.topLevelPaths = C:\Doclinks
    mxe.doclink.path01 = C:\Doclinks=https://myURL.com/doclinks

    In the DOCINFO table in the URLNAME field you would see a value like
    C:\Doclinks\ATTACHMENTS\Attachment.pdf

    Maximo converts that into a web accessible URL to access the file and the mxe.doclink.path01 property is that converter. In the previous attachment, Maximo would convert the URL to be:
    https://myURL.com/doclinks/ATTACHMENTS/Attachment.pdf

    This requires, however, that your web server (Microsoft IIS or IBM HTTP Server) is configured to handle the /doclinks extension. IBM mentions how to do it for HTTP Server in the Install Guide so I will leave that information out but for IIS you simply need to create a virtual directory to the doclink directory.
    The other option, and more secure option, is to set the mxe.doclink.securedAttachment System Property to true. What this does is it will no longer use the URL mapping of mxe.doclink.path01 and will instead show the user a Maximo URL (such as https://myURL.com/maximo/....) and Maximo will access and serve up the file. This would mean that IIS/HTTP Server would not need to be configured to handle the virtual directory /doclinks.

    The important advantage of this is (outside of simply solving your issue) is that if you enable the urls (like /doclinks), ANYONE can access the files that can connect to your Maximo server (which is global unless you have it IP restricted, then it's still everyone in your organization that can connect from those IP addresses). Maximo security isn't used to verify whether or not the user should be able to download the file. If there was a confidential record in Maximo that only a few users could see, that had DOCLINKS attached, someone could guess the filename and they would then be able to download the file without issue. By not configuring IIS/HTTP Server to enable the /doclinks to be accessible, you will no longer have that issue (this still doesn't prevent users who have physical access to the server from viewing the files, that's expected to be addressed in a future release by storing DOCLINKS in Maximo tables, but still greatly mitigates the risk).
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: When view attachment,it redirects to start center

    ‏2013-01-16T11:38:34Z  
    • SASHULL
    • ‏2013-01-16T00:34:44Z
    If the file is being uploaded to the server fine, that means the issue is most likely related to the mxe.doclink.path01 property OR isn't properly configured in Microsoft IIS or IBM HTPPServer. The property takes the file path in the docinfo table and translates it into a URL.

    For instance:
    System Properties
    mxe.doclink.doctypes.defpath & mxe.doclink.doctypes.topLevelPaths = C:\Doclinks
    mxe.doclink.path01 = C:\Doclinks=https://myURL.com/doclinks

    In the DOCINFO table in the URLNAME field you would see a value like
    C:\Doclinks\ATTACHMENTS\Attachment.pdf

    Maximo converts that into a web accessible URL to access the file and the mxe.doclink.path01 property is that converter. In the previous attachment, Maximo would convert the URL to be:
    https://myURL.com/doclinks/ATTACHMENTS/Attachment.pdf

    This requires, however, that your web server (Microsoft IIS or IBM HTTP Server) is configured to handle the /doclinks extension. IBM mentions how to do it for HTTP Server in the Install Guide so I will leave that information out but for IIS you simply need to create a virtual directory to the doclink directory.
    The other option, and more secure option, is to set the mxe.doclink.securedAttachment System Property to true. What this does is it will no longer use the URL mapping of mxe.doclink.path01 and will instead show the user a Maximo URL (such as https://myURL.com/maximo/....) and Maximo will access and serve up the file. This would mean that IIS/HTTP Server would not need to be configured to handle the virtual directory /doclinks.

    The important advantage of this is (outside of simply solving your issue) is that if you enable the urls (like /doclinks), ANYONE can access the files that can connect to your Maximo server (which is global unless you have it IP restricted, then it's still everyone in your organization that can connect from those IP addresses). Maximo security isn't used to verify whether or not the user should be able to download the file. If there was a confidential record in Maximo that only a few users could see, that had DOCLINKS attached, someone could guess the filename and they would then be able to download the file without issue. By not configuring IIS/HTTP Server to enable the /doclinks to be accessible, you will no longer have that issue (this still doesn't prevent users who have physical access to the server from viewing the files, that's expected to be addressed in a future release by storing DOCLINKS in Maximo tables, but still greatly mitigates the risk).
    Dear SASHULL ,

    Many thanks for your reply ,
    when i checked DOCINFO table i found that URLNAME value is \doclinks\attachments\attachment.pdf
    and also when i try to open any attachment , the url is not such as (https://myURL.com/doclinks/ATTACHMENTS/Attachment.pdf) but it looks like

    (https://myURL.com/doclinksATTACHMENTSAttachment.pdf)

    , and after changed the mxe.doclink.securedAttachment property to true , the error changed from redirect to start center to Cann't Display Page

    so , what may cause that ?

    Thanks ,
    Have a nice day / night
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: When view attachment,it redirects to start center

    ‏2013-01-16T16:44:57Z  
    Dear SASHULL ,

    Many thanks for your reply ,
    when i checked DOCINFO table i found that URLNAME value is \doclinks\attachments\attachment.pdf
    and also when i try to open any attachment , the url is not such as (https://myURL.com/doclinks/ATTACHMENTS/Attachment.pdf) but it looks like

    (https://myURL.com/doclinksATTACHMENTSAttachment.pdf)

    , and after changed the mxe.doclink.securedAttachment property to true , the error changed from redirect to start center to Cann't Display Page

    so , what may cause that ?

    Thanks ,
    Have a nice day / night
    For file attached prior the configuration, you must change the path.
    Go to an application that has attachment functionality (i.e. Item).
    From Select Action menu, choose "Attachment Library/Folder -> Manage Library". Here, you can change file path accordingly to you environment.
    Probably, it is necessary to restart the server. Hope this help.

    Regards.
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: When view attachment,it redirects to start center

    ‏2013-01-16T17:04:53Z  
    For file attached prior the configuration, you must change the path.
    Go to an application that has attachment functionality (i.e. Item).
    From Select Action menu, choose "Attachment Library/Folder -> Manage Library". Here, you can change file path accordingly to you environment.
    Probably, it is necessary to restart the server. Hope this help.

    Regards.
    Thanks rvivian , but it doesn't work too , i already attached files after configurations made and the same problem exist
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: When view attachment,it redirects to start center

    ‏2013-01-17T08:35:50Z  
    Thanks rvivian , but it doesn't work too , i already attached files after configurations made and the same problem exist
    Hi Kareem Naguib,

    you say:
    > when I checked DOCINFO table i found that URLNAME value is \doclinks\attachments\attachment.pdf

    so this means that the configuration of document folders is not correct.
    Then, check also the configuration of document folder from select action menu "Attachment Library/Folder -> Manage Folders".

    the "Default File Path" should be C:\Doclinks\ATTACHMENTS. Pay attention: the path is case sensitive. You must specify it using the same upper and lower case of the configured mxe.doclink.doctypes.defpath property (and HTTP configuration too).

    Regards, R.
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: When view attachment,it redirects to start center

    ‏2013-01-17T13:58:24Z  
    Hi Kareem Naguib,

    you say:
    > when I checked DOCINFO table i found that URLNAME value is \doclinks\attachments\attachment.pdf

    so this means that the configuration of document folders is not correct.
    Then, check also the configuration of document folder from select action menu "Attachment Library/Folder -> Manage Folders".

    the "Default File Path" should be C:\Doclinks\ATTACHMENTS. Pay attention: the path is case sensitive. You must specify it using the same upper and lower case of the configured mxe.doclink.doctypes.defpath property (and HTTP configuration too).

    Regards, R.
    Please check the property mxe.doclink.doctypes.defpath and
    Configure the property mxe.doclink.path01 as C<PATH>\DOCLINKS= http://Hostname here only you need to change the hostname(Give the IP address where the documents saved.)

    Then go to Manage folders ( through Select action ) Change the default path as what you gave in mxe.doclink.doctypes.defpath you need to change only file path upto Doclinks remaining will be same.

    Ex: *C:\DOCLINKS\*Steps only the highlighted one you have to change as per mxe.doclink.doctypes.defpath.

    You have to change the default path for all the folders.

    Then upload a new doc and try to open, It works.

    Thanks,
    Srinivas