Topic
6 replies Latest Post - ‏2013-01-16T16:51:47Z by SystemAdmin
SystemAdmin
SystemAdmin
47293 Posts
ACCEPTED ANSWER

Pinned topic No output coming from mt sync -imp

‏2013-01-14T21:34:28Z |
Hello,

I'm having an issue importing a sync packet on a CC server running CC v7.1.2.4. The sync packet was created from a server running 7.0.1.2.

Unfortunatly when I run "multitool sync -imp <packet>" I don't get any output from the command. The packet is NOT deleted from the incoming bay, the oplogs are not updated, and the exit status ($?) from the command execution is "1".

I do get an output from other packets that successfully import or a failure for example from a user who does not have sufficeint permissions to import.

No obvious errors are in any of the log files. Receipt handler is also failing but gives little clues on the problem at hand.

Any suggestions on how I can see the failing output?

2013-01-14T14:47:05-06:00 shipping_server(22237): (client=vob05): Error: receipt handler for shipping order file "/opt/rational/clearcase/shipping/ms_ship/outgoing/sh_o_sync_foo_vob_2013-01-15T02.16.45+05.30_4714" returned bad status 2
Regards,
Eric
Updated on 2013-01-16T16:51:47Z at 2013-01-16T16:51:47Z by SystemAdmin
  • brcowan
    brcowan
    719 Posts
    ACCEPTED ANSWER

    Re: No output coming from mt sync -imp

    ‏2013-01-15T16:51:37Z  in response to SystemAdmin
    Is this problem limited to this specific packet? Or is it all packets? if the latter option, have you had the sending site resend the packet?

    =================================================================
    Brian Cowan
    Advisory Software Engineer
    ClearCase Software Advisory Team (SWAT)
    Rational Software
    IBM Software Group
    550 King St
    Littleton, MA 01460

    Phone: 1.978.899.5436
    Web: http://www.ibm.com/software/rational/support/
  • SystemAdmin
    SystemAdmin
    47293 Posts
    ACCEPTED ANSWER

    Re: No output coming from mt sync -imp

    ‏2013-01-15T17:43:51Z  in response to SystemAdmin
    EricW14 wrote:
    > No obvious errors are in any of the log files.

    Including in the sync_import log on the vob server?
    ct getlog -host <vob srv> -last 5 sync_import
    

    Could setting TRACE_SUBSYS="*" and TRACE_VERBOSITY=4 help?
    Marc
    Updated on 2014-03-26T13:43:54Z at 2014-03-26T13:43:54Z by iron-man
  • SystemAdmin
    SystemAdmin
    47293 Posts
    ACCEPTED ANSWER

    Re: No output coming from mt sync -imp

    ‏2013-01-15T19:08:32Z  in response to SystemAdmin
    It's all packets for this one vob. I have tried resetting it and sending new packets, same issue. Other vob sync packets are importing fine on the server.

    The sync import logs just state a failure with the error, no error message.

    The increased trace verbosity has produced some output. I will go through it to see if I can determine a cause.
  • SystemAdmin
    SystemAdmin
    47293 Posts
    ACCEPTED ANSWER

    Re: No output coming from mt sync -imp

    ‏2013-01-15T19:37:53Z  in response to SystemAdmin
    From the output of the increased trace verbosity I get only get 2 somewhat meaningfull messages....

    >>> 13:05:12.537 (multitool): /vobs/multisite/etc/synctool/vob_st_import.cxx:50: operation 'import_job.execute' failed: unable to replay VOB operation because of missing input.

    multitool: Error: /vobs/multisite/bin/multitool/ms_cmd_replica.c:9159: operation 'ms_cmd_syncreplica_transport_api_with_legacy_support' failed: unable to replay VOB operation because of missing input.
    • brcowan
      brcowan
      719 Posts
      ACCEPTED ANSWER

      Re: No output coming from mt sync -imp

      ‏2013-01-15T20:42:01Z  in response to SystemAdmin
      What is different about this VOB?
      • Is it a different Feature Level?
      • Is it the only one getting an update from 7.0.1.2?
      • Does it have any other problems or oddities?
      • What does "cleartool lsvob -long" say about this VOB's "attributes?" Does it just say this:
      Vob registry attributes: replicated
      

      Or does it say more ("ucmvob" is ok, but anything else might be educational)

      =================================================================
      Brian Cowan
      Advisory Software Engineer
      ClearCase Software Advisory Team (SWAT)
      Rational Software
      IBM Software Group
      550 King St
      Littleton, MA 01460

      Phone: 1.978.899.5436
      Web: http://www.ibm.com/software/rational/support/
      Updated on 2014-03-26T13:43:50Z at 2014-03-26T13:43:50Z by iron-man
  • SystemAdmin
    SystemAdmin
    47293 Posts
    ACCEPTED ANSWER

    Re: No output coming from mt sync -imp

    ‏2013-01-16T16:51:47Z  in response to SystemAdmin
    Per IBM Tech Support's recommendation we upgraded our VOB server to v7.1.2.9 last night which has resolved this sync import problem that we were having for this vob. According to tech support there was a bug introduced in v7.1.2.2 that we had encountered. The bug was fixed in v7.1.2.7. I don't have any further details on the specifics of this bug at this time.

    Thanks for the help!
    Eric